Can't enter text. Keyboard shortcuts used instead.

This is a rather odd bug, and doesn't seem to always be persistent. After making a text layer it's often impossible to type in any text without the corresponding shortcuts being used. The text layer in indeed selected, and the text tool is highlighted.

For example, typing "hello" would select the hand tool, followed by the  ellipse mask tool, then set the video out-point. Quite annoying to say the least.

The issue does not seem to arise unless the viewer is floating. In fact, floating windows/tabs in Hitfilm 3 seems to be something testers have completely overlooked considering the space bar doesn't even play/pause when the viewer is floating and unselected. [An issue I already reported in the forum not too long ago.]

Thanks for taking the time to read my post. Aside from the few annoyances such as this, I'm super happy to have HitFilm 3 and I can't wait for future updates to correct things. Been a fan of FXhome since Vision Lab :)

OS: Windows 7
CPU: AMD Phenom II X6 1090T
GPU: Nvidia GeForce 760
RAM: 8GB

Comments

  • i have the same problem, Axel looking at my file , i hope i's gone get a solution...

  • Hi @LittleshyFIM yes that's something that we discovered before release but that is prooving rather tricky to fix. Unfortunately it won't be fixed in the first update but I hope to be able to solve that very soon.

    In the mean time, clicking on the viewer tab should give the correct focus (the tab itself, not the content, ie click on the "VIEWER" text).

  • edited May 30

    I have alot of complaints with the text editing in express 12 after not updating since november 2018.
    When editing text, the keys will often yet unreliably trigger their hotkey functions instead of typing the text. This even extends to the spacebar that unpauses the video. Sometimes it works fine, but eventually it will stop and i have to resort to copying older spaces.

    Is this issue relevant to other users? Did i do something wrong during installation?
    This was noticed when i was making text in a composite shot, and certain keys such as space would not type but unpause or do other things. It occurs most often after moving between the editor and the composite shot.
    Version: 12.1.8620.42247

  • edited February 25

    I o j k l  key doesn't work, too

  • Triem23Triem23 Moderator

    What's probably happening here is a behavior Hitfilm has always had, but recent changes to the Text engine are tripping users up.

    Hitfilm's keyboard shortcuts have ALWAYS been "panel sensitive." Which keyboard shortcuts are active is determined by the "Active" panel (last clicked on). 

    In older versions of Hitfilm one had to click in the viewer panel (making it Active) to place/create the text before typing. When the viewer is the Active panel there are no keyboard shortcuts. 

    Now that one can click the text tool and immediately type... Probably you have a different Active panel with shortcuts. 

    Click the Viewer to make it active and that should turn off shortcuts. 

  • edited February 25

    I have the same problem and the Hitfilm Answer above does not cure it.

    There is no way to make the viewer the active panel by clicking on it, at this time. It is becoming a high priority problem to me as I can only finish titles with quite more effort.

     

    Whether I click on the tab above the viewer panel or the text of a title in the viewer, hotkeys keep working.

    This has bizar consequences: for example I am typing in a text layer with no problem and then I use the space bar and this suddenly triggers 'playback'! Or I try to delete a word in the text layer with de 'Delete' button and this deletes the entire text layer, not the selected word.

    I've clicked everywhere I can think of, the viewer does not become the active panel, ignoring hotkeys.

    I use al kinds of tricks to go around it, like using control X to delete text or typing titles in MSword and then copy them into Hitfilm.

     

  • What does seem to work is using the pointer arrow in the viewer to select the text-block and then select the type tool. This does disable hotkeys.
    This is rather misleading because when you click on the text in the viewer with the type tool, you DO get a blinking cursor and are able to type text. In other words: all signs indicating you are working in an active viewer window, which only works as long as you do not use a hotkey.

    In the previous versions using the text-tool would automatically disable hotkeys when text in the viewer was clicked.

  • I believe this is an acknowledged bug, but I could be wrong. Regardless, this has definitely been a problem for me as well. My current workaround is to X out the Layer tab next to the Viewer tab on the top left corner of the Viewer Window. I have also heard that clicking on the Selection Tool, then back on the Text Tool before typing works well also.

  • Here is a 15 second video showing what I mean...

    https://youtu.be/aOvfVXo07WI

  • We are aware of this issue however it is not as easy to fix as one may think unfortunately. Hopefully we will fix this soon. Thank you for reporting it.

  • edited February 27

    Personally, I have to use other programs like Photoshop CS6 and saving as .png  or using Cinema 4D and exporting with alpha channel. So much easier than trying use the infuriating  text options in Hitfilm which I though they had properly implemented in release 12. Can't get text to overlay video footage.... sigh.

  • @FilmSensei

    "I have also heard that clicking on the Selection Tool, then back on the Text Tool before typing works well also"

    I love you senpai

  • @Dimipapa I am glad it works for you! :)

  • I have this strange issue that I don't have with anything else other than hitfilm pro 12.2 (think with 12.1) as well.

    Certain keys suddenly stop working O

    Pressing space bar makes it plays the clip rather than add a space.

    To fix, I click save, close and reopen.

    It can happen again in a short time or go away or hours.

    I have delete cache etc and done a save as etc.

    Happens with  brand new projects as well as save as copies.

  • It's a bug with the hotkey shortcuts that will hopefully be fixed in the next update.  I heard a couple fixes from a post from filmsensei, I know one was to click the mask tool then click the text tool again and then it shouldn't happen.  There was another fix, see if this one works for you if it doesn't I'll dig up the post.

  • As long as its reported and in the bug fix pipeline that's good enough for me.

    Cheers

  • Ha! This is pretty horrendous actually. None of the work arounds work for me.

    I'm literally typing up my text on a notepad and then pasting them into the text layers.  

  • Having the same issue....I tried the film sensei fix.....tried all of them....and still nothing. The only thing that has worked it to type it and cut/ paste it....or shut it down and try to restart it 

  • Having the same issue......tried the sensei method......didn't work.....I am now cutting and pasting to make it work .......any hope on the bug fix? 

  • Thank god I found this.....I am still cutting and pasting, these issues have persisted....any update on the bug fix? 

  • @CedricBonnier Has this issue of triggering shortcuts while typing text been addressed in HitFilm Pro 13? I find no mention of it in the release notes, but I can't seem to replicate it in Version 13 like I could in the video above. Thank you in advance for your answer.

  • @FilmSensei ; I thought it had been fixed a while ago but maybe it came back. I'll have a look when I get a chance. Thanks for the heads up.

  • edited November 16

    I had this problem, and my solution was just type the text elsewhere ie. in notepad or sticky notes and then copy and paste from elsewhere into the Hitfilm composite textbox. 

    This doesn't resolve the underlying problem, but is a simple workaround. Just thought I'd share for the future people who find this thread.

  • @YeahRighteousness that is a suitable solution for the problem, thank you for your suggestion.

    I will now close this thread, as it is quite old and there are valid solutions/the issue has been fixed.

This discussion has been closed.