3D objects - am I doing it right?

edited October 9 in HitFilm Pro Support

Hi Team

I'm trying to put together a video which uses 3D objects of an iMac, a phone and a tablet that I've found from various online stores. I'm brand new to working with 3D objects but the questions I have are:

1) What is the best way for me to put screenshots on the screens of these devices? I don't see a way to do it via the properties for the 3D objects, so I've been importing screenshots as a separate 3D layer, positioning them "on top of" the screens of the 3D objects, then parenting the images to the 3D objects. It feels like there is a better way to do it, but I don't know what that is.

2) Sometimes I am seeing glitches when I render scenes where I've animated the objects moving and/or the camera moving. For example, when the camera pulls back, the iMac's pedestal disappears and surface "tears". I even see the pedestal disappearing on the 3D object when in perspective view as I scrub my way through the timeline.  The problem goes away if I make the objects '3D plane' instead of '3D unrolled' but I have been adding them as '3D unrolled' layers as this makes placing them in 3D space using the perspective / top / left view possible. Am I doing this wrong?

Comments

  • edited October 9

    An example would be helpful

    Try this workflow. 

    • Import iMac screen model in a new comp. Name it iMac or whatever. Unroll the model. Just leave it facing you and a proper scale.
    • Import the video you want into this comp. Turn it 3d
    • Add camera 
    • Make a point and turn it 3d. Parent the model and the video/photo to the point.
    • Resize/position the video/photo down to fit your screen 
    • Add lights to make it look realistic
    • In materials of the video you turned 3D turn off receive shadows and illumination.
    • Make a new comp and put the first comp into it and then unroll it. Add a camera
    • Add a point. Parent the point to the Unrolled comp you just brought in.
    • In the Layer Properties of the unrolled comp you made check mark Promote lights
    • Use the point to control the rotation, position and scale of the model
    • Animate camera/objects to your liking

    Whala . The video/photo stays positioned to the 3D model screen no matter where you move/rotate the point.

  • @GrayMotion ; Snagged that nice recipe of instructions for my archive!  

  • edited October 8

    @tddavis - I actually figured this out via @Stargazer54 :-)

    https://youtu.be/cwvPt9vL68w

  • @GrayMotion - Thank you for the advice. I have re-engineered my scene to match your instructions, creating composites of each of the iMac, Phone and Tablet, adding those unrolled to an overall composite and using points to keyframe the objects movements.

    Unfortunately I still have similar results with the iMac - see below rendered output:

    https://youtu.be/amTeZfqBQIk

  • edited October 9

    stevens - 

    I cannot reproduce that. I animated the camera  (pull away) and then animated the object  (push back via a point).

    It looks like the two phones in front are clipping the rear object though. The left card (looking straight on) appears to  be clipping the edge of the model (screen).... You can also see the edges of layers? with both mobiles as they turn in. Small dotted edges along the monitors face from both sides.

    Does the problem exist if you turn off/remove the phones?

    Not exactly sure how your setup looks though.

  • Triem23Triem23 Moderator

    Where is your source model from (and is it paid or free?). Often a user will run into similar rendering glitches and it turns out the issue is bad model geometry. Usually that manifests as a "black flicker" or a "transparent dropout," not a "white flash," but its something to ask.

    Are your GPU drivers current? It's surprising how many errors come from old drivers.

    https://fxhome.com/faqs/view/10

  • @stevenz it looks like the polys on your model could be clipping. Whilst I wouldn't expect this with a paid model, it's still possible. This is due to two polys being located so closely together that the renderer cannot decide which of the surfaces it is meant to be rendering. You can adjust the clip planes on the camera in HitFilm to help fix this.

    Right click the camera and select Properties. From here you can adjust the near and far clip distance. If you reduce the far clip distance you will give your scene more precision which should help the GPU decide which poly it should be rendering.

  • Yeah,  the "flash" on the Left of the monitor model definitely looks like co-planar polys.

  • I can actually reproduce this. I found an iMac model with 2 layers, body and screen to do a test with. I'm sure not a perfect match to @stevenz's iMac but should work as a close comparision 

    When the Camera dolly's the clipping? appears...when it zooms it appears ok. Adjusting the cameras clipping distance has no effect.

    https://www.youtube.com/watch?v=9LIMDzg_aMU&feature=youtu.be

     

  • edited October 9

    @GrayMotion - no the objects in front aren't clipping - screenshot below shows the 'Top' view of the setup (edit -- I would, but I'm not sure where to host one without some further research since you can't upload an image. Recommendations?).

    @Triem23 - The model was free (we have limited budget!) but unfortunately I can't remember where I found it. Perhaps it is just a bad model as I haven't seen this issue with other models including the two other objects in this project.

    A question though regarding the method @GrayMotion recommended of making each model its own composite -- I can't seem to apply motion blur now. I can turn the icon on, but there's no motion blur effect being rendered. Is there a workaround for this?

    @TheBenNorris - The current clipping settings are Near: 1.00 and Far: 100000.00. I'm new to this so I'd need your advice on what to adjust it to, and whether these adjustments might have any other impact on the rest of the project? Having said that, if the model is indeed bad maybe I should just replace it. 

    Interested to know from the group what your go-to place for 3D models is?

    Thank you all so much for your time and patience.

  • @stevenz ; Free account at Dropbox works pretty good.  You can't see the image only a link but that's just a small click away.  And I think there is a way to take the dropbox link and change it with another free online service to be able to see the actual image...I'm not certain since I don't use it but I think it might be IMGUR ...or not :)

  • Update -- I re-rendered with the phone / tablet hidden and now the glitches with the iMac are gone. What does this mean?:

    https://youtu.be/34iY0Yu6Ad8

  • @GrayMotion ;  Your Mac has got some serious issue in the Dolly portion.  Looks like hackers are trying to get in :) that or Skynet is taking it over.

  • edited October 9

    "I can't seem to apply motion blur now."

    Add a grade layer in the first comp above everything (iMac screen) . Add the effect Motion Blur to the grade layer. I used Mode: Custom . You can use custom properties and set your  own Angle and  Phase  if you don't like the comp settings look. You should now have motion blur in your main comp

    Now...I see turning off the phone and tablet took the "clipping" problem away. Now I'am back to the thinking the models layers clipping each other? That's a question for the Devs really. 

    EDIT: There is a caveat using motion blur in the fist comp though. It effects the video. Add the Grade layer above the model and lights (if you have any) but below the video/photo . I had to keep the shutter angle 20 or less. There might be another way to do it but I'm a bit tied at the moment. Maybe someone with better knowledge than I can chime in...in case I'm eating carrots when I should be eating potatoes 

  • Update for you -- I replaced the iMac with a different object of a generic monitor. I saw exactly the same tearing / glitching UNTIL I changed the animation of the phone and tablet so that they do not rotate as they ease into place.

    I then went back to my original iMac scene and removed the rotation of the other objects and again the issue went away.

    So I'm not sure why, but these objects rotating cause the other object to glitch / tear. At no point do the objects intersect as they rotate. Is this a bug?

     

  • @stevenz the removal of the models adjusts the precision of the z-buffer which could be removing the tearing. I'd suggest sending us a support ticket if you're happy to send the project file so we can investigate further. I would try reducing the far clipping distance to something such as 1,000 and trying that first however.

Sign In or Register to comment.