New machine, can't see added TT Fonts in Pro 11

On my old machine (win 7) I had added TT fonts like Arubesh and Star Vader and they worked just fine in Hitfilm Pro 11.  I just added the same fonts in the new machine (win 10) and while they show in stuff like Microsoft Word OK...... they are not on the font list in Hitfilm.   What's up?

best,

.....................john

Comments

  • @JBaymore ;

    You may have already done this, but have you tried restarting your computer after font installation? You might also try clearing the cache in Hitfilm’s settings, or repairing/reinstalling Hitfilm.

  • Thanks.  Installed in Win 10 Pro "for all users".  I've tried cold reboots and also re-starting Hitfilm Pro.  Haven't re-installed Hitfilm.

    The bizarre thing is that it shows up in other programs like MS Word.  Just not on the Hitfilm "menu" options.

    Some fonts do get added to the list..... but some don't.  And this is a True Type font (ttf).

    best,

    .....................john

  • "The bizarre thing is that it shows up in other programs like MS Word. "

    Not bizarre. In my experience, Hitfilm font support is/(can be) quite sketchy. Bizarre in that your old machine worked with the exact same font file(s).

    You stated you've done this, but make sure that you install fonts for all accounts/users. Account installed fonts is a relatively new Windows 10 thing. Some apps can have problems with account installed fonts. e.g. Resolve had this. Not sure if they have fixed that yet.

    What text feature is having the problem? There is a difference in font support and/or enumeration between the features. There is the text layer/clip feature and the various text effects (text, credit crawl, etc). Or maybe both text features have the issue?

  • @NormanPCN ; Some of the added fonts that worked on the other win 7 machine worked Ok on this one and finally showed up in Hitfilm (already showed before that in Word) after a cold re-boot.   But some don't show.

    I'll play with a clip and see if they appear in the pull down list in the varius "text" locations and get back to you on that.

    best,

    ......................john

     

  • @JBaymore Could you please send us the fonts that do not work for you? I've just tried to install Star Vader and it works fine as far as I can tell. Maybe your font file was corrupted?

  • Finally got Star Vader and some Arubesh working.  Couple of restarts of the machine before it showed.  I still have one font (that I know of) that is not.  Will get it to you.  Thanks.

    best,

    ................john

Sign In or Register to comment.