Composite shot layers can't be fully muted

Bug #1: When I bring the audio level of a composite shot layer to its minimum, -60db, I can still hear it faintly when turning up the volume of my audio interface, and in some instances I can still hear it at normal volume. Please fix this because I need to be able to fully mute composite shot tracks!

Bug #2: why don't composite shots show their audio waveforms/visuals in the editor like normal files do? This is annoying because I use composite shots when I could just be using files in the editor to simplify the editing process, but not being able to see the audio is annoying.

Bug #3: When I switch from the slice tool to the selection tool, it often doesn't switch cursor icons, so I might try to slice something and find it to just select it because the cursor was still the slice tool cursor. I noticed that this doesn't happen when I use the keyboard shortcut but usually does happen when I selected a tool with my mouse. This is annoying and can cause me to undo an action when I don't need to.

PC Specs: Acer Aspire VX5

(Laptop) Intel Core i7 7700-HQ 2.8Ghz

(Laptop) Nvidia GTX 1050Ti

16GB Ram

256GB SSD

2TB HDD

Hitfilm Express 12 4/17/2019

Comments

  • edited April 17

    #1. Use layer properties. If you are talking about composites, or media, on the editor/nle timeline, then where you do not want audio simply cut those portions out. Or you can always stack audio levels. Add an audio levels effect and lower that.

    IMO. Hitfilm levels should jump from -60 to -infinity (aka mute). One more level beyond -60. It poor form not having this.

    #2 

    Waveforms cannot be shown if the audio does not exist. Audio does not exist until it is rendered. A composite shot is not rendered. It is rendered on the fly frame by frame during playback. In a media file the audio does exist. If a composite shot is pre-rendered then the audio does exist.

     

  • @GoldBlane

    Bug #1: When I bring the audio level of a composite shot layer to its minimum, -60db, I can still hear it faintly when turning up the volume of my audio interface, and in some instances I can still hear it at normal volume. Please fix this because I need to be able to fully mute composite shot tracks!

    This is not a bug. Reducing the audio level does not mute the audio. Right click the layer, and in the options menu, tick 'Mute'. There is also a mute option in the control panel.

    Bug #2: why don't composite shots show their audio waveforms/visuals in the editor like normal files do? This is annoying because I use composite shots when I could just be using files in the editor to simplify the editing process, but not being able to see the audio is annoying.

    This is not a bug. We do not generate waveforms for the composite shots on the editor because it would require all of the audio to be sampled, potentially for every frame, for every comp within that comp. Remember comps can be nested within comps without limit.

    However, if you pre-render the comp (right click the comp in the media bin), a waveform will be generated which will be displayed in the editor preview.

    Bug #3: When I switch from the slice tool to the selection tool, it often doesn't switch cursor icons, so I might try to slice something and find it to just select it because the cursor was still the slice tool cursor. I noticed that this doesn't happen when I use the keyboard shortcut but usually does happen when I selected a tool with my mouse. This is annoying and can cause me to undo an action when I don't need to.

    This is an intermittant issue that we've not been able to get to the bottom of. You might find the slice keyboard action to be more useful than the tool mode.

     

Sign In or Register to comment.