Audacity/Gsnap

edited March 30 in Everything Else

I have been trying to use audacity as my audio editing software and i found Gsnap as an auto-tune plug in. but i can't seem to get it to work.

someone help me please... 

MOD EDIT: Fixed image link

Comments

  • I tried uploading my screenshot but it doesn't work, but it says.. "Effect at  C:\Program Files(x86)\Audacity\plug-ins\GSnap.dll failed to register : Could not load the library"

  • Aladdin4dAladdin4d Moderator

    I copied gsnap.dll to "C:\Program Files (x86)\Vstplugins", the normal location for 32 bit VST plugins. Then I started Audacity and went to Effect-->Add/Remove Plug-ins to open the plug-in manager, scrolled down until I found the entry for Gsnap. The state was listed as "New" so I highlighted it, clicked Enable then OK and it appears to  be working.

  • For me, it does appear but when I hit on enable then ok then that message pops up 

  • Firstly, i installed everything with 64bit and "C:\Program Files (x86)\Vstplugins" does not exist for me..

  • Aladdin4dAladdin4d Moderator

    "Firstly, i installed everything with 64bit"

    Audacity for Windows is 32 bit only so you need to make sure you're trying to use the 32 bit version of Gsnap or it won't work. 64 bit Audacity is only available on Linux. 

    "C:\Program Files (x86)\Vstplugins" is the default location for 32 bit VST plugins. If you use other VST plugins that have an installer, that's where they'll end up. Since you don't have that folder yet, you can create yourself and Audacity will find it. It's a good idea to keep VST plugins there because that's where other VST capable programs are going to look for them. 

  • Does that mean I have to install both 32bit audacity and gsnap for 64 bit windows 10?

  • Aladdin4dAladdin4d Moderator

    Yes, Audacity 32 bit and Gsnap 32 bit on 64 bit Windows

  • How do i get audacity to find it? i created the folder. but under effects, add/remove plugins, new, gsnap still shows up under C:\Program Files (x86)\plug-ins\GSnap.dll

  • I'm still not sure what im doing wrong.. installed "recommended for most users" audacity, gsnap 32bit but the same message still appears once i try to install it in "C:\Program Files (x86)\plug-ins\GSnap.dll". Tried to create a folder but audacity doesn't seem to detect it. Removed Gsnap from "C:\Program Files (x86)\plug-ins\GSnap.dll" but it still sees it... what should i do?

  • Aladdin4dAladdin4d Moderator

    Well it should be "C:\Program Files (x86)\Vstplugins" not "C:\Program Files (x86)\plug-ins" like you just posted so make sure that's right first.

    To reset the Audacity plugin cache, you need to go to "C:\Users\YourUserAccount\AppData\Roaming\audacity" and delete pluginregistry.cfg. Once you do that and have gsnap.dll located in "C:\Program Files (x86)\Vstplugins" Audacity will find it and make a new pluginregistry.cfg the next time you start it.

  • tell me where i went wrong.. this what i did in order..

    uninstalled everything.. (audacity, gsnap)

    removed pluginregistry.cfg

    reinstalled audacity

    downloaded gsnap 32bit

    made a folder in C:\Program Files (x86), and named it Vstplugins

    extracted gsnap 32bit

    dragged gsnap.dll into C:\Program Files (x86)\Vstplugins

    started audacity

    and it  doesn't show under new.  i also think that audacity doesn't see the file.

  • nevermind, i duplicated gsnap, dragged it into C:\Program Files (x86)\Audacity\plug-ins then it appeared and it worked.

     

    Thanks for baring with me and offering your support. :D

Sign in to comment

Leave a Comment