Anyone Else Have HitFilm 2017 Pro Quit Working on Win10?

edited November 2017 in Pro Support

I've been fighting all night and now four hours through morning to get HitFilm back working. Kept getting a grey, then a blue screen hang. Uninstall, reinstalled x2. No deal. Did system restore, did a registry clean, you name it I did it. Finally, I right clicked the install .exe after the third clean install, and, instead of choosing repair, I chose Troubleshoot, and Windows set it to compatibility with Win8. Now it's working again. Don't know what happened, but I'm telling you that this was a VERY unpleasant experience, especially since I'd just been using it not a half-hour previous to it crashing. Just an FYI post, kind of hoping that somebody around here can tell me WTF happened. I have auto-updates on Windows 10 shut to Business level/Critical Security Updates ONLY to avoid MicroSoft-in-the-Head's "try-it-on-users-to-beta-test" BS, but I'm about ready to shut all updates down. I haven't been warned of any updates, not that they'll honor that setting, but, geez. This is not a fun game, at all. Any thoughts on what happened to my HitFilm 2017 Pro install last night?



  • Okay. STILL having problems. It throws an error every other time (about) that it's opened. If the HitFilm front page with all the linked in YouTube-ish tutorial advertising comes up, then it's okay. But half the time, about every other open, it doesn't get that far before throwing a Windows error that, if you hit debug, gives a command prompt black screen for half a second which then disappears, and the program closes. This is UNacceptable and driving me nuts. I really don't want to have to be reduced to only using my Win7 machine. Really.

  • @DLKeur I'm sorry you are having trouble with HitFilm. I was under the impression after reading your first post that your machine was bluescreening but that is not the case is it? The issue is that HitFilm crashes on startup, correct?

  • No, @CedricBonnier , this wasn't the Windows Blue Screen Of Death.  It was HitFilm gray the first couple of times, then a swirly blue screen subsequently if I tried opening a file instead of using the HitFilm shortcut. That was before I did all of the above mentioned in the first post. Now, what happens is: As HitFilm loads, before the file history loads and before the Internet YouTube ads screen loads, an error window comes up advising me that the program isn't working correctly and has to close, with the option of close or debug. When hitting debug, a Command screen blitzes up, loads up a bunch of debugging hash for a split second, too short to see, then disappears along with HitFilm.  I was able to get HitFilm to come up this morning the third try, and breathed a sigh of relief when on that third call the file list loaded in the left page and the Internet YouTube ads/tutorials right page came up. I don't know if I should try setting compatibility to Win7 or what. I do know that I haven't had this problem before last night, and nothing on the machine changed ...that I know of... (but realizing that Windows does stealth attacks with updates without notification that could have changed something)!

  • edited November 2017

    And further problems ...the same thing that started this whole problem last night. Trying to drag mp4s onto the timeline or even along the timeline gives me this pale blue full display screen and hangs. There's no escape, no outwaiting it. Not even CAD works, and I have to do a hard shut down. This can't go on.  I'm reduced to having to go back to my Win7 machine, I guess. This is way beyond my pay grade to fix. 

  • Not even CAD works

    So you're having issues with other software as well? If you go in the controls panel > Programs > Programs and Features, have you got any software that installed since it started going pear shape?

  • No. It's a HitFilm thing. I've looked at the error reports and logs. But that's okay. No worries. If it's broke on Win10, I know better than to bother using it on Win10. Back to Win7. Thanks for all the help.

  • We tried HitFilm with multiple versions of Windows 10, including the latest Fall Creators update but unfortunately we cannot reproduce the issue.

    The fact that it suddenly started crashing without any updates to HitFilm indicates that something else must have changed (could be a sneaky Windows update as you pointed out). Have you tried to run all the Windows updates? Maybe Windows installed only some updates but more are required to work properly? I'm just speculating here but it isn't great that you cannot use HitFilm on your Windows 10 machine, sorry about that...

  • Be that as it may, the latest greatest build of HitFilm Pro 2017 works fine on my Win 7 machine. I've done a full diagnostic on the Win10 from the command line, looked at all the events, and the only critical events were involving instances of loading HitFilm. The only changes to the Win10 machine showing in the logs was a sneak Win10 update that happened Tuesday. Those are the only changes and events. GoPro loads and works fine. Cineform works fine. Photoshop, local build, works fine. GIMP, Bryce 3D, Blender, DogWaffle, etc., etc., etc. Nothing shows up in the error logs unTIL I try loading HitFilm, and then only when it fails to load...which is two out of three times on average, now. But, like I said, the Win10 was bought because I needed something to access the Internet. As long as the machine can do all its other work, like recording the burn direct from camera, I'll just stick with Win7 for HitFilm.  

  • edited November 2017

    One more thing just came in via email. According to a tech I had look at the results, he says that it is a Win10 problem causing a critical event in the kernel, and that, in the last 24 hours, he's seen it in two other hot ASUS machines running Core i 7. He "thinks" its a Microsoft problem, not a problem with the games and programs that are bringing about the "event".  So, being me, I'll wait out the storm and will guess that in two or four weeks time, MicroSoft will come out with a sneak patch.

  • @DLKeur Have you considered updating the BIOS? My first thought on seeing a total of 3 Asus machines exhibiting the same problem that other Windows 10 machines aren't would be it's something to do with Asus, not necessarily Microsoft. Checking on what I believe is your motherboard shows a recent BIOS update. 

    Version 3504 08/18/2017 

    1.Update new CPU microcode
    2.Fixed Raid Card issue.
    3.Improved system stability and performance.
    4.Improved VGA cards and storage device compatibility
    5.Fixed KB/MS devices issues
    6.Fixed Plextor device issue

    1,3 and 4 could all relate to what you're experiencing. There's also an Intel Management Engine security patch that dropped today.

  • edited November 2017

    Well, I've not got a clue about this stuff, @Aladdin4d . And the fact that it started the evening of November 7th to me is suspicious since nothing else on the machine had changed. One would think that a stable machine, running just fine wouldn't suddenly freeze up when an mp4 is dragged across the timeline of HitFilm, when, a half hour previous it had no issues ever doing the same exact action and ones even more extreme in HitFilm.  As to updating/patching the bios, that scares the hell out of me.

    ADD EDIT since it won't let me post again: using msinfo32 on the command line gets me BIOS VERSION: American Megatrends, Inc., 3401

  • @DLKeur I don't doubt something from Microsoft slipped in but it may not really be or entirely be Microsoft's fault. There was a hyperthreading bug found in Skylake and Kaby Lake CPU's earlier this year. The microcode update in the BIOS update probably contains Intel's fix for it. Microsoft may have pushed out something in response too but if they did, there's no way to know for sure if it depends on the new microcode or is an attempt to work around the bug regardless of the microcode. 

    Updating the BIOS should be pretty easy. You should have the Asus EZ Update utility and that should handle updating the BIOS through Windows. You let it do it's thing and reboot. You can do it from the BIOS too. Download the update and get it unzipped on thumb drive, reboot to the BIOS and look for Asus EZ Flash. It should be in the advanced mode under Tools. Last but not least, you have a dedicated USB port and a button on the back just for doing BIOS updates. This time you get the update on a thumb drive and rename it to M8I.CAP. Shut down the system, put the thumb drive in the right port and press the button for 3 seconds then wait for the BIOS LED to stop flashing. Here's a generic video:

    And this should be the back of your board showing the locations of the port and BIOS button.

  • edited November 2017

    @Aladdin4d : THANK YOU. That helps.  I will use your info.  But, you know, I haven't flashed a bios in like two years or monkeyed around in one with settings in four. I gave up on that stuff after Vista and hired experts to do it. Well, husband is a tech and a good one, though, like me, he quit keeping up on stuff when things began getting specialized. If and when he gets home (he's drives semi-s now to put food on the table), I'll let him wander through that process. I'm way too fragile stresswise these days to deal with this stuff, which requires my analytical, mathematically-oriented, pragmatic brain in charge, not my emotionally wacked out right hemisphere. I'm still trying to get a handle on me after Mom's death, so way too ditsy to deal with stuff that requires a grounded, rational mindset. 

  • Okay. Back again, @Aladdin4d . Motherboard: ASUS ROG MAXIMUS VIII IMPACT LGA1151 Mini ITX DDR4  And then the bios says it's the American Megatrends, Inc. 3401.  So which bios update should I try? And, IF the whole thing goes black, then what?

  • Alright. And, @Aladdin4d , this is what I have under ASUS on the computer. Which one is supposed to be the EZ bios thingy?

  • @DLKeur Ok so you want 3504

    It's from this support page:

    Choose your OS then expand the BIOS by clicking the See All Downloads link underneath the BIOS box. Hopefully that makes sense when you see it ;)

    Your current BIOS is available there too.

    If the whole thing goes black DON'T PANIC! Asus developed the whole dedicated flash port and button thing just to recover from a bad flash so all you have to do is follow the steps using the 3401 BIOS to get back to where you started. 

  • edited November 2017

    I'm already panicking, @Aladdin4d . I like computers to stay stable, no messing about, just work with them until they die ...and mine usually stay running for decades. Seriously. I've still got a Win3.1 machine and a Win95 and a Win98 that are running just fine. I threw away a working Windows ME machine. In fact, my old 285 still boots and runs. All my XPs boot and run, as does my one Vista laptop which I still use for some graphics work using a hand-built fractal program. My Win7? Perking right along now that I completely shut off updates last March. This mucking about stuff is what I hate. I want a stable system that I don't have to muck about with. Seems to me that I'd probably have to have an in-house tech to keep this Win10 working, so I may just haul it to the dump. Wish you lived nearby.

  • Went to the link provided, @Aladdin4d . Geez. They've got a MILLION downloads for everything Win10 64bit. Geeyads. And NO instructions on how-to. I think I need whisky.

  • @DLKeur I wish I was closer too I could go for some whiskey!

    There's a lot there you can ignore. Windows Update will provide stable drivers for most things like anything Intel which includes your chipset, wired and wireless networking, rapid storage technology and the integrated GPU. 

    Bluetooth - Good idea to use the one here. I'm not sure if Windows Update carries drivers for Asus' own bluetooth and the stock Windows bluetooth is meh.

    Realtek Audio - What's here will make sure everything implemented by the motherboard gets enabled but that doesn't mean that's the most stable way to go. You can force Windows to use its own generic HD Audio driver and it'll work and be stable, but you'll lose a lot of functionality. The Realtek drivers distributed through Windows Update or direct from Realtek will be pretty stable with more functionality but might not cover everything the motherboard is capable of. This is one you have to make a judgement call on.

    That leaves the Management Engine update that dropped today. It's a firmware update that should fix some serious security holes but you might not want to do it. The reason why not is a little involved.

    Intel's ME is a CPU and OS that runs hidden on the main CPU. For administrators it provides some great remote management tools. An admin can check and see what's going on with the hardware and what state the system is in by remote regardless of what state the system is actually in. Put another way, an admin can check on something without the system being fully on or booted or ever giving the end user any notification that something is going on in the background. It's a closed system and Intel has taken great pains to keep the internals of how it works top secret. Earlier this year somebody figured out a way in essentially unlocking a God Mode. If you wondered how the NSA pulls off its hacks and infiltrations, many of them are probably through the ME.

    While they were poking around, security researchers found a way to turn off the ME. Not completely mind you, that can't be done fully because the ME is responsible for some low level bootstrapping, but close enough that it makes a system a lot more secure. The ME firmware update probably closes the security holes found by the researchers which is a good thing but with the way the world is today it probably removes the ability to shut down the ME too so you might not want to do it and opt for shutting it down instead.

  • edited November 2017

    And where do you live, then, @Aladdin4d ? I'll just ship the computer to you and you can fix it, then ship it back. I pay well.  Like I said above, this is way above my pay grade. Used to not be so, but that was back in the 90s and early 21st century. By the time we got to Vista I was in way over my head and knew it, so I quit, except for folks who insist I try to fix their systems ...which I manage, but just.

  • UPDATE: Well, it seems that it was some Windows update glitch, because last Tuesday, everything suddenly worked fine and there was an sneak update that happened. But Internet access tanked, so, while Hitfilm worked, wireless was spotty and slow. So Wednesday, mid-day, MicroMush again FORCED an update and everything was awesome. Hitfilm and wireless all stabilized.  Then, glory of glories, in comes a US Cert Advisory, and, yes, again, MicroMush decided they were forcing an update. And now I've got a weird beep happening ...sometimes. But wireless and hitfilm are both working fine. I'm beginning to HATE Windows 10 for this updating thing. I'd pull the computer offline, but I got it to be able to take my other machines OFFline. 

  • Hello. ever since I purchased pro my videos play back very distorted before they were fine?

  • JUst an update on my issue: I had my brand new computer torn down, reassembled, a brand new Win Pro 10 OS put on a brand new SSD drive with a secondary back-up drive, the old SSD drive now just storage. Uploaded HitFilm Pro 2017 and ... it works with a BUT. Here's the BUT:

    As I said in another thread, it tells me that hitfilmrenderclient.exe has stopped working and the program must close. However, upon hitting close, the program stays up (unlike the previous iteration of this problem) and then proceeds to work fine ...up through what little trial vid snips I've tried. 

    What is going on with HitFilm Pro 2017??? I'm not willing to purchase the latest greatest for more than half a grand more, first, Pro 2017 is plenty enough (super plenty enough) for what I need and when even that version, while working fine on my Win7 machine, is NOT yet working very well on my Win 10 Pro which I'm told by gamer friends and comp geeks alike (as they drool on my keyboard) is a pretty darn hot machine, now with a bought mint in box AMD Radeon 6900 series graphics card onboard. 

    You guys are still supporting this, aren't you? 

  • Hitfilm 2017, Pro or Express, was always working for me on Windows 10.

    Intel i7 4770k @ 4Ghz, 16GB ram, Win10 on an SSD 512GB Samsung 850 EVO, 1TB hard disk, Nvidia GTX 980 and then later a GTX 1080 GPU.

    "I'm not willing to purchase the latest greatest for more than half a grand more,"

    What costs a half a grand more. A Pro upgrade should be <= 200 USD from 2017.

  • edited January 7

    @NormanPCN : That's not what it offered me. I don't remember the exact number, but it was something like 566.+change USD. 

  • @DLKeur ; That's definitely got to be one of the bundles with VFX assets and such.  I upgraded from 2017 Hitfilm Pro during the November sale for somewhere around $168 (if I remember correctly) but that was just for Hitfilm Pro.  I didn't get the Studio package or anything.

  • edited January 7

    I have an AMD board and graphics card with the same issue of being unable to even open Hitfilm Pro 2017. I'd be willing to upgrade to resolve the problem for a nominal amount. That might be far easier than resolving a compatibility issue or alienating long-time supporters with statements like "I see you have an older version."

    I love you guys but let's make it right, quickly and efficiently, the most cost effective way.

    Forcing people to buy an upgrade from the very latest version at any price due to incompatibility issues is a PR nightmare along the lines of Apple slowing down older models.

  • Hi guys. Just to be clear, we do not intently break any old versions to make people upgrade.

    This seems like a new issue to me. @DLKeur if your system is well above minimum specs, HF5 should work. If it is not the case, please contact support.

    It is far easier to track issues on our support system compared to the forums, plus we can make sure that we contact everyone that was affected by the bug if we want you to try a fix or to notify you that it's been fixed.

  •  I didn't mean to suggest malfeasance. I just suspect that the time and expense of fixing issues for a small number of people might sometimes be outweighed by simply getting them up and running at a cost that makes everyone happy. ie. I won't care if you ever fix it if I got a deal that runs.

  • It will be a winblows 10 forced update.  they make updates for themselves not everyone else.  I just had one thrown on my winblows 10 system.  then suddenly forced shut downs into sleep mode. 
    What it screwed up seems to be the ACPI setting.

    I went into bios changed it from acpi 3 to acpi 1 booted up and crashed before i even loaded

    went back into bios and changed back to acpi 3 and booted up.  then shut down to get a clean boot (as winblows 10 has a fast boot option which you may want to shut off) waited about 5 min rebooted.  ran the machine for days before another issue

    what you're likely getting is a hardware issue as a result of the invasive Microcrap Winblows forced updates.  if you're willing to do so.  do a clean install and pull out the network cable so they can't send the crap through.  when i get a chance i'm formatting that system and it's going back to window 7

Sign in to comment

Leave a Comment