360video does not wrap around in Hitfilm pro 2017


I am a bit confuse here and I hope someone can shade the light on my small problem.  

I can import a 360 video and assign it  to a 3D plane but even if I apply the 360 video viewer or apply the 360 transform effect to my layer I can't  look around in my 360 environment. There isn't much info on the forum, on the internet or in the manual.

Is there a step by step guide to import a 360 video to be able to see it as it was created in VR360? ( Meaning  to be able to  see the layer in VR360 the same way as with the occulus rift or the  VR360 desktop) . At the moment, I can use Hitfilm to edit my 360 scenes together and it works but the main reason I bought Hitfilm pro 2017 was:

1-To add VFX to my Vr360 animation

2-To import a 360 camera real footage, use it as an  3D environment and add 3D character I created.

Thank you for your help!







  • Are you saying that moving/rotating the camera around is not moving across the 360 video?

    I don't have actual 360 video but I have used the viewer effect.

    Don't make the 360 video media a 3D plane with the 360 video viewer effect. Leave the plane with the 360 video viewer effect 2D. Also have that layer at the bottom of your visible layers.

    Then have a 3D camera and when you rotate the camera X/Y the viewer effect should adjust to the camera angle movement.

    You can stack layers using the 3D viewer. I've done that with a starfield as the base and planet layer(s) above that. All using the 3D viewer effect.

  • Hi Norman,

    Thanks for the quick reply, It works now.     You were right, the trick is to leave the 360 video in 2d, just apply the 360 video viewer FX and than create a camera. There is no option to create a 3D camera but there is no need to.

    This is my first post and I appreciate your support,

    Thanks again!



  • @jfrog ;

    You create a camera via the new layer button. The 3D viewer effect does have rotation properties and you can use those if you prefer.

  • Thank you Norman,

    I noticed that when exporting with the 360 viewer, it add some stitching artifact(line ) somewhere in the back . Not a big thing, I just uncheck the 360 viewer before exporting but is this the way to do it? 


  • Triem23Triem23 Moderator

    You need to adjust the scale ratio to eliminate the seam

  • It's an interesting area, I don't own a 360 camera but I have shot lots of panoramic shots in the past, and adding those to a 360 might create some interesting results.

  • "You need to adjust the scale ratio to eliminate the seam"

    Sorry, I am not sure I understand. Could you ellaborate please. I always have a seam when exporting with the 360 viewer.

    Thank you.

  • Triem23Triem23 Moderator

    First watch this tutorial m

    Environment Map Viewer is what 360 degree video viewer is called in Hitfilm before Hitfilm Pro 2017. 

    There is literally a control called "Scale Ratio" in the effect you will need to adjust. Divide the width of your 360 video by the height of the 360 video and input this number into Scale Ratio. This will probably fix the seam. 

  • Thank you for this great info, but changing the ratio to 1.777 (3840 divide by 2160) did not solve the problem.  I think that the process is a bit different then wrapping a 4k picure to a sphere, It seems that when an application already stiched a 360 video, it does not like to be stiched again in another app.  If I just edit the footage in HF Pro and export everything is great.




  • Triem23Triem23 Moderator

    Possibly true. I don't actually have any 360 footage, so I've only used the effect with still images and generated media. 

  • I will do more test in the few days and report back any change but thank you very much for your help.

  • Hi,

    I made a bunch of tests all morning and from my observations, I think the 360 video viewer is broken.  I  downloaded the "MetLife_Roof_pano" picture to simplify my test and basically if I import the picture and export it back without inserting the 360 viewer, I can see a nice 360 picture of the Metlife_roof. But as soon as add the 360 video viewer effect with the camera and than export , the result is a  zoom blured image with the stiched line problem.

    I mean from what I understand, it  should be quite simple to make it work. Add the picture to the composite shot, add the 360 video viewer fx than add the camera. My scale ratio is at 2 which should be the setup for a 4096x2048 image.

    Is there a specific place where I should post this problem to have this nice feature logged and fixed?

    Thank you in advance.


  • If you feel you have identified a problem then you can submit a support request.


  • Thank you very much NormanPCN. I will do that.

  • @jfrog did you get this working?

Sign In or Register to comment.