Playback stops as soon as I click on any controls

In other video editors, when I'm fine-tuning audio, I'd set a short loop and leave it playing while I tweak the controls (Equaliser, Balance etc.).

In HitFilm, it's almost impossible to do that because playback stops as soon as I click in the Controls tab to change something.  I have to do a click-Space-click-Space-click-Space thing.

I find it a pest when working with video filters but at least I can still see the effect of changes on the still frame.  It's absolutely infuriating when I'm trying to tweak the audio.

I stopped using HitFilm 4 Pro because of this behaviour, and I'm dismayed that it still seems to be how the 2017 edition works.

Does anyone know if there is an option or a switch that I need to set somewhere to disable this behaviour?  Am I missing something really obvious?

Thanks for any help.

Scott

Comments

  • Triem23Triem23 Moderator

    In Hitfilm 2017 use the audio mixer to adjust audio levels. Playback does not stop while adjusting faders on the audio mixer as shown here:

    https://www.youtube.com/watch?v=1Oi8Kkn_qZ4

  • edited March 2017

    Hi Triem23,

    Thanks for getting back so quickly.
    I know about the audio mixer, but it only seems to cover volume and balance.  I really need more in-depth control.  Mostly the Equaliser.

    The bottom of page 104 of the PDF manual suggests that extra effects still need to be customised via the Controls panel.

    (And, to be honest, I was hoping there was a solution that lets me tweak controls for video while it was playing back as well.)

    I can work around it by mixing the audio in other software - which might be a more sensible way to do it anyway - but I hoped I could switch off the auto-stop behaviour because it's the only thing that really annoys me about HitFilm, which seems really great otherwise.

    (edited to mention page 104 of manual)

  • (going offline now - back tomorrow)

  • I also hate this feature and would like it to be fixed. Even lowering my computer volume causes playback to pause. Like what the hell...

  • Also find this really annoying.

  • I also really  hate this feature. I like to click out of editor a lot its just how I keep motivated editing.  I hope they change this in the future.

  • same for me ... I have 2 screens, and when I run the video on the right screen, I use the left to manipulate the timelines, preparing the picture to embed when I pause (at the moment I arrive in the good sequence).
    With this autopause feature, I can not work properly. I'm wasting a lot of time, so I'm going back to Davinci Studio.

    I hate this autopause feature to.

  • +1 for changing this behaviour.

  • This "behavior" is also very annoying for me.  It makes me frustrated too when I am editing. 

    For Hitfilm staffs, please it will be very appreciated if you guys can make an option for people who does not want the playback to stop unless we hit the space bar or the playback stop button.  

    For Scottc (OP), thank you for posting this.

    +100 for changing this behavior. 

  • Add me to the list of those that support the removal of the auto-pause behavior.

  • It is quite bothersome. No word on whether this will even be changed?

  • I don't think it's a very high priority. I'm pretty sure one of the devs has commented about this in detail in some other thread, but I'm short on time to search, so I'm going to do my best to recall the reason.

    In short, this isn't some arbitrary decision.  If you click away from the main UI (or even in some parts of it, as has been mentioned), HitFilm stops playback just in case something has happened to one of the media files involved in playback.  IIRC I think it might be to prevent a crash due to attempting to access a modified/deleted file, but I'm not 100% sure on that. Perhaps @CedricBonnier could chime in to elaborate on (or possibly correct) my recollection of this reasoning?

  • Yes, we know it is annoying but we need to do more work to make sure everything runs smoothly before enabling that feature. We did turn it off for a reason. I don't think people would like HitFilm to be less stable just to be able to have this feature. Please be patient and it will eventually be done :)

  • It's nice to know that it's on the to do list.  As you say, stability must come first.  Thanks.

  • Yes unfortunately this is also the reason I moved away from using HE. I love everything about it but this is a deal breaker for me.

  • edited May 20

    @ecob What did you move onto because of this?

    Personally I find it a minor annoyance rather than a deal  breaker but we are, of course, all different.

  • @DafterThings My gut tells me that @Ecob will never reply.  They're in the ranks of forum users who join, make a single post on the same day they join, and never show up again. Not sure if accounts like this are real, or possibly someone's attempt at trolling the forum with negative comments.  Kinda feels like the latter considering how often it comes up.

  • edited May 24

    @jsbarrett ; I agree with your gut 100 %.  I have long suspected that there is concerted effort by a competing software manufacturer to take every opportunity to try and run Hitfilm down, and the sad part is if they put half the effort into fixing their own marketing snafu they would be better off.

  • @tddavis @jsbarrett ...and that is how conspiracy theories are born...

  • edited May 24

    @JMcAllister ; :)  I admit it.  I've been a "conspriacithist" since the late 70s.

Sign in to comment

Leave a Comment