Blender -> Hitfilm Presets Addons owmycgi.net : Design and VFX.

1454648505155

Comments

  • Wow! It just wasn't enough to get camera and empties into Hitfilm you had to go and bring particles into play as well. AWESOME! The RC is out for 2.8 so not much longer before the final and you won't have to worry about so many changes.

  • @FlyingBanana78 ,

    Yeah dude, I'll be stoked because coding won't take so long leaving more time for art and cooler stuff. oh and the hard surface Alembic animation stuff is working too.

    I'm pretty wired right now, probably too much coffee. I'm bouncing between building Filmer with todays 2.80.0 RC, Exporting Studio Product Shots, Cloth sims, Character animations, Hard surface animations and now Particle sims over to Hitfilm. Fractures, demolitions and somehow possibly... Smoke sims? :) 

  • Although this is just an experiment here is the Filmer particle simulation set up all pre-viz style in Hitfilm Express before sending the project over to Hf Pro for some nasty compositing.

    Possibilities ya'll. :)

  • @spydurhank ; Looking incredible.  I, for one and I know there are many others, am super excited for all the work you are doing with this.  It's really an stupendous advancement for Blender and Hitfilm connectivity!

  • Thanks @tddavis :)

    I've got it very close to being a drag and drop process which is simply sublime. :)

  • Hey guys, I'm uploading a Filmer release in about two hours with all the bug fixes including mesh export bug fixes up till today. There will be a short video with all the changes and additions.

    Worked a little on a new Filmer Splash Screen yesterday. Came out alright. :)

  • @spydurhank ; Looks cool in cap.  I wondered how much it was going to set you back when I saw Blender RC 2  this morning on Youtube. :)

  • https://www.owmycgi.net/filmer

    Not too, too bad @tddavis , just got it uploaded for you guys. :)

    Rc2 Filmer 7-20-19-a. Don't forget to un-install the old Filmer addons and install the new addons from this release as they have lots of bug fixes. :) 

    I may not get to the video so soon as I totally spaced and may need to go to the hospital with Courtney, she stepped on a screw yesterday so ouch. The in-laws were going to take her but I need to wait for everyone to wake up to be sure. She's just getting a shot so it'll be quick either way but in case I forget here are a few things to note..,

    There are a few Tools additions to the Hitfilm 3Dview panel that you can checkout. Just hover your mouse over the operator buttons for a tool tip.

    The Filmer viewport samples can be added to your final render which further speeds up render times by at least another 50% and higher when used along with denoising. Simply add any number value to the viewport samples to see them take effect on your final render. The higher the value, the longer the render time.

    Anyway, I'll be back after a while but I'm pretty sure that my mom-in-law is taking Courtney because they were going to run a few errands after they're done at the clinic.

    Frank

  • @spydurhank ; Ouch!  Tell her I feel for her.  Just got one of those last week after slicing the very tip of my finger off slicing potatoes of all things :)  No need to rush to get a video made.  We'll wait...

  • @tddavis Ow!!!!!!! I'm sorry about your finger but all I can think of is how I love potatoes so much. I've not met the potato that I didn't enjoy eating. But no, man oh man, your fingertip seriously ouch. :(

    Well, they actually just left to go be girls at the clinic so I'm free. I'll do a quick-ish video of the stuff I just noted in my previous post which will be at the beginning and should only take a handful of minutes like two or three minutes maybe and the rest will be showing you guys the works in progress for the alembic character animations with mesh deformations and Filmer particles in Hitfilm. This is only showing Hitfilm Express but works in Pro which I will showcase after Pro 13 is out of Beta. :)

  • edited July 20

    @spydurhank ; Don't know if anyone else has had a problem with the new Filmer download yet, but I can't seem to get it to open??  It starts and gets to that gray screen then just closes without any error message.  I'm going to redownload it in case I messed up somehow

    Yeah, just looked under the bandage and that finger tip is going to be a bit flat on one side from now on :)

     Edit:  Nope the redownload made no difference.  I tried to run as administrator just in case and that did the same.  Very weird...

  • @tddavis ,

    Check your video drivers, I'm not sure if that could be it because I was actually getting a crash just like that on yesterdays build but it should be working now as the Blender devs fixed something on their end.

    Does your download read Rc2 somewhere in the title of the website downloads page?

  • @spydurhank ; I checked the NVidia drivers and it says I have the latest 430.86 Studio drivers instaled but they are dated 5/27/2019.  I have both Blender RC 2 and Filmer Rc2 7/20/19 a.  I have just been unzipping them on the desktop and creating a shortcut to the exe cause I can't figure out how to properly install either since there's no installation file.  The RC2 Blender works ok...so far.

  • @tddavis ,

    Sorry about that, I just downloaded from my website and get the same crash as you so it is a problem with the download itself, gimme like 10 minutes please. :)

  • @spydurhank ; Ok, no worries.  I just tried switching back to Game Ready drivers for the NVidia and no change but they are dated 7/9/2019 I think I may stay with them a bit anyway.

  • The download is fixed, give it a go for me if you could @tddavis and sorry about the glitch on my side.

     

    Frank

  • @spydurhank ; No, I'm still getting the gray screen then shutdown even as admin.  Did you leave the version the same because what I am getting has the same name as the one early today if you did change it.  

  • Yeah sorry, I'm using the same name because there is nothing wrong with the actual Filmer RC2 release. It is the files in the zip that are being corrupted somehow during download. Either way it is an obvious bug and Blender 2.80 still has over 1200 unresolved  bugs. :(

    I tested with the original RC2 Filmer update from this morning and the files in the zip were indeed corrupted by the download but not sure at all as to how this happens so I replaced the old zip with a fresh brand new zip and now the downloaded version works again for me.

    I took these steps to verify and it works. I made a Filmer purchase on my site to test and downloaded the new zip file from the "thankyou" page and that Filmer works on my machine. I then also downloaded from the accompanying e-mail with provided link and this Filmer also works.

    Could be a browser issue? I'm on "Edge" and haven't tried downloading on other browsers. Just in case, I'll simply create a new product page for each new release update from now on but I'm pretty tired so maybe after some food I can take care of that.

  • edited July 20

    @spydurhank ; Browser issues sound plausible as I am using Chrome.  I'll give it a try with Edge, and don't think you need to apologize for keeping the name the same; I only asked to be sure I got the right file.  It's not a problem at all.

    Edit:  Nope that didn't change anything either but don't spend a lot of time beating your head against a wall.  Wait and see if the other testers have the same issue first.  It might very well be something wrong on my end here.

  • @tddavis , I indeed apologize and will do a better job at double checking that the downloads actually work as well as naming convention for each release.  

     

    Frank

  • @spydurhank ; Oh pshaw!  You do a phenomenal job.  I was adding to my above comment as you were leaving youors so see my edit above please. 

  • @tddavis , Gotcha and thanks. :)

    It is weird but I'm sure we'll figure it out and good suggestion about the beta testers so I'll tag them. @FlyingBanana78 @Graymotion @FilmSensei @Triem23 could you guys please download the latest Filmer and let me know if you have any issues with startup?

    https://www.owmycgi.net/filmer

  • I did a download of it and just a quick open before going to bed. This is on the laptop I got the same gray screen then it closes. When I get up in the morning I will bring it to the desktop and see if it does the same there. There has been a bunch of complaints about RC2 in forums and on FB saying that it is crashing like crazy and they have reverted back to pre RC as it seemed more stable.

  • Sorry Frank, but I am getting the same issues that @tddavis and @FlyingBanana78 are getting... the gray screen shutdown. I downloaded Filmer using Chrome, and I have been working in Blender RC2 without issue.

  • Okay, very sorry about that guys.

    I just read all kinds of bug reports on Blender 2.80 Rc2 and a bunch are a crash on startup so although it may seem discouraging, I suppose it is better to catch these bugs now than later so I'll give it a few hours and let the Blender devs do what they do.

    I'm gonna code a new Filmer build after some coffee to make sure whether that bug is still present. The only way to be sure that everything works is for me to run my build, zip and upload it to my website, re-download the zip and unzip it then run the Filmer .exe and if all goes well, I'll tag you here so you can download and test.

    Also I'll do what @tddavis and I were talking about and simply create a new product page for each new Filmer release to keep things better organized and neat. 

  • @Spydurhank Sounds good! Just let us know what you need from us, and we are happy to help! :)

  • Thanks @FilmSensei ,

    I greatly and much appreciate everything that you and the rest of the guys do especially helping me learn new stuff. It may not seem like it but I learn a ton from you guys, like a serious ton. :)

     

    Frank

  • And while I'm still waking up to some coffee, here is a quick clip that I rendered last night after sending a Filmer/Blender 2.80 3D scene over to Hitfilm. The 3D scene includes an animated camera, particle sim, mesh deformation and pseudo "path traced" color and self reflection passes from Filmer. All of that is imported into Hitfilm and comped together with the actual 3d scene as a backdrop. Any changes to the 3D scene in Hitfilm, reflect over the 2D Filmer render passes. The Filmer particle sim even reflects the Hitfilm particle sim so it is a good start to having crazy interactions between both programs.

    Completely stylized and reminds me of something I'd do in water colors, ink and colored pencils. This was done in Hitfilm Pro 13 beta which is a compositing beast. 

    https://www.youtube.com/watch?v=iKU2IrGxWZY&feature=youtu.be

  • edited July 24

    Tossed the previous project into Hitfilm Pro and played a bit. Forgive all the 8bit compression. 

    EDIT:  I may settle on the image below as a splash screen for official Blender 2.80/Filmer release which could be in a few days or an extra few weeks. I could easily change my mind though. :)

    The only two things that I've got to work on are adding some code to the Filmer Camera exporter so that any Filmer camera motion blur and depth of field keyframes are exported and synced in both Filmer and Hitfilm. :)

    EDIT: 

    Another quick update. Been running builds twice a day and one just now to make sure those startup bugs are gone. I'll have a fresh build uploaded in a few hours or tomorrow at the latest after first testing. The wip splash screen is nothing fancy but it came out looking alright.

  • edited July 25

    RC3 is released so I wonder just how much they actually fixed in it compared to the horrid RC2 release. *Fingers Crossed*  

    https://lists.blender.org/pipermail/bf-committers/2019-July/050085.html

Sign In or Register to comment.