Sizing the moment -

When I first got a version of Hitfilm  (I can't, now, remember if it was Express or my recently acquired Pro2017) - I would be confronted with a dialogue box offering a chance to alter or approve imported media (fitting [or not] my project perimeters).  For some reason, this doesn't happen anymore.  Consequently, my videos are comprised of clips with different perimeters.  This hasn't seemed to matter, when exporting, until yesterday.

I pulled off my first Mocha plainer track with a 90% result (a complicated move), but could not export it because it was too large.  I'm thinking that, if that clip size was the same size as my project size, it would have gone through.

How can I fix this?

Comments

  • File>Options>Warnings

  •  Thank you,... all boxes were 'checked'.

  • Uncheck them (or the one you want), Save program, quit, reload, check them (it) again?

    Something might have got stuck.

    Oh, yes, you don't get prompted for large images...also oversized video in Express (bigger than 1920x1080) because it can't set the project to that size if it asks you and you say 'yes', the limit for Express being 1920x1080...even though it could also have a different frame rate.

    Otherwise, keep asking and maybe someone else will have a better suggestion?

  • edited March 2017

     Resetting probably isn't a bad idea.  That said,... the file I'm wanting to import is larger than the 1080 length to which I'm restricted.

    It would be nice for Hitfilm to provide format reductions so we can use the (reduced) files in our videos.

  • Oh, you can do that alright, it's just manual. Right Click, select Transform>Fit to Frame.

    Then if you want to make that a composite shot at the same size, select Make Composite Shot, then select Effects and Transform Properties: Move with Clip, or it'll spring back to the original size ...but  you can scale it down manually to fit again.

  • Okay, I did the 'Fit to Frame thing - then I made it a Composite shot - then I right-clicked on it (in the editor) - discovering a link: Composite Shot Settings,... which allowed me to type in the dimensions I wanted.

    Next, I'll find out if I can get this out of Mocha, once I get a camera solve -

    Whether it works or not,... thanks for the suggestions-

  • You resized it in the Properties instead of select Effects and Transform Properties: Move with Clip.

    You say po-tay-toe, I say po-tah-to :)

    Easier way is the not-typing-anything-way though. ;)

  • Yeah, I'm thinking this amazing software needs a lot more information in it's documentation.

    Again, thanks for your help.  For some reason, Mocha is the tripping point (format-size wise). because all the mixed formats & sizes, in this bunch of clips, all come out fine - but I just need to add this tracking (I think), in order to add glowing fire embers & trailing smoke to my battle-damaged spaceship, as it flies by camera-

Sign In or Register to comment.