"Freezing" once I click edit [SOLVED]

edited January 2017 in Express Support

The program starts up normally. I can click everything  but once I click new or open to do a project, it "freezes" on me. I would click a certain option and then I would have to minimize the window by click the icon on the task bar twice to actually do anything. I updated my drivers so I didn't think I wouldn't have any problem since I ran it on this machine before. 

Intel core i7-6700HQ processor 2.6 (3.3 oc)
Intel HD Graphics 530 and Nvidia GeForce GTX 960M 
Windows10 64-bit, x64


  • That's very odd. I suggest reinstalling HitFilm to see if that fixes the problem. You don't need to redownload HitFilm, you can simply use the same installer you used the first time.

    If that doesn't fix it, then I'm at a loss, I've seen that the Staff has said in the past that HitFilm is automatically using the more powerful GPU, but the HD 530 is still above the minimum requirements, and opening a tab isn't particularly demanding...

  • Triem23Triem23 Moderator

    Is the computer Dell or Alienware? 

  • edited January 2017

     It's an MSI laptop


    I went to my program and features window to "repair" the software with the installer, but nothing happens.  Once I click [start editing], I have to minimize again.

  •  I found the problem.

    Nahimic was running in the background and had to close it.

  • Glad to hear you found the cause and were able to rectify it.

Sign in to comment

Leave a Comment