Lightsaber, render issue?

It is a little strange, when applying the lightsaber (glow only and 4 point), the the pre-render seems not to work. After rendering it is not rendered, even when the blue bar is showing up. 

Am I doing something wrong?


  • Any news on this? Thanks

  • Huh, interesting. Seems like the lightsaber effect can't use the RAM preview, I'm experiencing this too...

  • I didn't have any issues with the 2 point sabre. Haven't tried the 4 point one yet.

  • i just checked and it works ok on my end with in ram preview, Are you getting no animation like flicker or noise from the core?

  • Well the effect itself renders like it should, it just doesn't get cached into the ram preview. So, no matter if I have RAM previed an area or not, playback is still sloppy with the lightsaber effect on it.

  • RAM preview seems to be working completely normally for me with the lightsword effect.

    What hardware are you guys using?

  • i7 4770k, 560 ti, 16gb ram

  • 2,3 GHz Intel Core i7, 

    16 GB 1600 MHz DDR3,

    Intel Iris Pro 1536 MB, and a bigger nvida when on power cord

    MacBook Pro Retina

  • AdyAdy Staff

    Hi guys,

    Like Simon, I am unable to replicate the issue, could you upload a project where it happens in-case we are missing something when creating our Projects? No footage is required, just use planes as in the OP.


  • I do not have a dropbox, can somebody else upload the project? 

  • On it right now, give me a few minutes to replicate and save a project where it happens.

  • Okay, here you go.!64301

    I tried some other things, and found one REALLY weird behaviour - the way the project is right now, it seems as if the RAM preview is rendered correctly (goes through all frames, tinting the timeline in the viewer blue for cached area), but for playback and scrubbing, it seems to completely ignore the preview, leading to sloppy, jumpy playback just as if I didn't preview at all. It doesn't invalidate the preview though, at least that's what the blue area on the timeline is still indicating.

    Nothing new so far, BUT, and now comes the weird part, I then duplicated the lightsword effect a couple times (I think I did four or five copies) to see if I could amplify the effect, but surprise - with the duplicated effects (and thus way sloppier playback), the preview generated, and this time, it actually worked! It played back the previewed area fluidly with no problems. I deleted the duplicates, preview playback was sloppy again. Duplicated a few times again, worked again, so this is perfectly reproducible her.

    Also, proxies kind of show the same behavior - or I just wasn't able to properly generate a proxy for the composite shot, as I didn't see any confirmation that a proxy was created. Should there be one?

  • Thanks, same thing here. 

  • I played with the project Robin uploaded and I saw similar behavior.

    With the composite as-is, I let it build the ram preview and when I played it, it was a little bit choppy, and my GPU load shot up.

    I dropped the 'Smoke' effect into the composite as the top layer, built the ram preview and when I played it, it played smoothly, and my GPU load stayed low.

    If the testers are using fast systems that can play it at full speed, maybe watching the GPU load might help. 

  • AdyAdy Staff

    Hi guys,

    So I've had the Project for most of the day but I don't see any of the behaviour you guys described. Works perfectly for me.

    I'm going to try it on a machine with a similar series card to the ones you guys & using & see how things go. But at the moment I cannot see the issue.

    SimonKJones - Have you had a chance to try?

    I'll keep you posted


  • @ady the card in my machine plays back that timeline in real time even without RAM preview, so it's hard to tell without modifying it, which then of course avoids the issue in the first place.

  • In real time? What machine is this? 

  • @Robin - There should always be confirmation of a proxy being created. Regardless of whether it is a video clip or a comp, the asset in the Media panel should show a progress wheel while the proxy is rendering, and it will switch to a little play icon when the proxy is complete.

    I tried the project too, and cannot replicate the issue. I'm using a Radeon 5770 GPU.

  • AdyAdy Staff

    @SimonKJones - Ahh yes, I forgot about the crazy speed of your machine.

    StephansBilderwelt - Simon has a GTX 970 because he's a very very lucky boy! 

  • @AxelWilkinson Ah yes, got it working now. Don't know what I'm doing wrong last time. So - proxying the shot actually does work just like it should! The RAM preview still doesn't, though, same effects as before, even after some reboots. I will try again once the latest update for HitFilm is installed.

  • Well, nope. Same behavior as before. I only had the feeling generating the preview went somewhat faster :D

  • edited April 2015

    Has perhaps something to do with the dark force.... 

  • Little update, I found something else that might be related to this. I played around with a particle effect with caustics, heat distortion and color vibrance put onto it (gives a quite convincing fire effect, btw!). I created a ram preview of the composite shot. Scrubbing through the timeline, I noticed that up to frame 51, the transform widget for the particle effect are still visible in the viewer, flickering on and off while getting closer to 51, and on 52 they are completely gone. This is not only during playback, but while scrubbing through the timeline with ctrl + arrow keys. The funny part is, one the frames where the controls are visible, the ram preview seems not to work. So the first to seconds of playback are still jittering, once it has hit frame 52 and the controls are gone playback gets smoothed. I'm getting really confused here.

    Here is the project file I've produced this effect with right now, I saved it right after creating the preview and noticing the effect:!64998

  • Looks good here after rendering in 2D and 3D. Very nice fire effect by the way. 

  • Thanks! You don't get those previewing issues?

  • Triem23Triem23 Moderator
    edited April 2015

    Sigh---I sat down five hours ago to try to play in Hitfilm and started doing wedding stuff instead.

    I'll do a quick and dirty lightsaber just to see if I'm getting the same render and preview issues you guys are.

    @Robin, that's a pretty neat fire and a different way of looking at it. on a side note, you ever play with making an embedded comp shot with the Fire plug-in and using that as a video texture source for a particle sim (or, using a stock fire/explosion as the particle textures?) That works well, but it's a slow render....

    EDIT: Apropos of nothing, one of the fun bits about downloading someone else's project file is seeing how that user had the interface organized at time of save. Robin's is very different from mine. As seen here:

  • @Triem23 Interesting Idea... Just took a shot at it on my surface, but even the fire effect on its own brought it to a crawl, so I guess it has to wait for my desktop pc :D

  • Triem23Triem23 Moderator
    edited April 2015

    Yeah, it's a heavy render--but if you saw my strike wing animation, the explosion in that is (several) particle systems, but the main fireball is a particle system using a stock explosion from digital juice as the texture source. I've tired it with the fire effect generating the particle texture as well, and discovered that THAT'S a GREAT way to get familiar with proxies, fast. ;-) There's a Red Giant tutorial for Particular that uses explosion stock as the texture source as well, but I had the idea on my own before I saw that tutorial.

    Back on-topic. I did NOT run the lightsaber test I intended tonight. I ended up doing wedding stuff for five hours, and, for my Hitfilm activity for the night I returned to this shot that's been a thorn in my side for a month. What I've learned from THAT shot is I want Hitfilm to add a Particular-like "Grid" emitter to the particle system. To get a regular arrangment of Daleks I just had to place them in 3D space. Doing it all on different layers is too much for my GPU (immediate crash-on-render), so I had the joy of duplicating 24 Daleks (I'm pretty sure no one will notice that Dalek 25 vanishes between shots) and placing them in relative positions within a single layer. Joy. On the other hand, I found out if you put multiple models onto a single layer, each individual model can be parented to it's own point. That's actually kind of neat. That would let me assign groups of Daleks to varied points so i can show them fly into formation. And, I went right back off-topic again.

  • No previewing issues with this one, no. 

Sign in to comment

Leave a Comment