GoPro Studio generated AVI files working, Resolve generated AVI files not working.

edited April 2015 in Express Support

The title says it all. After reading some more about intermediate codecs, I decided to download GoPro Studio to see if cineform worked better than DNxHD on my computer. I generated "the same" file using both GoPro Studio and Resolve. The file created by GoPro Studio plays on Hitfilm, but the Resolve one gives me an error. I tried several different levels of compression and the results were always the same (as in, the file would not play on Hitfilm). The Resolve one plays well on Resolve.

Here are the files if you want to check.!pMNhlLbS!L6vVYR5dhuNlDcyju3VG_TD-i5JdkgIku-i1fH8F9yE!YR011Q4S!iw47WoWXpJrENlMwRHjtA9E84rx8kSErZ3lBqBCZKiA

Suggestions are welcome.


  • Aladdin4dAladdin4d Moderator

    @AramM The first obvious difference is the Resolve file has an audio track defined and the GoPro Studio one doesn't. Did all of your Resolve renders have an audio track?

    I'll dig deeper into the clips in a while.

  • @Aladdin4d, good catch. I'll have a look, maybe it is an issue with the audio codec not being compatible with the container but Resolve somehow getting around it.

  • Aladdin4dAladdin4d Moderator

    @AramM Sorry I'm running a bit behind I had something I had to get out for first thing tomorrow morning. Anyway I can open both clips in a variety things, file structures look good and everything but neither one works in HitFilm for me!

    @Chris2014 has also been trying out new intermediate codecs and has also had problems getting some of the resulting AVI files to work in HitFilm. Oddly though a CineForm compressed clip with an alpha channel is working for him in HitFilm. More info on the issues in these threads:

    HitFilm ultimate not responding (computer below spec?)

    The Intermediate Codec Thread

    I've also duplicated some of the same problems @Chris2014 has had so I'm thinking collectively we  may have discovered a HitFilm problem instead of a codec problem

  • edited April 2015

    @Aladdin4d no worries. Now, that neither works for you is a surprise! Have you installed some version of cineform on your computer?  Installing GoPro Studio will do that (just in the very unlikely case you haven't installed it already). 

    I tried creating an AVI with no sound with Resolve and no joy there. It still does not work on Hitfilm.  

    Will check those threads!

  • On a tenuously related point: I also find that Hitfilm struggles with the standard MP4 files right out of the GoPro camera. As in it processes about 1 frame a second and tracking keeps stopping every few frames and has to be restarted. The alternative is to simply keep clicking on the single frame track button for the entire clip.

    I know all the arguments about MP4 being a bad format to edit with, but everything else seems to manage just fine, scrubbing in realtime forwards and backwards, including GoPro Studio itself.

Sign in to comment

Leave a Comment