Single Point Tracker doesn't stop.

I'm sure I've read another post with the same issue but I just can't find it. So sorry for the duplicate.

When tracking backwards and the pause icon in the Track Controls is pressed the tracking doesn't stop.

  • Create a Composite
  • add a clip with something to be tracked, when I originally had the problem I was tracking an eye, I have reproduced this with some random clip of one of my kids.
  • Go part way though the clip
  • Add a single point tracker
  • Start tracking backwards
  • After a few seconds try to stop the track. If you're lucky it'll stop, if you're not so lucky it'll stop after about 10 seconds and if you're really unlucky it wont stop until the beginning of the clip is reached. My eye tracking never seems to stop. With the other clip I reproduced this with it some times stops after a short delay and sometimes after 10 or so seconds delay.

The original file is a heavily compressed 1080p/29.97 mov while the second is a 1080p/25 m2ts. In both cases the project frame rate matches the clip.

  • Windows 8.1 Pro
  • i7-2600K
  • 24GB RAM
  • GTX 660 (Driver 347.88)


  • Update: Must be related to the source codec/container type. I exported the original clip (or the part I'm interested in) as a png image sequence and it's doesn't have the same problem with stopping the tracker.

  • Hm, I've never encountered this issue myself and have used a wide range of media types. Does it happen every time, consistently, when you use the MOV and MTS files?

  • I've occasionally had it take a while for it to respond to the stop/pause while tracking. Can be annoying when you know something's about to pass in front of what you're tracking, and think your stopping at the right time :)

    It hasn't been enough of an issue for me to worry about, but I'll try to pay more attention next time it happens. 

  • AphAph
    edited March 2015

    It may have been my post, I wrote this in another thread:

    "Well, I do know that using the simple 2D tracker in HF3 is painful. When the tracker loses the object it's tracking and I press the pause button, it takes a good 15 seconds or longer for it to "pause"! I tried the same footage in HF Express, and the pauses were almost immediate!"

    I'm talking about the single point tracker, of course.

    The media is .mts: 1920x1080 29.97fps

    Laptop computer has: Win7 64bit, i7-3610QM@2.30ghz, 8g ram,  nvidia gt650m

    Since this works perfect in Express & Ultimate (same media, settings, etc.), the code has obviously changed a bit in HF3.

    In general, HF3 has proved to be less responsive and slower in all respects compared to Express and Ultimate... but I have just accepted that I may need a better computer.

  • @SimonKJones, I just tried two more clips of both types of file and was able to reproduce the problem each time.

    The .mov files are from a Nikon CoolPIX P310, which is a consumer point and click style camera. Theses files are 19.0Mbps, AVC main@4.0 18.8Mbps, 2 channel AAC 128kps. While the m2ts are from a Panasonic HDC-SD700 which is a consumer handycam. These files are 12.6Mbps, AVC high@4.0 11.7Mbps interlaced (hmm I'll try some progressive later, although the mov are progressive), 6 channel AC3 384kps.

    @Aph, yes I think that is the post I was thinking of.

  • AdyAdy Staff

    __simon__  - I've taken a look at this issue but I'm not able to reproduce it. Is it possible for to upload a sample of the footage that shows the issue clearly?

    Many Thanks,

  • edited May 2015


    There's a readme which hopefully has everything you need, if not feel free to ask.

  • AdyAdy Staff

    __simon__ - Excellent, thank you so much. Going to take a look at this A.S.A.P. 

  • @Ady, just wondering if you've had a chance to look at this and reproduce it. I've installed HitFilm on my wife's laptop and reproduced it. The specs are i7-4710HQ, 16GB RAM, GTX 860M (Driver 350.12), Win 8.1.

    I originally tested this with update 4 and have just installed update 5 and verified that the issue persists.

  • AdyAdy Staff
    edited April 2015


    Sorry for the late reply, things have gotten a little hectic here since we last spoke.

    I've taken a look at the Project & followed the steps you've outlined but the problem does not happen on the test machines here. As soon as I attempt to stop the Track, it almost stops immediately.

    I'm going to try with some different set-ups today, but so far on 2 machines with a GTX 760 & one with a GTX 560Ti I'm unable to reproduce the problem. But I'll keep trying.

    Sorry again for not getting back to you sooner.

  • @Ady, that's cool, thanks for trying.

    I'm trying to think what might be the common factor since my wife's laptop and my PC differ significantly yet both reproduce the problem every time. For example my PC has a SSD for Windows/Programs, a separate HDD for the project data and another separate HDD for proxies, and I've also changed the location of media database/cache to be on the same HDD as the proxies. The laptop on the other hand has one HDD that's been partitioned into a Windows/Programs and Data drives and is a lot slower than the HDDs in the PC, I haven't changed the location of the cache/proxies from the default. The laptop is also reasonably new and thus doesn't have a lot of other stuff installed.

    So if I focus on what's common then;

    Windows 8.1

    Quicktime 7.7.6

    Avid Codecs LE (2.6 on laptop, 2.5 on PC)

    Red Giant Universe

    GeForce Experience

    ESET Smart Security 8 (antivirus/firewall etc)

    Datacolor Spyder 4 (display color calibration)

    The User

    And some programs which shouldn't have any effect such as Firefox, Thunderbird, irfanview, ACDSee, Cloudmark DesktopOne, VLC, Adobe Reader.

    I can't remember if I reproduced this on the laptop before installing Red Giant Universe. The GeForce drivers are up to date and have been updated during the time I've had the problem.

    I've tried disabling the ESET antivirus and firewall, removing the monitor calibration and exitng the Datacolor tray app but these had no effect.

    It doesn't seem to matter whether other applications are running. On the laptop the first time I tested this only HitFilm was running. My wife and I have separate logons and this evening I just switched users so currently all her programs are still running in the background (I can see in task manager that her login is using 5-10% CPU and ~1.5GB of RAM)

    Which leaves the User, me. Maybe I'm just doing it wrong. I tried to use NVidia ShadowPlay to capture what I do but that doesn't seem to work on the laptop. I'll try it on the PC next time I use it. If that still doesn't work then I might have to resort to old school filming the screen.

    The only other thing I can think of is that in both cases the project files and media are on D: but I'm really just clutching at straws now.

  • @Ady, I've recorded a screen capture of me replicating the problem on my PC.

    Sorry, haven't got myself setup for you-tube right now: 04.23.2015 -

    At 42 seconds I try to stop the track, you'll notice that the editor and viewer time display stop at 00;00;05;15 and the key frames stop updating, the whole UI seems to have stopped except for the video playing in the viewer.

    At 56 seconds I wiggle the mouse and the pointer turns into a busy indicator

    At 1 minute 7 seconds the track completes and the UI updates with all the keyframes and time etc.


  • AdyAdy Staff
    edited April 2015

    __simon__ - Thanks for doing a video, sadly it looks like dropbox is having a meltdown or something has gone horrible wrong because when I access your link the page just hangs.

    Not really sure what's happening there, can you check everything is ok on your end?

    EDIT: It seems to be working now so please disregard the above.


  • edited May 2015

    This is also still happening for me after update #5.

    I've taken exactly the same file into both HF2E and HF3P and one stops immediately, the other drags on.

    What I have tried doing with some success is starting and stopping it every few seconds, as it seems that after a few seconds HF3P gets its steam up and doesn't like stopping once it's got going. But if I stop it when the fans kick in on my PC - indicating the CPU is getting up to speed - then it stops and I click to recontinue. It's slower doing this, but ultimately less awkward than having lots of tracking points I don't want.

    BTW, I also find that HF2E is also a bit better at following a 'less than ideal' tracking point and that if I don't exercise trackus interuptus on HF3P it stops itself for no obvious reason anyway. It was this behaviour that led me to the start/stop/restart/stop/restart semi-solution out of necessity to get it to track properly in the first place on some footage... Same footage in HF2E just waltzes along with no apparent problems.

    Essentially, it seems that HF3P seems to get in its own way somehow.

Sign in to comment

Leave a Comment