Mac exporting problems "unable to initialize"

edited December 2014 in Express Support

I'm disappointed and frustrated.

I've done a clean install of my IMac, I've contacted the support, sent the clip, sent the crash report and still have no possibility of exporting a single frame.

Either I get a warning "unable to initialize" or Hitfilm simply quits.

Looks like I'm not the only one experiencing this problem and the answer is "sorry, we cannot reproduce this issue". 

I cannot accept that and hope for a solution asap.


  • Hi @aledige - so sorry you're feeling frustrated with the software. We've been made aware of the issue and we're working hard to address it. Sometimes it might take a while to reproduce an issue, but that doesn't mean we won't continue trying, or find other ways to find out what's happening. 
    We'll make sure that we respond on this forum post as soon as we are able to offer you a solution or an update on the situation, and I hope that will be some time today. 

  • You mentioned in your support ticket that creating a new user account did fix the problem you're experiencing with the Mac. Is this still the case? 

    We are, as previously mentioned, having issues recreating the problem here - but we have found that everyone else experiencing this issue can avoid it by creating a new Mac user account. There are only a handful of people and so it must be something unique to those specific systems. In the meantime, we're working hard to try to recreate it on a developer's computer and come up with a solution. Unfortunately we're unable to say how fast this might be. 

    Can you let me know whether you have managed to bypass the issue by creating this new account. If it hasn't worked, we'll make sure that you receive further support. Sorry about the inconvience this has caused you @aledige

  • I've cleaned the system once again. From previous installation I've imported mail messages, photos, Itunes items only.

    I've installed Hitfilm and exporting seems to work. As next steps I'll install FCPX, Motion and Compressor. I'll make necessary system updates and see what will happen.

    I'll let you know. Many thanks for your support.

  • Just to clarify, what @KirstieT was referring to was creating a fresh user account on your Mac, and installing HitFilm into that.  Keep us posted on your efforts to clean the current account as well, but if you can also confirm whether a fresh user account clears up the export problem, that would be great.

  • @AxelWilkinson indeed - thanks for the clarification. 
    @aledige I really hope that works for you. If not, let us know and we'll keep working on it. 

  • @AxelWilkinson Yes Axel. I did it on prevoious system configuration and exporting has been successfull.

     @KirstieT ok. I've installed FCPX, Motion, Compressor, Motion and FCPX Supplemental content and Pro Video Formats on my main account. Tried to export and crash. Switched to the other fresh created user account and export with no problem. I'm a bit confused.....

  • Thanks for the additional details, aledige. It sounds like the problem might be related to the additional software you've installed, although that all looks like standard software which lots of people who aren't having the problem would also have installed.

    Did the crash start again after installing a specific program? If we could narrow it down to exactly which product is conflicting it'd be really useful.

  • edited December 2014

    Not suggesting that anyone does this, but--since having some issues with Hitfilm 3 Pro crashing on the Mac--I've taken HF3P off my Mac for now simply because the long-term project currently being worked on was started in HF2U. As a rule, I don't interrupt an established workflow to try out a new product (or new version).

    So I deactivated one license of HF2U from my PC and reactivated it on my Mac. Haven't had any problems with HF2U on the Mac. Then activated a license of HF3P on the PC. HF3P--from my personal observations--seems to run a lot smoother in Windows than it does on the Mac.

    If it helps, I'm only running Motion (5.07; on Lion/Mountain Lion, so I can't run 5.1x)--not FCPX or Compressor. The supplemental files and Pro Video codecs have been downloaded.

    If it helps, here are the specs of my systems (again, both Macs have Motion 5.07, supplemental files and Pro Video codecs installed):

    - Mac Mini (2012): OS X 10.8.5, 8GB RAM, Intel HD 4000 IGP, 2.5GHz Dual-Core i5.

    - iMac (Mid-2011): OS X 10.7.5, 4 GB RAM, AMD Radeon HD 6750M (512MB), 2.5GHz Quad-Core i5.

    - Toshiba P75-A7200: Windows 8.1, 8GB RAM, Intel HD 4600 IGP, Quad-Core i7 2.4GHz (base).

    - Toshiba E55-A5114: Windows 8.1, 6GB RAM, Intel HD 4400 IGP, Dual-Core i5 1.6GHz (base).

    Hope this helps.

  • @Pencilandinc Many thank for sharing. I've uninstalled compressor and Still having same problems (export window pops up and after few seconds Hf crashes). I'll try uninstalling FCPX, leaving Motion.

    What's odd is that on a brand new user everything runs smoothly.

  • @aledige I tried leaving Motion 5 on and running the HitFilm plug-ins and, for some reason, they wouldn't install (at first). Once they did install, they wouldn't run under Motion.

    My suspicion is that it has something to do with the way HitFilm addresses Quicktime on the Mac. On Windows, Quicktime runs under 32-bit addressing. OS X is a through-and-through 64-bit operating system as is Windows 8, but my best guess is that there may be some hang-ups between HitFilm's core programming and Apple's 64-bit version of Quicktime.

    On HF3P (Windows 8.1), Imported a 720p sequence made in Blender, exported it from HitFilm as ProRes 4444. Played back beautifully on both the PC and Mac.

  • @Pencilandinc Had no issues with plugin installation but did not do any test....

    what you say might make sense, since sounds strange that running HF as new user exporting is not a problem....

  • Pencilandinc I have used the plugins a couple of times now within FCPX and Motion, they work all well for me. The only issue is that the two will startup much slower now. 

  • @aledige  @Stephans What are the specs on your respective Macs? To be precise, what are your:

    - Operating system versions

    - video card specifications

    - amounts  of RAM

    - processor specifications

    - make and model of your Mac

  • @pencilandinc

    • Yosemite
    • AMD Radeon HD 6970M 1024 MB
    • 16 GB 1333 MHz DDR3
    • 3,1 GHz Intel Core i5
    • Mac (27 inches, Mid 2011)
  • @StephansBilderwelt ;

    What are the specs on your Mac? To be precise, what are your:

    - Operating system versions

    - video card specifications

    - amounts  of RAM

    - processor specifications

    - make and model of your Mac

  • @Pencilandic

    Yosemite, 16 GB Ram, end 2013 Retina MacBook Retina Pro, Processor 

    2,3 GHz Intel Core i7, video 

    NVIDIA GeForce GT 750M and

    Intel Iris Pro

  • Thank you, gentlemen.

    With the data you have supplied, I was able to research why it might be possible that StephansBilderwilt’s Mac is running the HitFilm plug-ins with no problems while Aledige and I can’t even get them to come up in FCPX or (in my case only) Motion.

    Please remember that I am not an expert, nor am I a programmer but I have been troubleshooting my own Macs for 20 years and, in that time, gained a bit of insight about how these babies work.

    I won’t bore you with all the geekspeak involved in my theories...suffice it to say that it works on yours, Stephans, because your hardware is newer and, I believe, because Hf3P is having problems dealing with QuickTime’s 64-bit programming code (on Windows, it’s still 32-bit) on older versions of OS X.

    If you don’t want a lot of technical jargon, stop right here. The following is all conjecture.

    HitFilm 3 Pro dropped support for the Intel HD 3000 Integrated Graphics Processor. HitFilm also uses OpenGL for a fair amount of its graphics power; therefore, I think it’s safe to assume that FXHome is no longer supporting OpenGL version 3.X in HitFilm. That said, the machine that Stephans is using has an Nvidia GeForce GT 750M processor (2GB of VRAM) in it. Aledige’s iMac has an AMD Radeon HD 6970--no slouch by any means--but you then have to look at how the OS is sending commands to the GPU. Apple builds their own instruction set based on the manufacturer’s specs to create the video drivers inherent in the various versions of OS X. Unilke on Windows, where you can actually download and install updated versions of the manufacturer’s video drivers. With OS X, you have to hope that the updated video drivers are included in the next “dot-release”. This is one of the reasons why I think that HitFilm 3 Pro actually works better on Windows than it does on the Mac.

    Having said that, Stephans has stated that he has no problems using the HitFilm Plug-ins other than a slight lag in initial load time for the software (which is understandable). The simple answer is that Yosemite’s instruction set is “talking” to all the components of his newer hardware in a much more efficient way than it would to older hardware. And this especially shows in the way that it’s required to handle the programming code in HitFilm 3/Plug-Ins.

    To this end, I still think that it has something to do with the way HitFilm is interfacing with the version of QuickTime (and the codecs) inherent in versions of OS X prior to Yosemite and, possibly, Mavericks. Given that you both have Yosemite and I’m trying to get this to work on Mavericks...I might theorize that for all but the 2013+ higher end Macs, you would need at LEAST 10.9.X to be able to run Hf3P and/or HF plugins. But that it might HAVE to be the combination of 2013+ higher end Macs and the more recent versions of OS X. A 2011 Mac with an updated version of OS X might not do it. Aledige, I feel your pain, I updated my 2011 iMac to Mavericks trying to get Hf3P to run. No luck.

    I must also say in closing that my theories are in no way an implication of fault on the part of FXHome. Thank You For Your Time.

  • @Pencilandinc what you're saying is interesting and I'm also pretty sure that a later iMac with a much powerful graphic card would make the difference.

    Still I do not understand yet why, switching to a new user, I'm able to export HF composite shots without any problem....

  • edited January 2015

    @aledige  Was speaking with someone this past weekend about this predicament. He has a theory much more simple than anything I've postulated. Plain and simple, he thinks that--while everything stated above plays into it--the HitFilm plugins don't work on our machines and WILL work as a new user with none of Final Cut/Motion/Compressor loaded is because of the way system resources (VRAM/GPU, RAM, CPU) are channeling the data when creating/exporting video files on a Mac.

    In other words, HitFilm is fine when it's the only application resident on the OS using the Quicktime programming to export video compositions; BUT it is possible that when the Plugins are used in conjunction with another program, such a high amount of resources are required that if one of those resources are found wanting (not enough RAM, GPU/CPU is too slow)--for whatever reason--the file can't be created.

    StephansBilderwelt did say that--once he'd installed the Plugins--it took his FCPX a little while to load. The Plugins could be being treated by FCPX as another full application running concurrently with it. Basically, when you're exporting a clip with HF3 VFX in it, it's not only pushing from FCPX but HF3 as well. Again, requiring more resources than may be available.

    Additionally, as far as why HitFilm works under a clean install, I suspect it could be a permissions thing between QuickTime and the Apple Video programs as assigned within OS X. Once any of them are installed, they may take over key defaults within QuickTime. As QuickTime IS the multimedia backbone of OS X's audio and video capabilities, OS X probably assigns certain properties/permissions to those programs that HitFilm is able to use if the Apple Video programs are not resident OR that Macs with a generous amount of resources are able to exploit.

    As someone who really enjoyed (and still does) HF2U on the Mac, it seems to me that the problem is the way Apple has written OS X and/or their high-end video programs. HF2U doesn't/didn't have these types of problems when released on OS X in 2013.

  • @Pencilandinc I'm not a programmer too, although  I think there's a sort of conflict or 'priority' among the applications. I had exactly the same problem with HF2U, which I had the opportunity to test few days before switching to HF3.

    But, if this would be a problem as how OSX is programmed, then the same issues would also afflict other applications which need to export footage. I've been using Premiere and After Effect on my IMac and never had a problem. I therefore came to the conclusion that there is a sort of programming fault  in HF code. I can imagine that tracking down it would be problematic and, being probably WIndows users a majority, not the highest priority for Hitfilm.

  • Any updates on the OpenGL issue? I too have experienced it and I think that some of these posts are pointing in the right direction to hopefully solving it, as well as solving export crashes. I find it very interesting that no staff have been able to reproduce the issue since it seems like such a common one.

  • AdyAdy Staff

    Hi guys,

    Sorry, for the delayed response, somehow I didn't see this thread. And although it is quite old now, I do have some updated information & would like to clarify a few points

    While it is true that we have struggled to replicate the issue originally detailed in the OP, we have spent many hours testing, probing & looking for the route cause of the problem without any success at present.
    That is up until the last few days, Where upon a test Mac has started to exhibit the issue describe in this thread. So we are currently investigating what is causing the issue & why it's only suddenly now appeared on a Mac that has worked perfectly for many months before. Hopefully at some point in the not too distant future I may have some more information on this, but that is all I know for now.

    As I said above, I would also like to clarify a few things that were raised in this thread:

    "HitFilm 3 Pro dropped support for the Intel HD 3000 Integrated Graphics Processor. HitFilm also uses OpenGL for a fair amount of its graphics power; therefore, I think it’s safe to assume that FXHome is no longer supporting OpenGL version 3.X in HitFilm."

    Yes we did stop supporting the Intel HD 3000, this has no relation to the version of OpenGL we are using. When developing HitFilm 3, we just found that the hardware itself was not up to the level we would expect from the GPU, so we made a decision to no longer support it.  What we use in terms of OpenGL remains the same as it did for HitFilm 2 & where possible we do take of advantage of features available to us in higher versions of OpenGL.

    "I can imagine that tracking down it would be problematic and, being probably Windows users a majority, not the highest priority for HitFilm."

    Sorry but again I have to highlight this quote, our users are our priority, we don't give preference to any platform over another regardless of the installed user-base.

    So, just to summarise, we have found a way of replicating the issue which hasn't been possible before & the developers are looking into it now. I would keep an eye on our blog & social network for any potential updates on this bug or the software.

    Many Thanks,

  • @Ady Having dealing with this issue since HF2U was released for Mac, this is some fantastic news! Thanks a ton for the update!

  • AdyAdy Staff

    BlindFireStudios - Thank you for your patience and the same to all of those that have experienced this problem. I know how frustrating it is when things don't work, but I can assure we will get to the bottom of it.


Sign in to comment

Leave a Comment