Hitflilm Express 2017 not responding

I have recently downloaded Hitfilm Express 2017 and whenever I open it i get an error that the program is not responding, any help would be appreciated 

Comments

  • hi there, I tried to start editing on hitfilim4 express and a dialog box pops up stating that hitfil4 express encountered a problem and has to exit

    OS:Windows 8.1pro

    Disk: 128GB SSD

    Processor:i7-2670QM@2.2GHz

    RAM:8GB

    Graphics: Intel HD3000 +AMD RADEON HD7400M series

  • Triem23Triem23 Moderator

    Your machine is under minimum specs for Hitfilm. 

    That specs list can be found here. 

    https://hitfilm.com/express/specs

  • Is the AMD 7400M under spec?

    I question if the HD 3000 and the AMD 7400M are both active but if they are then the question becomes which one is Hitfilm trying to use. You want it to use the AMD GPU.

  • Triem23Triem23 Moderator

    @NormanPCN benchmarks are imperfect, but the 7400m benches at half the speed of the Hd 3000,which is under spec 

  • Sounds cute, "Hitfilim" :)

  • Triem23Triem23 Moderator

    If the software is crashing without opening this usually means you are under minimum spec. What is your CPU, GPU, OS, RAM and storage? 

  • edited May 2017

    Whenever I open a project and try to go into the Edit tab it says "We're sorry, Hitfilm has encountered a problem and has to exit." I don't know what's wrong; all of my drivers are up to date as far as I know and the computer that I built myself is well above the minimum system requirements. This is incredibly frustrating because, since Hitfilm 4 is my primary editor and compositing software (at least back when it used to work), I have basically been without any editing software whatsoever for the past three months now. I'm currently working on a short film and now I can't edit it or do any visual effects on it. I NEED THIS FIXED THANK YOU VERY MUCH.

     

    If you want to know, my computer is this:

    Core i5 6400

    EVGA GTX970 super superclocked edition

    120GB SSD

    1 TB hard drive

    Asrock b150m pro4 motherboard

    16 GB of ram

    500W power supply

  • CPU: AMD FX(tm)-6350 Six-Core Processor

    OS: Windows 7 Home Premium 64-bit

    Ram 16Gb installed 7.90GB available

    GPU: ASUS HD 7770 Series

    Storage: 1TB installed 645GB Left

  • This has been happening since April 12th for me. 

  • Nevermind I fixed it and Im stupid

  • Triem23Triem23 Moderator

    @Unidrew what was your problem and solution?

  • Aladdin4dAladdin4d Moderator

    And the fix was?

  • My Hitfilm was out of date

  • This is still a rampant problem for me. Happens every few clicks. 

    Every few minutes if I'm lucky

     

    CPU: AMD Phenom ii x6 1100T

    OS: Windows 7 Ultimate 64-bit

    Ram 8Gb installed 

    GPU: Raedeon HD 6850

    Storage: 1TB installed 95GB left

  • Hello!

    I´ve got the same Problem. Every time i start Hitfilm Express 2017 it is crashing without opening.

    I´ve updatet all of my Drivers and also deleted all of it and Setup all Drivers new.

    I´ve dowloaded the newest Version of Hitfilm Express 2017.

    Now i´ve got no idea left..can anyone help me?

     

    My Device:

    Intel i5-4430

    Z87 Chip

    8 Gb Ram

    Nvidia Geforce 1050ti 4gb

     

  • If HitFilm is crashing when it opens, contact Support.  We forum mortals can't help much.  Sorry.

  • Every time I try to start mine it always says, 

    "There was a problem the QuickTime helper process

    Error code: 42

    As a result You will not be able to import QuickTime movie files.

    Please re-install the application to fix this problem."

    I press "OK" and nothing shows up. I've already re-installed the program about five times and nothing has worked. Do I need to update Quicktime or something?

  • Triem23Triem23 Moderator

    @HanakothatMystic Sounds like you should re-install quicktime.

  • Just downloaded express and it also crashes.

    I did track a Snowboarder in a Minute Long shot and stabalize it so he is in the mittl. and try to modify all the tracking Points that are too far to one side.

    It mainly crashes when I rightclick or doublick Things in the tracking menu (trying out if there a menues with funktions as I've been not able to achieve my Goal yet) it the program just Greys out and Windows Shows it as not answering. CPU is at about 15% and it doesn't come back even after 15 min or longer. 

    Name NVIDIA GeForce GTX 780
    Betriebsystemname Microsoft Windows 10 Pro
    Prozessor Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz, 3501 MHz, 4 Kern(e), 8 logische(r) Prozessor(en)
    Hauptplatinenhersteller ASUSTeK COMPUTER INC.
    16GB RAN

     

  • edited January 6

    Posting what fixed it in my case here as well.  This may only help if have have floated the viewer.

    My system: Win 10, AMD 1700, SSD drives, GTX 1060 6GB, 16 GB Ram.

    Floating the viewer on my systems makes Hitfilm extremely unstable.  Once the viewer was floated and I reopen Hitfilm the next day it would not start.  Hitfilm shows the two windows and then hangs.

    Here is how I got Hitfilm working again.

    1. Uninstall Hitfilm Express 2017 (this does not remove UI settings!)
    2. Open explorer and navigate to: C:\Users\YOURUSER\AppData\Local
      Delete the folders: FXHOME and FXHOME Helper
    3. Click on your start button and type "regedit", run regedit from the program list.
    4. In Registry Editor click "HKEY_USERS" under "Computer".
    5. Click Edit then Find...  Type in "fxhome" in the Find What box.  Make sure Keys has a check mark next to it and press "Find Next"
    6. This may take a while but regedit will find a folder "fxhome"  In that folder are Hitfilm Express 2017 and Organization Defaults. 
    7. Right click on the "fxhome" folder and choose "Delete".
    8. Re-install Hitfilm Express 2017

    It would be great if UI settings were not saved in the registry.

  • My Hitfilm express 2017 isn't responding and I updated my drivers. I downloaded Hitfilm express 4 but it didn't get out of demo mode 

    I have a

    CPU: I7 7700K

    GPU:  Gtx1060 3Gb

Sign in to comment

Leave a Comment