Text formatting arrow buttons not responding

edited January 2017 in Pro Support


I've come accross an odd behavior with the text tool.  In short, it seems that the up/down buttons for the 'Charachter Spacing', 'Line Spacing' and 'Stroke Width' fields don't adjust the values.  However, placing my cursor over the field (so the opposing arrows appear) and dragging left/right works fine.  Also, entering a value manually works as well.

Steps to reproduce:

1. Open Hitfilm Pro 2017

2. Start a new project, select 'Start Compositing'

3. Select the Text Tool (T) in the viewer window

4. Create a text box and add some text

5. Highlight text and switch to the TEXT tab.  Use the up/down arrow buttons to adjust parameters for the 'Charachter Spacing', 'Line Spacaing' and/or 'Stroke Width' fields.

Can anyone else confirm the same behavior?

Also, relevant system specs: Intel Core i7 4790K, 16 GB G.Skill Trident X RAM, EVGA GTX 980Ti, Windows 10 Pro 64-bit (latest patches applied), Hitfilm Pro 2017 5.0.6007.34105 (Update 1).

Thanks! :)


  • Triem23Triem23 Moderator

    I can confirm this behavior on an i7-6700, 64GB RAM, Nvidia 980m, Windows 7 (SP2) and HFP 2017 Update 1.


    I can ALSO confirm this behavior in HF4E and Pro on the same hardware. I'm not going to go back to HF 2 or 3 to test this.

    I've never ever tried to use those arrows before. I've always either directly entered values or dragged in the fields. Go figure.

  • Confirmed.

    The buttons do work when the control entry field has focus. Click the control on the entry field for the control. The control will be highlighted with a thin blue box. Once focused, the up/down arrows function.


  • Thanks for the replies guys. :)

    @NormanPCN, yep the buttons do indeed work when the box is highlighted.  Never noticed that though since I usually just go straight for the buttons if I want small adjustments.  Anyhow, thanks for the workaround. 

  • @francisw19 Good find, I've fixed it for the next update of HF Pro 2017. Sorry about the inconvenience. Thank you for reporting this.

  • @CedricBonnier, glad to help.  Thanks for the quick fix! :)

Sign in to comment

Leave a Comment