"The File could not be imported" when importing an MP3

I'm importing a MP3 and get an exclamation mark on the file when in the Priject Media section. Clicking the file states "The File could not be imported" error message.
I click the import button, select MP3 for file type, and then select my MP3. HitFilm adds the track to the Project Media section.
The track is about 2 minutes long. It also 256kpbs.
Am I doing something wrong?


  • AdyAdy Staff

    I'm importing a MP3 and get an exclamation mark on the file when in the Priject Media section. Clicking the file states "The File could not be imported" error message.
    I click the import button, select MP3 for file type, and then select my MP3. HitFilm adds the track to the Project Media section.
    The track is about 2 minutes long. It also 256kpbs.
    Am I doing something wrong?

    Hi Alberto,
    Sorry can you just clarify the problem for me. Apologies in advance if I'm getting things confused.
    So when you click Import & select the MP3 file it does not Import. But if you change the Filter within the Import screen to MP3 then it does Import? Is that correct? Or does the file just not Import at all?
    Are you able to upload the file or a sample so that we can test it here in the Office?
    Many Thanks
  • Thanks fr your help.
    I do the following:
    1. Click the Import button in the media section.
    2. I then changed the drop down menu from "All Supported Media Files" to "MP3 Audio"
    3. I select my file
    4. Click Open
    File is added to Project Media with an exclamation icon on it
    I tried a few MP3s and I am getting the same results.
    I have a drop box link to the audio file at http://db.tt/qv8Ntv7
  • The software that created your MP3 file has written more than one header into it, which causes a problem for the Windows technology that HitFilm uses to read and play the file. We are working on a fix for this problem.
    In the meantime, you could try converting your MP3 to a WAV file, such as by using Audacity, and then import the WAV file into HitFilm.
  • Thanks for your reply and assistance.
  • Thank you for posting this question and answer. I have been having the same problem so I will try the suggested remedy. Thanks again.

  • edited December 2015

    The same thing happens to me when I am trying to import .mp3 files as well. It just keeps saying that the file is not supported and I can't find how to fix it.

  • edited May 2016

    I converted my .MP3 to .WAV and HitFilm still won't let me import it!

    PLZ help me im fucked up because i overdubbed long film in Adobe Audition and I can't even upload it on youtube!

    Repair it as fast as possible!!!

  • Aladdin4dAladdin4d Moderator
    edited December 2015

    @Unreal Can you upload your audio somewhere? Because of the holidays you probably won't see a quick fix for this so maybe somebody can get your wav to work

  • edited January 2016

    Has there been any progress on this,  as it makes finding music for videos incredibly annoying.

  • @AntonyMitchell Your best bet is to try converting an mp3 to a WAV first. HitFilm has problems when there's multiple headers in the file or when the header doesn't conform to a strict Windows spec. 

  • Im unable to import audio as well. Tried mp3 and also converting to wav

  • edited January 2016

    Everyone who is having problems getting their audio files to import to HitFilm, upload your audio files to dropbox, or somewhere else, give me the link and I will show you how to get your audio files to convert properly and import into HitFilm.

  • Thanks for posting this question, @TeamNinjaIsland! I also was having the same problem, but I was able to convert the mp3 to a 16 bit wav file in audacity and sucessfully import it thanks to @Hendo and @Alladin4d's suggestion.  :)

  • Mm, if anyone is still having an issue even after all of the above suggestions, i would recommend just flat out playing back the mp3 file (with windows media player or something along those lines) and record it as it's playing. It seems kinda simple, but importing mp4s is never an issue for hitfilm. So record the audio of an mp3 as an mp4, import it to hitfilm editor, and then unlink, and remove the video track.

  • edited July 2016


    I had the same problem and it seems that you have to use an audio editing software (Audacity or Audition) and convert it to a 16-bit wave file. This worked for me after trying to import a 16-bit .mp3 file which failed, and a 32-bit wave file which also failed. 

  • Hendo? i have audacity now but how do i make it a WAV file?

  • Stargazer54Stargazer54 Moderator
    edited July 2016

    Don't have Audacity in front of me, but it should be: Load the file, then click File > Save As (or Export)> pick .wav as the output type. 

  • edited August 2016

    Adding to the last message of @Stargazer54 ,

    You need to select "WAV (Microsoft) signed 16-bit  PCM" for it to work. Had the same issue as well.

  • The WAV file still did not work, in fact, no audio file is working

  • @SmokySpace ;  Outside of any other software can you double click  on the .wav file (assuming you're on a PC) and have it play?   Same question for the .mp3.

    If you are having trouble with the above steps there may be issues with drivers for your audio card (or chipset, these days).   Anytime you have issues with basic functionality its always good to check you are up to date with drivers.

    Also, the thing about mp3's is that they tend to come in many flavors.  Which means that the software you use to convert them also has to have access to the same codec to read and convert the file.  It's possible you may have to write out to a  more common mp3 type from the original file and then try to convert to .wav.

  • But I'm on a Mac! :(

  • The only change is here is "double click" (on a PC) vs. single click on a MAC.   All other points about drivers, etc. will still apply.

  • So this is still an issue. I did a convert from a video file to an mp3 file using VLC, and the audio (mp3) is unrecognized or unable to be imported into Hitfilm. Saddest part is I just updated Hitfilm, and no fix was included with the update. Is this a common problem with other video editing programs? Because the mp3 plays fine everywhere I've tried it thus far.

  • @SmacLees - make sure you don't write more than one header into the MP3 when you create it, and it will import fine. The issue is only related to files with multiple ID3 tags in the headers.

  • Here's a video that shows how to remove the ID3 tags from the .mp3 audio in with audacity:


    Much Obliged.

  • Thank you all for the tip "mp3->wav", it works for me.

    Thank you also TheRevisionist for the tuto about Audacity, it works too :-)

    But it's a pitty that the software can't manage all mp3 files without additional actions...

  • Been looking for answers to a similar problem with loading audio files into hitfilm4: .wav, .mp3, and some mp4's. Usually it happens after i import one audio file..then my video files.. then if i try to add more audio files it will not load them. so i tried something different. I imported 4 .wav files first before anything else and they all loaded no problem. So maybe try loading your audio first then anything else after. It could be for some reason that once u start editing anything hitfilm says nope: no more files for you. Not entirely sure what i did is a fix but you could try it.

  • I'm in this position at the moment. The audio files were recorded on a small hand-held recorder that has previously imported into Hitfilm without problem, but this time won't. I have tried transcoding them into a variety of formats, including 16-bit WAV via Audacity. The tip in the video embedded above didn't work for me as the fields is says to delete are already empty. To add insult to injury, removing the audio file from the Hitfilm project always crashes the software, resulting in a five-minute wait for the project to re-open.

    However, I have a cunning plan that I'm going to try next. I'm going to open up iMovie (which I thought I'd put aside for good once Hitfilm started working on my Mac after months of refusing to export anything). I'm going to import the audio in to that, put a plain black background to it, and export it as a video file. If that doesn't crack it then I think the only option left is (as suggested above) play it and re-record the output. Assuming that will import once done...

    In general, I'm loving Hitfilm to pieces - so much functionality in free software is astounding, and the add-on packs are reasonably priced. Little irritants like this are, by their nature, irritating - but little.

  • I went into Audacity and converted my .mp3 to a .wav (32 bit) and it still didn't import.  Do I need to use another type? Like .wav 16 bit or something?

  • I convert my mp3 files to .wav here: http://audio.online-convert.com/convert-to-wav

    and it works! try it :)

Sign in to comment