Plugins Not Activating

I have the Hitfilm logo over the transitions on a FXPX project I had archived from a few months ago. I thought I just needed to update the plugins.. I tried and they gave an error and wouldn't instal. Then I updated OSX to 10.11.6 and that fixed the instal.. I instaled the new plugin updates, then activated.. still getting the hitfilm logo over transitions. any idea? 

I'm not even sure where to check the activation for the plugins. I have hitfilm 3 pro 


  • Go to the menu, top right of this page, open the menu and click account. This lets you check (and manage) your installations, get your serial (if needed) and download the most recent installers. 

  • edited September 2016

    I've been playing cat and mouse with Hitfilm Plugins for a week now. No matter what I did I could not a) activate the plugin (the license showed activated but didn't work) and b) completely uninstall the plugins.

    There is no uninstaller for Hitfilm Plugins. On a Mac  you have to move the application to the trash to uninstall...but that doesn't work with Hitfilm Plugins. Remnants of the plugins are littered all over the place.

    So here is what I did..fired up Finder and found all instances of Hitfilmplugins, FXhome, Hittfilm Plugins and FXPlug and deleted them. I have Motion, AE and FCPX so the plugin was installed in several folders.

    I was never able to get the Plugins (Hitfilm Plugins) that came with Pro 3 to work again. Even tried re-installing. No help. I do own Ignite - and in the end that's what worked.

    Motion and  FCPX did not warn of duplicate plugins but AE sure did.

    Very strange adventure to say the least.

    OSX 10.10.5

    Edit - Make sure to show the Library in the Finder by pressing Alt from the Go menu. Look in  /Library/Application Support or /Library/Plug-ins/FXPlug

    To uninstall -  make sure to use the plugin that you used the first time to install. The first instance of the plugin is ver. 1.0.145, the second is 3.1.0173. But as I say this actually didn't work for me.

  • @GrayMotion to uninstall the plugins on Mac you can launch the activation app (/Applications/HitFilm and press the uninstall button.

    Alternatively, installing HitFilm Ignite should remove any previous version of HitFilm Plugins / Ignite to prevent having conflicts.

    Installing a newer version on top should always work (if it doesn't, please let us know). If you wish to downgrade to a previous version for some reason, please use the uninstall button, which removes all the plugins installed in various directories as well as the activation app.

  • @CedricBonnier - Thanks but my post above spelled out the steps to remove Hitfilm Plugins that came with Pro 3. As I stated the install puts the plugins every where BUT there is no uninstall option with version 3. The drag the app to trash does NOT remove all instances of the older version. For me... I had to hunt them all down.

    I was actually trying to help the OP by spelling out how to deleted ALL instances of the plugin and then try to re-install THEIR version. Have not heard back from the OP so don't know if their problem is resolved

    To be clear - there are no problems with Ignite. The uninstall works perfectly every time. I've tested at least a 1/2 dozen times. 

    BUT - Just and FYI - If I uninstall Ignite and try and install the older ver 3 of the plugin AE warns me of duplicate plugins.

    I don't plan to retro grade as Ignite works perfectly and I'm very pleased ;-)

Sign in to comment

Leave a Comment