Graymotion's Production Zone



  • @GrayMotion ,

    Hey man, I took a look at your file a little while ago, just woke up from a needed almost two day long sleep. I know that I need better how to videos so I'll start adding that to my routine right away but I'm pretty sure that I need another full day of being knocked out in bed because I stayed up all last night coding again after the night before because I thought my family was on their way back from their trip and I wanted them to have fresh coffee and stuff waiting for them. They didn't make it back till 11:00am-ish this morning so I could have just gone to bed. Whoops. Sorry I'm rambling. :)

    Select your camera then click "control+a" to apply the scale. Should be set to scale of 1. 

    The camera exporter in Filmer still doesn't like 90 degree turns on the Blender Zaxis/ Hitfilm Yaxis. and it needs the forward camera movement to be in Blender Yaxis/ Hitfilm Zaxis to help avoid Gimbal lock. Sorry, this is where I need better videos and documentation. 

    Till I solve a bit better for euler conversion, it is better to keep the "forward" camera animation along the Blender Yaxis without animating a rotation of 180 degrees in the Zaxis. Your camera animations forward movement is along the Xaxis causing the Gimbal lock. You could create a new Empty and then parent everything in your scene to this Empty. Rotate the Empty 90 degrees so that your camera forward animation path is in the Blender Yaxis/ Hitfilm Zaxis.  

    The empties sometimes hold the animation data better than the camera when imported into Hitfilm. I normally animate a Blender camera with rig made of at least two Empties and never just the camera. One for position transform and the second for rotation transform. Then in Hitfilm if the camera goes off, I can delete its animation keyframes and then parent the camera to the Empty. I've done it this way to avoid Gimbal lock and it has worked on 360 degree rotations on the Blender Zaxis/ Hitfilm Yaxis.

    I need another day but I'll see if I can parent an empty to your camera or copy its animation data to the empty that way you can just export the empty and in Hitfilm parent your camera to it. The important thing is that the camera and the empty need to have the same orientation or it wont work.

    If you want to try/test it. In a blank Blender scene, add an "arrow" empty so that you can see all of the axis represented. Now add a Camera. It should be created in the same 3D coordinates as the arrows empty. The camera is facing down so rotate it 90 degrees in the Xaxis. The cameras forward movement is now on the Blender Yaxis Hitfilm Zaxis. This is a bit safer to avoid gimbal lock.       

  • Thanks Frank. I should have payed more attention to what I was doing. I'll keep working at it. Thanks for all you've done. Most appreciated.

  • You're welcome. :)

  • edited May 2019

    Ok...a model lighting questioned popped up the other day about losing lighting after 1 frame. Now I don't know the exact particulars the original OP's setup...especially playback setting but in my case I have all that properly setup as you will see. I ran several copies of a short capture and then voiced over it please don't be confused.

    So, @Triem23, @tddavis, @spydurhank, @FilmSensei or anyone else who would care to respond. I consider you ALL very knowledgable when it comes to Hitfilm and using models so that's why I tagged you. Do you have ANY idea what is going on with the lights??  The examples is coming from v11. Thanks for your time.

  • edited May 2019

    @GrayMotion ; Only recently, since @FilmSensei 's tutorial on The Orville, did I get comfortable enough to import models into Hitfilm with any success.  Usually I render PNG sequences in Blender and import them, but I do believe that I have had this happen before and chalked it up to my mistakes, (and I KNOW you are ladders above me on models and HItfilm so you aren't making those) but cannot for the life of me remember what file.  I tried to replicate it with this free Voyager model and it doesn't want to do it.  Here is a link to a screen cap of the  Hitfilm project and an actual export of the project.  I'll dig into my projects some more and see if I kind find at least one I know I saw do this before.   :)  I think what I ended up doing was rendering as is and cutting the 1st frame.

    Edit:  I have the lights turned up waaay too much.

  • I've only had something similar happen when I accidentally opened a v12 composite shot in v11.

  • edited May 2019

     Well...really appreciate the response gentlemen. This has been driving me "Miss Daisy" for a few days now. Surely I couldn't be that stupid (I keept mumbling to myself)

    Frank got me to think...version changes. I went back and found the original shot I did in (April 29, 2017). Cant tell what version but I wanna say 8? Not sure. Look at 4:15. You'll notice the model is illuminated  consistently even from Frame 1 (0) on...

    So.. this presents a problem if you want to work on project made previously in newer version of the software. Real bummer if that's the case. I haven't looked at Pro v12 yet as it's just to damn buggy. Paid copy sitting idle really leaves  a bad taste in my mouth to be sure...but I digress...thanks very much @tddavis and @spydurhank

  • edited May 2019

    @GrayMotion ; Absolutely no problem...  I should have mentioned that Voyager was a V11 file opened in 12.3.  It prompted me on save to rename it if I wanted the original to open in earlier anyway.   I want to think I had the problem with a little Defiant model but not sure.  Been rendering my head in that armor spacesuit for a little thing I may submit but not sure yet, so I haven;t got to looking hardcore yet. :)

  •  @GrayMotion that reel is awesome. Got some really nice stuff in there. Makes me want to get to creating stuff again, very inspirational.

  • @GrayMotion ; Well, it wasn't the Defiant or The Orville either. I'm not sure of this, but something is wiggling around in my memory that I may have found that one of the light layers or the camera layer had shifted a smidge and that was causing it for me...But I am not at all certain of my memory these days!

  • @GrayMotion I wish I had something more to chime in with, but I honestly have never had this happen. I did have a situation where an exported frame didn't have the same look as the frame in the clip did, and that caused a lot of problems for the project file I was creating, but I doubt that is the same thing. I watched your video, carefully examining every number that I could see, and I see nothing that would cause that. I am sure that you haven't done something really stupid like keyframed the lights, so I have no helpful advice at all. Sorry! I sure would like to know what is going on though.

  • edited May 2019

    @GrayMotion I think the bug may be related to the color bit depth, what I see here leads me to believe that it's starting out as Linear and switching to integer, there are other bugs that still exist with motion blur also I'll bug @Ady on said bugs :)  

  • @FilmSensei I admit I didn't show enough "numbers" but I assure you I did not keyframe 4 lights. In fact I actually deleted all the lights added one new one. No change.

    @tddavis Sir, don't rack that brain too hard. You have been a great help to me by simply responding with a test of your own. Now if I recall...before the v11 update I "complained" about the environment map doing the same thing. Illuminating for one frame and then nothing but for the life of me I can't find the post where I pointed it out. Now to FXHome's credit they did fix that issue and I have not seen it since.

    @FlyinBanna78 Thank you very much. I must admit that video is a few years old and there is a mixture of AE, Blender and Hitfilm works there and sadly most is not my original ideas. I was teaching myself from other work just to see if I could re-create what they did and for the most part I did "ok". I swear I'm getting better though!

    @NXVisualStudio Tony! Long time no see Master! I'm honored that you took the time to look in - I'm trying hard to remember to do all the things you shared with me. Damn shame you had to see my "complaining" though.

    OK all... A few things here: for one I'm using an older version (v11) so I don't have much room to talk. If I kept up on versions I might not see as many things as I do but currently v12 gives me OpenGL errors like mad, especially when working with 3D models and multiple views. Talk about frustrating! Don't get me wrong I don't expect FXHome to support older version(s) but at times it frustrates me to no end. Sometimes there are no problems and other times they plague me like... well the plague! 

    If I just stuck to titles , 2D, the particle sim and videos like most users here do I'm sure I wouldn't see these problems but sadly that's just not me. I can do all the awesome Titles I want with Motion and video editing with FCPX without the stress that Hitfilm brings to the table for me when doing those things. Just looking in from the outside  it appears I'm the ONLY one having the problems I point out - at least from the standpoint of active users here in the forums.

    Really I'm thinking these days that a lot of my issues arise from Hitfilm's 3D module and certain models I use. After all it's just a reader with a few tweaks and I think I'm really expecting more. I think from now on I'm just going to keep it "inside" until I'm always current with the newest version of Hitfilm. That way I don't sound like a "whiny" baby to the degree I feel I might be doing.

    I do love Hitfilm but MAN.....very very "buggy" for the lack of a better term. From my point of view FXHome seem to be worried about adding more more more instead of fixing what they've got got got. I learnt long ago that if you don't have your shit together as a business/product after 5 years you'll never have it together. If I used the fallback that I'm a young small company just give me time to get your fiber network right I'd have never made it to 5 years..let alone the 25 years. You do realize that you Internet/Network users are a very demanding bunch and there is no tolerance for getting it wrong!

    Enough of that though... I like Hitfilm a lot and I like the fact that this forum exists for users like me to share/vent/ask. Again...I'm not being trying to be mean or talk down the product.. just talking from the heart.

    Thanks one and all for the time you devoted to my issue.

  • @GrayMotion ,

    Dude... that video, whoa! Fantastic stuff. Seriously awesome. :)

    The devs are actually really, really good at squashing bugs, I think we/beta testers could really do a much better job at helping them do theirs. I know that they've asked me to almost annoy them to death whenever I find a bug which are mostly found when working with 3D objects so that they make sure the bug is gone.

    Is there a list somewhere of 3D related bugs that are still present so that we can help move things along? I haven't really been paying attention but the devs have stalled scheduled HF releases at least twice to fix bugs. The last one was for v12. Found a bug where environment map reflections on a 3D object would only render on the first frame. It took the devs a little while to fix it but they fixed it first and then released v12 out into the public. 

    The devs are down to fix anything, we just need to let them know and keep letting them know till they can fix the problem. 

    One quick thing I will say about importing 3D objects into Hitfilm... not every single problem that you run into is a bug.   

  • "One quick thing I will say about importing 3D objects into Hitfilm... not every single problem that you run into is a bug"

    @Spydurhank  Yes sir...I completely agree with and understand what you are saying here. I actually do not like to use the word bug so that's why I try and refrain from using it and I understand that some of the problems are user created. That's why I said late in my comment that it could be me or the models themselves. :-)

    Thanks bud!

  • Thank you for your kind words @spydurhank and others... Just to reiterate on what's been said, from our point of view sometimes we do not fix bugs because we cannot reproduce our end and struggle to understand what is going wrong, other times we see a bug being discussed on the forum, log it onto our internal system but then forget about it. We all have a lot of bugs / features assigned to us so sometimes it is better to focus on the top of the list, however if an important bug has not been set to important it goes to the bottom and disappears quickly.

    We do want to fix issues in HitFilm and that's what we have tried to do with updates 12.1, 12.2 and 12.3. It may seem annoying to you to keep asking for the same bug to be fixed over and over but for us it is good to get a reminder and have a look at it again.

  • edited May 2019

    @GrayMotion I understand the frustration, at one point I bugged the devs so much that it was almost every week I'd remind them I wasn't a happy bunny, back then there was a zeroing issue, if I remember culling/clipping with the camera where if you passed a certain point through a bunch of 3D models they would all freak out creating Z Depth errors flickering all over the shot, needless to say @Ady and @CedricBonnier plus any others fixed it sharpish, here was my response;

    On par with @spydurhank ; they do their best and it can feel so frustrating but just shoot a reminder from time to time and try creating multiple instances that demonstrates said bugs as hardware can create different results I've noticed.

    However @CedricBonnier ; this is a better time than any, a while ago I was working with Ady to nail a motion blur bug here; the issue was that the motion blur would only apply to 1 of 3 frames (1-0-0-1-0-0) creating a stutter, it was fixed in the main camera but the fix wasn't applied to the effects like atomic particles and environment map that also used motion blur built into that effect (Use camera settings) I'll do my best to give many buggings of said issue but hopefully this is sorted as it's long over due, keep up the good work guys.


  • @GrayMotion I just did a quick test using two different types of models, the Battle Cruiser is a LWO (lightwave object) The Nubian City is a OBJ. There is 4 lights in the scene and at first I thought it might have been the cruiser passing in front of one of the lights causing the shadow change towards the end of the clip but the shadow doesn't "Pass" across the city it just goes completely dark all at once. However the lightwave object seems to be fine throughout the whole scene.  The background image is an HDR. So I am not sure if it is more towards a 3d object format or what as I am using the same version of Hitfilm as you are due to mainly working on the laptop the newest doesn't fair so well on it.

    I am going to play around with other types of 3d object formats and see if they react the same with the odd lighting/shadowing issues.

  • @FlyingBanana78 ; it took me a minute, but are you talking about the area of the right landing pad that appears to be a thin rectangle going back under a canopy?  If so, it is super strange that it is limited to such a small and specific area.  It sort of reminds me of that post a while back about textures on StarDestroyers wiggling around.

  •  @tddavis Yes, that is why it struck me as odd being it is only a select portion of the model. and being the model isn't moving either it makes no sense why it should change at all and none of the lights are moving either. Just the 4 stationary lights in the scene. And if it was a shadow of the cruiser going by then it should affect more than just the landing decks section and not just go from lit to straight shadow over a frames period. I already took the models both into Blender and examined them and no doubles nor normals issues on either model.

    I am still experimenting around with some other higher end models and formats I have on hand to see if I can get the same results in the same scene.

  • @FlyingBanana78 ;I'll get back to you on a potential fix to that in a bit.

  • edited May 2019

    Ok. I did about 15 test with different models. The Environment Lighting is the culprit I believe. The vid shows the material settings of 3 good models. I didn't show the environment map I'm using but its a hdri desert with a blue sky. (notice the blue tint in the models on frame 0)

    I can't believe I've missed this for a year? Musta cleaned my glasses somewhere along the line. I actually thought this was fixed in v11? Was there updates between v11 and v12? Yes?

    And have to make pre-render or render  to see  it. If you just scrub or ram preview it does not show up.

    So @tddavis @spydurhank anyone ...since you have v12 could you see if it acts the same please? 

    About 2 minutes...good music if you care to listen and not an old mans crackling voice


  • @FlyingBanana78 Forgot to tag you. Since we have same version you wanna check this too?

  • @GrayMotion I'm wondering if it's related to something I logged a while back, try removing the materials and see if it still happens, bump in particular, if not that then Specularity, it's just a hunch.  

  • edited May 2019

    @FlyingBanana78 for your issue try this, right click the camera in the scene, properties and change near clip distance to around 3 or higher, 'depending on the scale of objects in the scene' once the ship passes a curtain point past the camera only does that happen, if what I suggested doesn't work add a 3D point and select everything including the lights, parent them the that 3D point and in the 3D point scale properties reduce by half, this might fix the issue, don't forget to reposition the camera, if that doesn't fix it, move the camera way back and zoom in within the camera properties. 

    Edit; If that doesn't fix it... it's most curtain 'sudden doom'. 

  • Ok Tony.  No Specular, No Bump, No Materials = Environment lighting disappears

  • edited May 2019

    Not related to my issue, however I followed the steps in the video and mine doesn't have this issue, any clues to how much VRAM you have Sir? 

    Edit; also how big is the HDRI in file size?

  • edited May 2019

    VRAM 8192mb sir - Total Graphics Memory 24553mb


    EDIT : HDRI = 16384x8192

    Project settings : 8 bit, 4x MSAA, Shadow Map 2048, Model map size 4096, Reflection Map Size 512???


  • edited May 2019

    My fine gentleman, one shouldn't be having said issues with that amount of VRAM, I'm still curious on the file size of the HDRI,overall file sizes and material/environment has always been an issue but that's more down to limitation, overall file size and bit depth usually is the culprit for me.   

    Also Edit: thanks for the Edit ;) 

  • edited May 2019

    Ok, take that HDRI into Ps and shrink it down as much as you can 'res and overall file size' and check if that solves your issue, if not you're doomed! momentarily. 

Sign In or Register to comment.