Imerge doesn't run

Today i i tried to open Imerge, but once i click on the icon, doesn't happen. It doesn't run.

I reinstalled it, but the issue remain.

Any tip on how to fix it?


  • What are your system specs? OS, CPU, GPU, RAM, and free hard drive space.

    If you're on Windows, have any system updates been installed since the last time Imerge ran successfully? Are your video drivers up to date? Do you have antivirus software running?

  • Everything is updated (win10, drivers). Imerge worked fine. Today suddenly not (in my laptop).

    Maybe from yesterday, who knows.

    When i reinstalled it (today) in order to fix it, antivirus and User control was off.

    In installed it first without uninstalling it, and then, one more time, after uninstalling it first.

    No success.

    Earlier today i updated my Nvidia Driver.. could that be the problem?

    In my Desktop computer however, i also updated my nvidia driver today, but Imerge is working fine there.


  • It's possible the Nvidia driver update is the problem. Do you have any way of rolling it back to the previous version?

    Why it works on your other system is unknown. The joy of modern computers is that the same update on two different systems could still lead to different results.

  • Yes, this make sense, because , both, computers and gfx cards, are different, so it's possible that the results can be different.

    My laptop is a new HP Envy 13.3" (i5-8250U/8GB/256GB SSD/MX150 2GB) ah0001nv (4CP81EA)


    1. I restored Windows to an earlier time, before the installation of nVidia and before some other new HP (laptop) updates.

    2. I started installing all HP updates, one by one, restarting after each of them, and tried to see if Imerge works after each installation.

    3. Everything went ok, until i installed the Intel HD gfx driver: then, again, i wasn't able to start Imerge.

    Therefore, the cause of the issue was (at least) the new Intel driver.

    I didn't attempt to reinstall the new nVidia driver yet.

  • SamuelMorrisSamuelMorris Staff
    edited January 17

    Hi @Proteas, sorry to hear you're having problems.

    Could you tell me what the exact driver versions are that you think are the problem (and if possible the versions when it worked)?

    It is probably an idea to install the drivers directly from intel ( and nvidia ( than through HP as well.

    When you say it doesn't run, does anything happen at all?

  • I don't know the working version, but it is one version earlier (before January 2019).

    The non-working version is visible in the attached photo.

    When i say "it doesn't run", i mean i click on Imerge, the mouse pointer is turning into hourglass for shorter time than usual and Imerge simply doesn't run. Nothing happens, even if i click again on Imerge.

    P.S. unfortunately, i can't attach the photo. I have no idea what to enter in the "Source". There is no "Browse" option.

    Anyway, the version of the intel driver is this: SoftPaq number sp92704, Version, size 361.84MB

  • Hi @Proteas, it looks like Intel driver is a few versions old (but not old enough that it shouldn't work). This is probably HP giving drivers that they consider stable.

    Could you search for Settings in the windows search box next to the start menu, click on System and go to the About tab. What information is listed under the Windows specifications section?

  • @Proteas ;To add a photo, "Source" must be the URL for the photo on some other site, like your own website (if you have one) or an image hosting service. More info in this thread:

  • edited January 23

    CleverTagline  I am not sure if this is what you expect to read:

    Windows Specification

    Edition  Windows 10 Home

    Version 1809

    Installed on 24.12.18

    OS Build 17763.253

    Btw, i wanted to add a photo (screenshot) that is saved in my computer and not a photo from internet. Therefore, the Search box is not what i need, because i don't have "dropbox" nor "Drive".

    Btw, thank you for the useful information that the by HP suggested Drivers are a few versions old.

  • @Proteas according to this link the 24.x series drivers are for the Windows 10 April update whereas the 25.x series are for the October update (which you have installed).

    It may be that you'll need to update to the 25.x series. However if you can run Imerge fine with the older driver I'd suggest waiting until HP update on their end. It seems like upgrading to the 25.x series is fine, but if you need to downgrade back to the 24.x series it is more difficult.

  • @Proteas ;That was actually Samuel asking for your Windows specs. :)

    As for the image, I understood that you want to upload an image, which is why I mentioned image hosting services in general. However, I probably should have mentioned something more specific, like , which lets you host images for free. Make an account there, upload your image, select it, then copy the Direct Link URL. You can then paste that into the Source field when posting here.

  • SAMUEL: No problem, i will follow your advice and wait for the next HP suggested driver. But i had to report the issue.

    CleverTagline: It's a headache to open new accounts, in order to do something in other accounts (fxhome).

    Therefore, when possible, i will keep trying to describe everything.

    The major problem with Imerge in my case, is not temporary issues like the reported driver above.

    I will open a new discussion to post the major issue.

  • @Proteas If you have an account with anyone else online that lets you host images, you can do that as well. No need to make a new account if you already have one elsewhere that will work.

  • is free and will store/host your images and give you links to post here. On Windows they even have a simple app to capture an image and upload it and give you a link here.

Sign In or Register to comment.