How do I render diffused shadows?

I am trying to render out a composition I did, but I found that after setting a certain level of diffused shadows, hitfilm renders them extremely sharp and I cannot figure out why. I tried to fix the problem by creating another project and doing the same thing but I encountered the same issue. Does anyone know why this is? Or how I can fix it?

Comments

  • CNKCNK
    edited February 12

     Hello,

    Please specify your HitFilm version

    Check out this thread because i believe its likely a shadow map issue But without knowing the light setup its hard to guess.

    https://fxhome.com/forum/discussion/44911/increasing-shadow-quality

    Upload a screenshot to e.g imgur and then link that here so that we have something to go on.

  • edited February 12

    How do I upload a screenshot? And my hitfilm version is hitfilm pro 14

  • What CNK said.  Post to here https://imgur.com/ or some other online photo sharing place.  Then paste the link in the body of your post.  Currently the forum software does not support posting images directly.

  • edited February 13

    https://imgur.com/dAO5zUn - Here's a link to a screenshot from the project file

    https://imgur.com/BB0jNCi - And here's a still rendered seconds after taking the screenshot. 

     

    This was created using just a white plane on the ground set to multiply (for catching shadows) another plane to block the light and make the shadow, and of course the light.

    I feel like there's some setting or something I don't know about but... I don't know.

  • CNKCNK
    edited February 13

     Could this be the difference in exporting your project as a MP4 instead of a MOV with alpha? Give it a try. :)

  • edited February 13

    Is the "shadow catcher" plane Illuminated?

  • edited February 13

    You said "This was created using just a white plane on the ground set to multiply (for catching shadows) another plane to block the light and make the shadow, and of course the light."

    Um. I'm confused so I apologies up front - The ground plane - White plane turned 3d and rotated to match image ground. Scale it up huge. Blend mode to Multiply. Material slot of the plane  - Turn off Illumination. Turn on receive shadows.

    Now - Here is where I am confused...the second plane to block the light. Why not use an 3d object? You have Pro yes? Not sure what your scene is doing.

    Now to control the diffuse of the shadow you can use the light settings - Shadow Opacity and Shadow diffuse to control the shadows intensity.

    EDIT: Ok. I created a plane for the object that is casting the shadow. Basically a circle mask on a black plane. Turned that plane 3d. Blend mode Normal. Unchecked Illuminated. Cast Shadows on.  Fiddled with Transforms Position, Rotation X and Y of the plane. Same result without the use of a 3D object.

  • Triem23Triem23 Moderator

    This isn't a rendering bug, this is an incorrectly set up shadow catcher... @GrayMotion beat me to one of the steps below... 

    So, you have two problems here. The first is the shadow catcher is illuminated, so the shadow catcher is falling into shadow. 

    The second is the shadow catcher isn't big enough to catch the shadow of the object. 

    You're seeing the edges of actual shadow catcher plane. That's the hard boundry. There are two things you need to do to fix this. 

    First, in the Layer Settings for the shadow catcher plane find the material settings and uncheck "Illuminated." 

    Second, make the shadow catcher bigger by scaling it up. 

Sign In or Register to comment.