Missile Smoke not working as I think it should in 3D

I am trying to do what Hit Film Sensei did in this video.


But my missile smoke is going behind my 2d film.  

This is the perspective screen capture showing the smoke clearly behind my layer


This is the Active Camera, where I still see the smoke in FRONT of my video


And these are my layers


I have a clean plate (the back layer in the perspective) and a masked layer in front that the smoke is supposed to be going around.

What am I missing?


  • Your mask layer needs to go above the missile smoke in the layer stack. While calculated in 3D the smoke is rendered to a 2D layer, so elements "in front" need to be above. 

  • @DarrynGlass Make sure the Missile Smoke Effect is set to 3D Unrolled.

  • Or what @FilmSensei said.

    I'm spoiled by Depth Layer options in Pro, Jay. I haven't used 3D Unrolled in a while. 

  • @Triem23 Coincidentally, as luck would have it, I just watched my Missile Smoke video yesterday for the first time in years! It was done in Version 4. I recorded next Friday's tutorial based on it... Light Trails Swirling around me. I did not play with the Depth Layer Options, so that might work also. I would have to go in and see.

  • Thank you!  I don't remember anything about 3D Unrolled, but that did what I was expecting!  There is so much to learn in this software lol

  • Is there a way to reverse the path of the smoke?  It goes clockwise and I want it to go counter clockwise

  • @DarrynGlass Change the Y Rotation Keyframe to go the other way (negative number).

  • Ohhhh! Duh.  LOL.  Thanks!

Sign In or Register to comment.