How can i fix viewer auto zooming in

Hey guys, i'm having problem with the viewer automatically zooming in when i add certain (not all) my clips. I've tried going into controls and adjusting the scale, which works but also blurs the footage. Can anyone suggest a way of solving my problem? To clarify, the Trimmer tab is showing the correct footage, the viewer is showing it zoomed in on the centre of the footage.

Comments

  • edited October 31

    https://imgur.com/8pFToa0 

    Example of my issue

  • Right under the Viewer panel next to the magnifying glass is a down arrow.  Click that and make sure you have Scale to Fit Selected.

    Under the Full drop down are controls for Playback and Paused quality settings.  Check that you aren't using anything less than "Draft".  Just keep in mind those controls are only for speeding up preview in the View port and do not affect export settings. 

  • The selected clip is 4K (3840x2169), what are your project settings? If the timeline is just HD then you'll have to scale down the videos, or they will appear zoomed. Then you'll need to check the quality settings as @Stargazer54 suggested, that would explain the quality loss. The Trimmer will always scale the video to fit in the trimmer window.

  • edited October 31

    I believe @pinthenet ;has hit on the cause, in this situation - your project resolution is smaller than your video file's resolution, and thus the entire video cannot fit into the project, unless you reduce the Scale property for the video. Right-click the video, and select Transform > Fit to Frame.

    Alternately, change the resolution of your timeline to match the video (3840x2169) so the entire video can fit at 100% scale.

  • Triem23Triem23 Moderator

    Note: something that is primarily an NLE (Final Cut, Premiere, Avid, Vegas) will default to scaling footage to fit the timeline - the assumption is you want everything to fill the frame.

    While Hitfilm has an Editor module, it is primarily a compositor, and a compositor defaults to bringing in media at "real size," as a large background might be scrolled around in an animation or composite.

    Another way to rescale a clip is to right click and choose a "Fit to Frame" option. After you scale one, right click it and Copy. Highlight all remaining  (oversized) clips, right click and select "Paste Attributes" to scale them all.

    "Blurry?" take a look at this. 

    https://youtu.be/umHH_3FYWaw

    Since Sensei made this video the playback controls moved to the bottom right of the viewer. 

This discussion has been closed.