Hitfilm Keeps Crashing Randomly

When I am using Hitfilm Express it just randomly crashes with a pop-up, and when I try and send a crash report that fails too. The thing that I don't understand is that before Hitfilm worked fine with my computer, and I don't think it is my computer but I am not sure. I have been able to run Hitfilm for hours but for some reason it can't even last 2 minutes and I am hoping someone can help me. Thanks in advanced.

Comments

  • Well let’s start with the basics. What are your computer specs? OS,  CPU, GPU, RAM. What version of HitFilm are you trying to run? Which version worked before?

  • @Calick it would also be beneficial to know whether you were always using a certain project or certain media, as this could potentially also be the cause. But the specs would probably be the most informative piece of information right now.

  • edited October 30

    @TheBenNorris and @triforcefx My Specs of my computer are: CPU: Intel(R) Core(TM) i7-4790K CPU @ 4.00GHz 4.00 GHz. RAM: 8.00 GB. GPU: NVIDIA GeForce GTX 760. OS: Windows 10 Pro, Version: 1809, OS Build: 17763.805.

    I am using Hitfilm Express 13 and I remember being able to work on Hitfilm for hours in Hitfilm 12, and I have used Hitfilm in previous versions too and they worked fine.

    Thanks in advance.

    Edit: My computer is 64-bit.

  • @Calick is this a recent occurrence? Are your drivers up to date?

  • @TheBenNorris Yes this is recent and my drivers are up to date.

  • @Calick the fact it's recent makes it think that something may have changed on your end. Can you please send us a support ticket so we can investigate further, thank you.

This discussion has been closed.