[SOLVED] Hitfilm watermark in Vegas 17

edited October 2019 in HitFilm Pro Support


When using a hitfilm composite in Vegas Pro 17, I have a Hitfilm Watermark, both on preview and in the exported video. How to remove this ?


  • @Deweak the obvious first question is are you using HitFilm Pro? Do you have Express installed at all?

  • edited October 2019


     Thanks for your answer :)

    I'm using Hitfilm Pro 13 and Vegas Pro 17. I'm a HF Pro user since 2017, never had Express installed in my computers.

  • @Deweak are you using HitFilm 13 or 13.1? The integration with 13 should not work, which could cause issues?

  • edited October 2019

     @TheBenNorris It's version 13.1

    Here is what I'm getting in Vegas viewer and file render :

  • Hi @Deweak,

    Sorry you are having trouble with the software. I've taken a look at your issue here & I can't reproduce what you are seeing, so I just wanted to confirm a few things if at all possible;

    a) What build number of Vegas 17 are you using? For my tests I was using build 321, which is the most recent version.

    b) How are you using the integration? Are you using the Edit in HitFilm option or are you simply importing a HitFilm Project into Vegas. In my tests I used the Edit in HitFilm option, but importing a Project seemingly worked ok also. 

  • Hi @Ady !

    Vegas Build 321 here, too. I'm using the "edit in Hitfilm" option, and as soon as I validate, the watermark appears in Vegas and stays after the editing in Hitfilm.

  • @Deweak - Ok, could I ask you to deactivate HitFilm & re-activate if you haven't already, see if that resolves the issue?

  • @Ady after deactivating / reactivating Hitfilm... problem solved ! Thank you very much, you made my day !!!

  • @Deweak - No problem, not sure how it got into that state, which is something I'll look at. But I'm very pleased that it's now working for you.

    As your issue is now resolved, I will close this thread & mark it as solved. If you have any further issues please create a new thread or contact support here

This discussion has been closed.