Problem with the export - exported video is different to the timeline

Hi. I've just finished a short video. There is a title screen and at some stage I decided to change the text layout because I didn't like it. So in other words, I had an old title and now I have a new one. It's still the same composition and the same layer, I just made some changes to the position of the text.

When I play the movie straight from the timeline (pressing space while editing) it shows the new title as you'd expect. However, when I export the whole movie, it's still has the old title in there. I can actually see it already during the export (and of course it's also in the the exported video itself).

My guess is that HF is somehow caching parts of the video for further renders and it's not registering updates to this particular part. Anyway, regardless of what the reason is, do you have any ideas how to fix it (other than moving everything to a different folder, trying another machine which I have a feeling would work)?

Earlier on with another project I had a similar issue where something looked different too but I actually worked a lot on that composition and at some stage it started to render properly.

TL;DR part of exported video is different to the same part in the timeline

Thank you in advance!

Comments

  • when your exporting are you adding export in and out or all contents? out of interest? I would try and render the first 10seconds before you do the whole thing again to catch the problem first and see why it is doing this for

  • Any tasks added to the export queue store the exact condition of the project at the point when the task was created. So if you added the timeline to the queue, then made some changes, then rendered the queue, the changes would not be factored in.

  • Thanks for coming back.

    GarethOwen I was selecting "In Out". I didn't want to change the export area because there are no markers and I was to lazy to write their timestamps. Anyway, the whole material takes only about 5 minutes to export and the problematic part is pretty early so once I saw the problem in the preview window during the export, I was simply cancelling the whole export.

    AxelWilkinson there's been no changes after adding to the export queue - I tend to avoid that in fact. Unfortunately the render was different to what I could see in the timeline.

    Anyway, I managed to sort it out. I found one text layer that misbehaved, as far as I remember (I kinda had to find the solution, sorry for not updating this thread straight away) I just edited it massively or just deleted it, created a new and copied the text and at some stage it started to render properly (as in exactly how it should.

    I mean, I understand that affecting the project after adding to the queue won't affect the final result, but let me rephrase it: I never made any changes between adding to the queue and exporting.

    I was in a rush to finish this project and I didn't think of marking copies from and before when it happened to see if it can be recreated. However, if I've come across it again, I'll make sure to open a ticket. 

    Thanks for the responses!

     

     

  • I have something somewhat similar so I'm putting it here so I don't start a new topic.

    I have a short 30s clip, edited it, only cleaning up/improving the video, no additions or editing of the timeline.  I export it as mp4 with everything 'from source', including frame rate of 30fps.  When I export, it goes to the window with the exported clip showing on top where you can choose a profile, and the bottom pane where the queue shows.  The top one shows clip as 31:14, queue shows 1:30:00, but exports a 31:14 file!  The frame rate is 30fps so the resulting video is now superfast, plus, there is a lot of added video at the end, repeats of a few seconds of the video.

    Reading the above comments, I may see the problem, kinda.  I edit a lot of short videos, no big projects, no need to take a lot of clips to make one video, so what I usually do is import whatever video I need to work on, remove any clip on the timeline and then add the new one, edit and export.  This works fine for what I do.  This weirdness just started happening.  The clip I am editing was edited before and those repeats that keep getting inserted in my new edit were added.  But, I had re-imported the original clip, I had emptied the timeline, the timeline has only the 31:14 seconds on it, used the 'in-out' export, in was 0:00:00, out was at 31:14, and that old crap keeps getting thrown back in and the frame rate-duration is really doing weird shit.  I have been doing this for a long time, even edited the same source file with different edits, I've never had this unwanted and unasked for holdover.  Why is this happening?  Am I missing something?  I'm sure I could just start a new project but I shouldn't have to and I want to understand what is going on anyway.

    Yeah, tldr, so thanks for anyone who might be able to explain what's going on.

  • Maybe I need to start a new thread.I tried a new project, same 30 sec clip, edited it but no additions, splices, etc.  Duration of the clip is 34:12, that's what it shows in the export choose profile area, shows 4:13 in the queue, exported video is 34:13, somehow the extra scenes keep getting added and then the whole thing is crammed into the 34:12???  This is really irritating and confusing.

Sign In or Register to comment.