Masking an Invisible Layer - Possible Bug?

I have noticed that the ability to mask a layer whose visibility has been turned off is not longer possible in HitFilm Pro 13.0. I am wondering if this is an intentional change in the application or if it's a bug. In Javert's tutorial called "How to create the Upside Down from Stranger Things | 3D Camera Tracking in HitFilm Pro" dated June 28 I noticed that at 1:16 minutes he turns down the opacity before adding the mask instead of disabling the visibility. This leads me to believe that the developers are aware of this and that maybe it was an actual choice to change this. I have included a demonstration video to help anyone who needs it to understand what I am saying...

https://youtu.be/3le4esee5ek

Comments

  • Triem23Triem23 Moderator

    I'll tag in... Oh, @CedricBonnier this time, but my guess would be this is a deliberate change. I seem to remember complaints back around Hitfilm 4 where a user was trying to mask a plane and Hitfilm kept selecting the layer above (in the stack) when he was clicking in the viewer, even with the layer disabled. Seems logical one shouldn't be able to mask a layer that's hidden? 

  • @Triem23 It does seem logical, and I admit that I have accidentally masked the wrong layer myself.  But it also takes more clicks (therefore more time) to turn down the opacity rather than simply unchecking the visibility. It is my opinion that the Locking Layers feature would be very useful in making sure that you don't accidentally mask the wrong layer. Also, I am a believer in personal responsibility... Don't complain about something when you messed up! :)

  • @Triem23 @FilmSensei I'm not sure to be honest. It feels like it should work at least in the layer panel. I'll log it for someone to have a look later

Sign In or Register to comment.