[HitFilm 4 Pro] Missing Fonts After Upgrade to Windows 10

Hello.

I have this weird problem after I upgraded my PC and to Windows 10.

Of course I had to reinstall everything, including Hitfilm. I own the 4 Pro version I bought back in 2016.
I've tried to reinstall fonts I was using before on Windows 7, and none of them work -- not even the ones that I know for a fact previously did. TTF or OTF, doesn't matter.

I was previously using the Russo One font and it worked in HitFilm with Windows 7, despite being OTF format. I've now installed that font and roughly 10 other TTF fonts -- none of them show up in HitFilm but in other programs. I've tried restart, reinstalling, none of it works. And yes, it's directly installed and not a shortcut.

Before you recommend me TransType 4: I downloaded that but it was too new and the site was not secure. Not gonna install that.

Help? Please? :)

Thanks!

Comments

  • Let's start with the rest of your hardware specs. That might give us some clues... CPU, GPU, RAM, system (or mobo) manufacturer

  • @triforcefx What does my hardware have to do with anything?

  • Triem23Triem23 Moderator

    Because Hitfilm renders everything using OpenGL and out of date GPU drivers can cause all kinds of problems. 

  • @Triem23 I don't see how my graphics drivers have anything to do with fonts, but here you go:

    * CPU: Intel i5-9400F (6 cores, 2.9 GHz)
    * GPU: Nvidia GeForce GTX 970
    * Motherboard: ASRock B360M Pro4
    * RAM: 4x 8 GB G.Skill DDR4 = 32 GB
    * OS: Win 10 Pro 64-Bit on SSD (includes HitFilm)
    * Storage: 2x 1 TB internal HDD, 1x 1.5 TB internal HDD, 1x 750 GB external HDD

    And yes, all drivers up-to-date. I know for a fact because I updated them last night.

  • Its great post and help me a lot. please keep continue posting

  • After several Windows updates and whatnot, this issue STILL persists.

    Adobe Premiere sees all the fonts, no problem.

    I checked that all fonts are unlocked by Windows and not blocked.

    HitFilm simply does not recognize any of the fonts after I upgarded to Windows 10. This is ridiculous.

Sign In or Register to comment.