Home Page Won't Load

So recently I've opened hitfilm as usual to work on my projects and out of nowhere, the home interface is not losing anymore. FX Home tutorials won't show up, my project listing won't show up, all that's shows up is the top left corner logo and bar showing (File Edit View Help). Is there a way I can get this initial interface page back?

Comments

  • Stargazer54Stargazer54 Moderator

    @Edmar100 ; The usual question will be what are your system specs?  Did you recently upgrade anything on your system?  Got enough disk space?

    But, you might try re-installing as a first step.  Otherwise, please provide more system info.

     

  • edited May 10

    @Stargazer54 ; Specs are a core i5 8th gen, gtx 1050ti, 12gb ram, 1tb hdd. I havent updated anything recently,  I do still have sufficient storage.

     

    UPDATE: Just after a couple days of this issue being an outgoing problem, its finally fixed itself. Not sure what made it go through that in the first place.

  • Stargazer54Stargazer54 Moderator

    @Edmar100 ; Glad it cleared up.  Other things to look at when you have weirdness like that is make sure your virus definitions are up to date and do a regular virus and malware scan. 

    You specs look ok as long as you have enough free space on disk.  Which OS?  The official windows supported version is now Windows 10.    Make sure your system is updated. 

    Ironically, the virus software itself can be also be an issue.  If you run into this again and are sure your system is clean, you can try disabling the virus software before starting HF to see if that is a conflict.

    Just FYI, I use AVG Free and have no issues with HF under Win 10.

Sign In or Register to comment.