HITFILM 12 and the RAIDERS of the LOST FRAME

Hitfilm Express 12 have a BIG problem.

PLEASE, DOWNLOAD the source files at https://www.dropbox.com/s/bo3xxy3s932e7yd/HitFilm.BUG.rar?dl=0
Decompress at C:\Temp\

When I click in the icon Preview (Alt+L), Hitfilm 12 repeats the first frame in the second frame in the blue area. This causes a misalignment of 1 frame, i.e., the image displayed in the preview is not the actual image. And this also ignores the last frame of the preview (blue area). Please open the project called "Stopwatch with image sequence 59.94fps.hfp" and confirm the problem. Note in the image "A photo of THE BUG.png" that frame 233 should be written "233" in Stopwatch, but that is not what happens. It's are repeating the first frame TWICE!


Note also that Hitfilm has a problem reading the last image file in an IMAGE SEQUENCE of 59.94fps. I have tested on all other framerates, and this BUG only occurs in 59.94fps image sequences. In the example shown, the last position of the second hand (59) does not appear in 59.94fps projects.


The problem is how Hitfilm considers a 59.94fps framerate. It should be 60000/1001, which results in a periodic tithing of
59.94005994005994005994005994005994005994 ...

But Hitfilm But Hitfilm considers JUST only 2 decimal places.
59.94000000000000000000000000000000000000 ...

This is a BUG, an ERROR.

Comments

  • Hmm... I wonder if could be why tracking 59.94fps footage always produces random 'off' frames when you transform the tracking data to a point.

Sign In or Register to comment.