Imerge Pro not able to run on a VM?

I have a Windows 10 Pro VM that I'm trying to test Imerge Pro on and whenever I launch the software, it gives me "The program can't start because OpenCL.dll is missing from your computer."

Could this be because this is a virtual machine and not a physical one?  If that shouldn't be a problem, what can I do to fix this?

The virtual machine is built to the specs outlined in Imerge Pro system requirements.

Comments

  • Hi @dsexton72. In short, yes, unfortunately Imerge is not supported on virtual machines.

    The reason it says OpenCL.dll is missing is because OpenCL.dll is normally shipped as part of your graphics drivers from Nvidia, AMD or Intel. Typically your VM will not expose your physical GPU to the guest OS and you will be unable to use the functionality that Imerge requires.

    The one possibility I can think of is something called GPU passthrough where your host system uses one GPU and your VM uses another. This though of course requires two GPUs and can be quite difficult to set up.

  • Hello @dsexton72.

    Imerge Pro does not support running inside a virtual machine. It uses the GPU via OpenGL and OpenCL and graphics drivers and virtual machines tend not to have the hardware level access those drivers need to function. Virtual machines tent to inject a layer which allows them to be virtual between the software and the hardware they are running on which slows things down.

    Normally, "OpenCL.dll is missing" means you do not have a up to date graphics driver from your graphics card manufacturer installed. Installing those will usually fix this error, but given you are running in a VM you are likely to have other problems (we have not tested it since its not supported).

    If you can, I'd highly recommend trying to try Imerge out on a physical machine with a supported OS installed. You will get a much better experience and it will be more representative.

Sign In or Register to comment.