Some projects unusable after upgrade - Win 7, HFE 11, probable memory leak crashes Windows

I've been enjoying the hell out of HitFilm Express 2017 (5) since late April. I just upgraded to HFE 11 and about half of the ~8 HFP files I have (all for one project) aren't usable now because HitFilm pegs all 4 processor cores at near total capacity and gradually consumes every KB of memory on my entire Win 7 operating system after opening them. Exiting HitFilm also doesn't work -- it never terminates the process, which continues to accumulate memory unless I manually end the process in Task Manager. I let it go for over ten minutes, hoping it would eventually shut itself down, but no luck.

My suspicion is that there's a source MP4 file imported into these particular projects that's missing a character or something in it's format that would normally tell the software where the file or a variable ends, and that the latest version of HFE, not receiving that character, simply spins on forever, gradually allocating more and more memory for that one variable or file indefinitely. It's just a theory obviously, I just have been a software engineer since 1995 and that's the best working theory I could produce from the symptoms.

If I can't get these files to work with HFE 11, I'll have to downgrade back to 5, although unfortunately I can't find my installer for 5... So if someone could help me figure out how to download the older version again, that would be great as well, though obviously I'd like to have these files working in the new version. It seems like this is a support ticket issue? But I wasn't sure if that applied to HFE or if it's limited to Pro licenses?

Thanks,

Sam

 

 

Comments

  • edited December 2018

    I forgot to mention, upgrading the project file to the new version of HFE doesn't seem to help either. I can save the file with a different name in the new version and the new file also causes the same gradual crash after saving, manually stopping the process and then re-opening the upgraded file in HFE.

    Removing the imported assets does seem to fix the problem after a save and a restart. So open, delete all imported assets, save as upgraded file, manually end process in Task Manager, re-open upgraded file in HFE does resolve the problem and I can use the new file, but it doesn't tell me which imported file was causing it.

    Right now I'm examining the XML in the HFP file in my code editor to see if I can figure anything else out.

    Thanks. :)

    Thanks.
     
     
  • @woohooligan ; You can go up to the ACCOUNT label at top right and there you should be able to see all previous versions of Hitfilm that you have ever activated under the same email account.  If you click on the word Install it will open a page with instructions and a link to download that version again.  But this will only work on versions you had activated before as FxHome cannot activate the old versions anymore just reactivate.  Hope this helps.

    As for you thought about a bad mp4 file in your project, if you know the names of those mp4s you might try transcoding them to another format and replacing them in the project to see if that helps.

  • edited December 2018

    -- EDIT: IGNORE THIS -- it was a dead end in troubleshooting. ;)

    Most of the XML in one of these project files is pretty straightforward -- I can see how an assetlayer node references the ID for the asset and how it stores the layer order, in and out points for the asset clip and the start point on the composite shot timeline.

    I notice toward the bottom of the file there's a metadata node with a bunch of values separated into categories by variable type -- boolean, integer or float. The individual values seem to have an ID using the label "K", which would make sense you would need some way to identify that variable, but I can't find any place where those values are referenced, so I can't see how any of these metadata values would be used.
     
    The nodes look like this:
     
    <metadata version="0">
    <bool>...</bool>
    <int32_t>
    <Item V="0" K="1177489200"/>
    <Item V="1200" K="1752931627"/>
    </int32_t>
    <float>...</float>
    </metadata>
     
    So v="1200" obviously is the value of that integer, and then K="1752931627" would be its ID.
     
    I mention it because I notice that a brand new file where I haven't imported any content still has several of these metadata nodes that don't seem to be referenced, and it seemed like if I imported an asset some would likely be created, and then removed when I deleted that asset from the project. However, in a file where I had removed ALL of the assets, there still seem to be dozens and dozens of extra metadata variable nodes (not just the handful from a new empty project), even though whatever content they might have belonged to had been removed from the project.
     
    I wonder if these variables aren't being cleaned out of the XML when items are removed and the extra nodes might be creating problems for HF? If I delete these nodes, would the worst case scenario be having to reset some values in the editor, or is the worst case scenario that the file won't load at all?
     I noit
     
     
     
  •  @woohooligan I'm pretty sure FXHome offers technical support for HitFilm Express as well as for HitFilm Pro, but sadly what they don't offer support for is running HitFilm on Windows 7, so if the problem can't be replicated in Windows 8 or Windows 10 then you might be on your own.

    Probably worth asking them anyway though.

  •  Thanks, J. :)

     
  •  Found a solution. :)

    The problem definitely was in loading imported MP4 files.

    I managed to isolate a series of short clips I had previously exported using HFE 5 from a very long (9 hrs) MP4 of the Kavanaugh confirmation hearings (PBS News Hour). Each clip is rather short, between 5-90 seconds.

    To accomplish this, I had to progressively

    1. open the project,
    2. remove a handful of clips from the top in the few seconds to a minute in which HFE would (slowly) work
    3. save the project
    4. exit HFE
    5. manually end the HitFilm process in TaskManager before Windows inevitably ran out of memory
    6. reopen the project and see if removing those files stopped the problem - If not start again at step 2 - or - if it had stopped...
    7. recover the original project file from a backup and go back to step 2 but remove just the last few files (not any of the files above)

    I wasn't able to establish an individual file that was causing HFE 11 to run away and chew up all the memory, however, when I moved the whole collection to a subdirectory, so that HFE couldn't find those files when loading the project, it stopped happening, which of course didn't resolve my problem, but it told me the problem was definitely in those files (which are no problem for any of my other software like Windows Media Player, etc).

    The same problem occurs when I create a new project in HFE 11 and attempt to import those MP4 clips, and in the new project without any other distractions, I notice that several of the clips have a throbber on them and say "conforming audio" although they all have thumbnails, so I think the problem has something to do with that particular audio import process.

    So I opened the whole set of files in XMedia Recode (https://www.xmedia-recode.de/en/) and "converted" them from MP4 to MP4, placing the "converted" files back in the original directory so HFE could find them. The new files are a bit smaller. I'm not sure if I'm losing quality, but my settings in XMR produce smaller files from HFE's output, often dramatically smaller, which is why I use it before uploading to YouTube. The shrinkage on these files wasn't much, but HFE has no problem with the new files, so that seems to have solved my problem. :D

    Hopefully this will help someone else... I couldn't find anything on the problem via Google search and I suspect anyone who's having this problem will be challenged to find this thread on Google either, but I'd rather it be available anyway on the off chance someone finds it.

    I'd also love to provide a zip with the original files (110MB) to anyone with a Windows 8 machine they'd like to test it on... my wife's machines were both upgraded to 10, so that leaves me without a Win8 machine that could potentially reproduce it. Though I may give it a shot on one of the Win10 machines when I have some extra time.

    JMcAllister Thanks again!

     
     
     
  • All versions of Hitfilm up to v11 work fine on Windows 7 though, so it shouldn't make a difference. One way to check is try the project on a Win 10 machine. If it's still broken, then it's not the OS.

  • Thanks, @Palacono & @JMcAllister

    I solved it. It was the files and not the operating system.

    I left a pretty lengthy comment two days ago that apparently hasn't been approved.

    I put the files in a subdirectory so HFE couldn't find them on loading the project and that stopped the runaway process.

    From there I imported each of the files into an empty project one by one, checking Task Manager to see which ones caused the problem and manually ending the process when it happened and moving on to the next file.

    Once I knew which files were causing it (all of them seemed to be clips previously exported from HFE 5, not raw downloads), I was able to fix those specific files by "converting" them from MP4 to MP4 using XMedia Recode.(I use that normally to compress my exported videos down to a more manageable size before uploading to YouTube.)

    I had a dozen or so files that were causing the problem and all of them work fine after this solution.

     
     
  • Interesting. Did you overwrite all of the problem files, or make new copies as you "converted" them? If it's the latter, you might ping support and see if they want to look at a few of them to find out why they behaved that way, and how to import them without issues (if it's even possible).

  • Thanks, @CleverTagline ;

    Yeah, I anticipated the original files might be useful for that reason, so I did keep them. That's probably a holdover from the habits I cultivated over the couple decades I was actively coding for a living.

  • @woohooligan Sorry I'm a bit late to the party but if you could send us one of those problematic files with a link to this thread, it would be useful. Even if the files are malformed it should not cause HitFilm to hang like that.

  • Thanks, Cedric. :D Sorry I forgot to leave another note here... I sent some files, but I think I sent the wrong files... d'oh! So I resent a file that I double-checked to make sure it was causing the problem. Hopefully it will help. :D

    p.s. I know I'm kind of on my own since Win7 isn't supported, I just wanted to help in case someone else was having this issue.

     
  • Ah, I thought I couldn't reproduce but if you sent the wrong files then that explains it. I'll have a look early next year when back from holidays :-)

Sign In or Register to comment.