Hitfilm 2017 Express cannot open after installation

edited November 2018 in Express Support

I have recently installed a copy of Hitfilm 2017 Express onto my gaming latop, but after completing the installation, I can no longer enter the program. I keep getting this message instead:

Does anyone happen to know what the problem is? If it helps, here are some specs of my computer:

Additional Specs (in case the above photo does not appear):

  • CPU = Intel(R) Core(TM) i7-7700 HQ @ 2.80GHz
  • GPU = GeForce GTX 1050 Ti
  • RAM = 16GB
  • HDD = 128 GB SSD + 2TB HDD
  • OP = Windows 10 64-bit

Comments

  • edited November 2018

    Here is  a link to the image of the problem in question: (Because hyperlinking doesn't appear to work)

    https://imgur.com/5l6HKjg

  • Are your GPU drivers current? Have you installed all critical OS updates? Is your computer a Dell or Alienware? Otherwise, you'll probably need to contact support directly. 

  • On a side note, adding images from Imgur works only if you copy the URL from the "Direct Link" field, and use that when adding the image to a post/comment. The URL in the "Image Link" field is (effectively) a page link, which won't work for image embedding as you noticed.

  • edited November 2018

     My GPU is updated regularly (it was updated right before I installed the program.) My Laptop is a Lenovo Legion Y520. As far as critical OS updates that might be the culprit, I might have one that Vantage has been asking me to update:

    Seagate Rosewood 2D HDD - 10 [64]

    However, I've been reading in the brand's community that it could kill the laptop's functionality (or at least be out of date) and I've been hesitant to install it as a result...

  • edited November 2018

    @JohnDrooney Which version of Express is this? If you are running the latest version (10.0), we have found that some fonts are making the software crash. We've fixed it internally and will push an update asap.

    Did you send the crash report? I can't see any with your email address so I couldn't check if that was the cause of your crash. You can try uninstalling 10.0 and installing 9.1 for now. If this fixes the issue then it is very likely that the next version fixes it for you.

    PS: I've fixed the image links for you in your post, hope you don't mind :)

  • @CedricBonnier It's the latest version of Hitfilm Express. I downloaded it this Thursday.

    I tried opening it today, but no luck. I've taken your advice and sent you a crash report. Hope it helps

  • @JohnDrooney Can you try again with the new version (10.1)? If it doesn't work then please contact support

  • edited November 2018

  • edited November 2018

    Hello. Sorry I haven't updated this lately. New job's got crazy hours that doesn't give me much free time...

    CedricBonnier's advice and upgraded to version 11 (by the time I could get on, ver 11 was released) and now Hitfilm works once more. I can finally get into the program.

    Thanks for the help!

  • @JohnDrooney Thanks for following up to let us know you got it working! :+1:

  • The problem has come back...

    I tried to start a new project, but the program has crashed and I can no longer enter the program again. This is version 11

  • Have you tried to uninstall it, reboot, then reinstall it?

  • I'll try to remember it when I get more time off.

    @CedricBonnier - Am I looking for customer or technical support?

  • In the meantime, would these same problems persist IF I were to buy Hitfilm Pro?

  • @JohnDroony until the issue is resolved that question can't be answered. Pro and Express are the same core code.

    Have you run all critical OS updates? The most recent Nvidia drivers seem problematic - see this thread: https://fxhome.com/forum/discussion/48518/trouble-with-last-nvidia-drivers#latest

    What is your Antivirus? Is it a Dell or Alienware computer? 

    • As far as I know, I believe so. My Windows updates are all up-to-date. I know nothing about Lenovo Vantage, and after one of their recommended updates killed my last laptop, I leave it alone all the time.
    • NVIDIA's GeForce is updated regularly, but lately it cannot seem to download the latest update (Version 417.01) onto my laptop and that was released on the 26th. Could that be a source of the problem?
    • My antivirus is Trend Micro
    • My computer is a Lenovo Legion Y520 Laptop
Sign In or Register to comment.