Could not initialize the MP4 writer (Error 28)

I go to export a 24 second clip and it stops and says Could not initialize the MP4 writer (Error 28) this has been happening no matter what I try. 

My PC specs:

  • Windows 10 Home
  • Intel® Core™ i7-7700HQ processor Quad-core 2.80 GHz
  • 17.3" Full HD (1920 x 1080) 16:9
  • NVIDIA® GeForce® GTX 1060 with 6 GB Dedicated Memory
  • 16 GB, DDR4 SDRAM
  • 1 TB HDD, 128 GB SSD

I dont know if any of that had affected error 28  but I would surely appreciate it if I could fix it, Thank you.


  • @fatpug124 ; I'm no whiz here, but I'm going to guess it might be an issue with the settings of the export.  Have you tried exporting in any other format? If you don't have any sound in your clip, you could try creating a folder and using the PNG export option to see if it will without the error.

  • Some info on what you are exporting can help. Timeline frame size and frame rate.

    Some info on the export settings being used. e.g. Are you using a export predefined preset. If yes, which one. In no, then what were your settings.

    For a problem like this you might be best off contacting support.

  •  Same problem here. Just bought a new Win10 PC and getting the same error when exporting any GoPro 1920x1080 29.970 fps footage.

    Used several export predefined presets resulting in the same error.

    Have same specs as fatpug124  except for the processor which is AMD ryzen 5 1600. Previously I used Hitfilm on my win10 laptop running on some older hardware and the same footage export was working fine.



  • DannyDevDannyDev Staff
    edited March 2018


    Error 28 indicates a file issue, possibly permissions or lack of disk space.

    This error is emitted before any export settings are supplied - it cannot create the mpeg container on disk.

    Is there an .mp4 file with the same name on the export path? Is that file being locked open by another process?

    Can you try exporting to a different file or another drive?

  • I just received the same error code while exporting. I wanted to overwrite a file (which I had not had trouble with before), so I closed out of HitFilm only to discover that I was playing the video file (the one I was overwriting) in another program. After closing out of the video and relaunching HitFilm, I didn't have any further troubles.

  • Has anyone had this issue after updating to the windows 10 April update? or is this a issue that is only affecting my pc? 

  • I have experienced this issue recently, and I have found a possible fix. when exporting your video make sure you don't have a file with the same name, if so, override the file with the edited version with the output-path and Hitfilm should start exporting your video. :) 

  • I've found this on

    • Select Start  > Settings .
    • Choose Update & security  > Windows Defender.
    • Select Open Windows Defender Security Center.
    • Select Virus & threat protection, and then choose Virus & threat protection settings.
    • Under Controlled folder access, turn it off.

    then you can try to save your project again. Worked fine to me  :)

  • I had the same issue going on. Basically, Hitfilm doesn't change your export output option in the export section. I have my OS on an SSD and only have a bit of system space left over. So it was trying to export to the default location ( the c: user documents section) instead of my 3 TB HDD that I had changed it to in the main settings menu.

  • @FXhomer12005

    Bingo, we just hit the same problem here. It appears that Microsoft, in the latest version of Windows 10, has begun locking down directories to prevent processes from writing to them, the desktop folder being one.


  • Hi, 

    I ran into the same problem. However, I did not find a solution to error 28 on this thread. How did you fix it?

  • @mrlost there are multiple solutions to multiple (Windows caused, not Hitfilm) problems in this thread. The first was making certain you aren't writing to a filename that already exists in the folder. The second was making certain you weren't overwriting a file in use by another program, the third was a bulleted list regarding Windows Defender. Have you checked all three of these options already? 

  • edited April 11

    I figured out whats wrong this was driving me crazy all I wanted to do was edit(: but heres what you do for everyone who's having this annoying problem... step 1: Go to file step 2: go to option step 3: go down to export step 4: and finally make sure that your default export directory are set up if not press brows... and select where you want your video to export!!!!

  • I'm experiencing the same error on my Mac. Any suggestions?

  • The Same Thing Happened to me bla, bla, bla, look, i have been trying to fix my computer, changing soft wares, and de-corrupting files for 2 days now. first i used DaVinci Resolve 15,It Worked Like a charm for months. my computer crashes so i decide to upgrade to DaVinci Resolve 16. Can't Open It because it didn't save a shortcut for me to access. By now I'm Pissed right the f*ck off. then i download Window-share Filmora. Can't Export. Then I Download This. GUESS WHAT?!? (if you thought i couldn't export) YOU'D HAVE BEEN RIGHT! error 28...writer... Look. Does anyone have a fix for my computer/hitfilm download?




Sign In or Register to comment.