Action Pro on Linux - experiments with Wine

Edit: To clarify, the following is presented just in case any other users are interested. It is not a complaint or a request, I'm simply reporting my observations.

Breaking News!

Unlike HitFilm, the windows version of Action Pro can be run on Linux, using Wine. 

As far as I can tell, there are only two problems:

1) The 3d-viewer part of the ui does not display. Bit annoying. But despite this, it is still possible to record the movement of the mouse and add it to the timeline. (I checked by saving the project, then opening it in windows, and the movement is correct)

Edit: ^This was/is a GPU driver issue. I solved it by using the open-source nouveau driver instead of the default Nvidia one

2) The activation app crashes, so it is impossible to activate the software. This means that you cannot save out a .hfcs file, only a .animation file... but since HitFilm itself doesn't run in Wine, you would have to boot to windows or mac to use the .hfcs file anyway, so it doesn't really make a huge amount of difference. 

Worth noting that these are almost certainly due to bugs in Wine and not in Action Pro. 


But still, good to know. 


  • edited November 2017

    here is a screenshot demonstrating the missing 3d-view, when running in Linux Mint

    Edit: using the default open-source GPU driver instead of the Nvidia one solved this problem for me

  • While this is stupendous, I wouldn't push at the guys to try and make something for Linux just yet.

    The issue isn't that Linux is incompetent, you have to take into consideration the time, effort and technical hurdles they have to go through, which is, put simply, a ton of money.

    You'd probably need to get them a sucessful kickstarter campaign. And a massive one too, considering that even if they're able to fill the linux niche, they'd need the funds to maintain it. 

  • @Hictor I am aware of FXHOME's reasons for choosing not to develop Linux versions of their software, and while I may personally be disappointed, I can understand and respect their decision.

    While I would love to see HitFilm on Linux I am sure the staff are more than tired of people asking for it, so I (mostly) stopped.

    But that doesn't stop me from testing all their products on Wine just in case... and this one actually worked. So I thought I would post here just in case any other users are interested.

  • @JMcAllister it's not really that we get tired of it or fundamentally don't want to do it. I've been a linux user at home for years and would also love to make HitFilm work on linux but realistically it is a big amount of work to get it working and then an even bigger amount to support it. Testing each feature in Pro and Express, both on Mac and Windows takes quite a bit of time already and I think that adding another OS would not be possible with our current resources.

  • @CedricBonnier I totally understand.

    That's why I (mostly) stopped nagging you lot and I plan to start nagging the Wine people instead

    I started this thread because Action Pro actually works (sort of) in Wine, which I wasn't expecting. And I thought others might be interested to know that.

  • Well that really is exciting news!

  • @JMcAllister ;

    Action Pro is written in an entirely different language and uses a different framework.

    Traditionally, Wine, like most virtualisation layers, lacked access to the GPU which HitFilm depends on, which was a problem back when HitFilm was Windows only and many people were trying to run it on Mac with Parallels and VMWare. I suspect that the framework upon which Action is built is dropping back to software rendering in this case which is why it seems to work.

    Regardless running Windows applications in Wine on linux defeats the purpose of running linux.

    As Cedric pointed out, we're not against a *native* linux port of HitFilm but the effort required, not least the support burden, would be massive, more so than it was to port to Mac. And it would be to the detriment of Windows and Mac versions (fewer new features) so those users would not be pleased.

    I don't see it happening unfortunately.

  • @DannyDev

    "...we're not against a *native* linux port of HitFilm but the effort required, not least the support burden, would be massive..."

    Fair enough.


    "Action Pro is written in an entirely different language and uses a different framework."

    Interesting. That could explain why Action Pro works near-flawlessly in Wine, while HitFilm causes Wine to crash.


    "Traditionally, Wine, like most virtualisation layers, lacked access to the GPU..."

    a) Wine isn't really a virtualisation layer as I understand it.

    b) I'm pretty sure Wine has access to the GPU now.


    "I suspect that the framework upon which Action is built is dropping back to software rendering in this case which is why it seems to work."

    I hadn't thought of that. 

    But the log files seem to indicate that it is using hardware rendering.


    "...running Windows applications in Wine on Linux defeats the purpose of running Linux."

    Well yeah, if you're using windows applications for everything.

    But if you only use one windows program, and it is probably never going to get ported to Linux for the reasons you described? You can see where I'm going with this...

  • While it is excellent that Action Pro works better with the Wine compatibility layer it is more by chance than design I'm afraid.

  • @JoshDaviesCEO

    On a semi-related note, what was the cause of the bug in 0.1 that caused Action Pro to immediately close for some people running windows?

    I ask because having spent several days figuring out how to get the activation app working in wine (and along the way also figured out how to get HitFilm running in wine, but more on that story later), this bug has now reared its ugly head in wine as well

  • @JMcAllister The bug was a permissions issue under Windows and the software being allowed to save the activation info.

  • I was also running into a permission issue in Wine, so maybe it's the same issue.

    Also it's possible that I was in fact running 0.1 in Wine when I had that error. (I was reinstalling quite a lot during my experiments, and I did at one point deliberately install 0.1 to check whether the "update available" box worked in Wine..)

    I will do some more experiments, and perhaps this time actually take proper notes... trying to replicate exactly what I was doing before Christmas is proving tricky since I forgot to make any notes.

    Thanks for renaming the thread, btw. In hindsight, "experiments with Wine" is a much more suitable title than "Yay! It works!" or whatever it was before

  • update: I tested Action Pro 0.3 again today using Wine 3.17.

    I no longer see an issue with the 3d-viewer, so now everything works except activation

  • good news/bad news for anyone else who is following this thread (I suspect it's just me now)

    the good news:

    It is possible to (legitimately) activate Action Pro in Wine. It's a bit of a hack, but it works well enough. I put some instructions up on the Action Pro page in the App database at


    the bad news:

    Action Pro 0.4 has the dubious honour of being the first version of Action to not work properly in Wine. Not exactly sure why, but it seems to be something to do with the way the 3d-cursor now follows the mouse exactly.

  • A brief update for completeness' sake:

    To get Action Pro versions 0.4 and 0.5 to work properly in Wine requires running winecfg and disabling the option to "Allow the window manager to control the windows".

    Disabling that setting also helps with Action Pro 1.0, but as far as I can tell 1.0 has some other issues in Wine as well

  • edited June 24

    I transfer to Linux (Lubuntu 19.04 approximately 1-% CPU usage, 200MB+ RAM idle) for every week now due to the fact I need the performance that it gives than Windows (too many unkillable system services 8+% CPU, 1.5GB+ RAM). 


  • @thomascoello your comment is on an old post and seemingly irrelevant. Your account also has no history, and the bot-like behavior of posting immediately after joining. Please refrain from resurrecting old posts in the future.

Sign In or Register to comment.