Running Ignite Express in Linux

I hope the Ignite Forum is also taking discussions about Ignite Express. If not, please move this impending thread to the appropriate area.

A few months ago (might have been more than a few), I participated in a discussion wherein the subject of creating a version of HitFilm for Linux was brought up. My thought was maybe that a version of Ignite could be created for Linux. Well, I was poking around on the Natron forum and two Natron (as well as HitFilm) users seem to have been successful in getting Ignite Express working on Natron in Linux by using WINE as the virtual environment in which to install Ignite. It appears that, if you can install Ignite in a 64-bit environment of WINE, you can then place the path to the plug-ins in Natron which, in turn, allows them to work in Natron in the Linux environment because the installation is in a Windows virtual shell. Note: they were successful in a Fedora distribution of Linux (all of the linux users will know what this means).

Here is the link to the discussion in the Natron forum. I'm going to try this out this weekend. All kudos go out to Micah Pendelton and EIDirector for finding this out. The posting in question is only 15 days old as of this writing.



  • Interesting.

    I too will test and report back.

  • edited September 2017

    OK, I've now been trying this all afternoon, and no progress.

    I have tried installing Ignite Express 2017 on Fedora 25 using both the most recent stable branch of wine (2.02) and also the most recent development branch (2.17). I also tried using wine 2.17 on Linux Mint 18.2 (my OS of choice).

    Always the same result: trying to run the activation program crashes wine with an error message. Meanwhile the plugins appear to be installed, but pointing Natron at them does not result in the plugins showing up in Natron.

    (Interesting note: the error is similar to that encountered when trying to run HitFilm Pro in wine)


    If anyone else does better, I would love to hear about it, but for now I'm gonna call it a day. A very frustrating day.

  • edited September 2017

    Tried to do it on my CentOS 7 system. Kept getting errors. I surmised incorrectly that if it could be done on a Fedora system, it could be done on a CentOS system (same base: Red Hat). I was wrong. Tried it on the CentOS system because a certain node-based compositor that has a free version for Linux recommends installation on THAT particular Linux distribution. Not going to load up Fedora to test that theory. 

    I apologize if I mislead anyone and am going to wait (as JMcAllister is) for someone else to have success...or until I get bored enough to take a blank hard drive, install Fedora, and give it a go. IF I decide to try and get it working, I will post here (and include screenshots).

  • @Pencilandinc re-reading the original linked thread, I notice that the person who says they are on Linux never explicitly says that they got it to work, and the person who says that they got it to work never explicitly says that they are on Linux. 

  • An interesting development: if I install windows version of Natron through Wine, then the Ignite plugins can be made to show up inside Wine windows Natron.

    The game is afoot...

  • Indeed...the game is afoot. I'm about to check to see if I have 64-bit Wine 2.0+ installed in this Ubuntu 14.04.3 install I have on one of my refurbed towers. If not, I'll install and run Ignite Express and Natron for Windows (if possible) and see what I get. Thanks.

Sign in to comment

Leave a Comment