[Resolved] Install Error

edited May 2017 in Express Support

Hello erverytime when I try to install Hitfilm 4 Express I get this error: An error occurred during the installation of assembly `Microsoft.VC90.CRT,version="9.0.30729",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32". Please refer to Help and Support for more information. HRESULT: 0x80070424.

It would be grade if someone can help me.

 

Comments

  • Triem23Triem23 Moderator

    The problem is your OS. That is a Microsoft error code, but it says you have a 32-bit version of Windows and Hitfilm requires a 64-bit operating system. 

  • I have a 64 Bit system and Hitfilm worked in the past.

  • @Triem23 why do you say this is a 32-bit OS host issue?

    "type=win32" does not mean 32-bit. That name really just applies to the API and the name Win32 has stuck for the API even in the 64-bit era. MS did not make a compatibility break from 32 to 64-bit like it did from 16 to 32-

  • Triem23Triem23 Moderator

    @NormanPCN and Leopard, obviously I am in error. Better that way, as this means it should be a fixable issue. Norman and @Aladdin4d are better than I at tracking these down. 

  • I think that installation issues are best handled by those people who handle them on a regular basis. They have learned to recognize common issues and solutions. The OP is probably best submitting a support request.

    Errors installing VC runtime redistributables can be a pain since there are soo many versions that get installed when you have installed a number of different applications on a system.

  • Aladdin4dAladdin4d Moderator

    The error code (0x80070424) officially means "The specified service does not exist as an installed service". In real world terms it usually means there's a problem with Windows update and/or the Windows Modules Installer service. I would try going through Microsoft's trouble shooting steps and the automated troubleshooter for Windows update.

    https://support.microsoft.com/en-us/help/10164/fix-windows-update-errors

  • Its still not working. I think the last method is to reinstall windows.

  • Aladdin4dAladdin4d Moderator

    @Leopard2858 There are some other things that can cause issues trying to install a Visual C runtime. One is having pending reboot so if by some chance you haven't rebooted yet trying to fix the problem, reboot and try to install again. 

    Another one is corrupted system files. To check for that and hopefully fix any issues found use the System File Checker. Here's a link on how to do that:

    https://www.lifewire.com/how-to-use-sfc-scannow-to-repair-windows-system-files-2626161

    Now as @NormanPCN already mentioned further troubleshooting of Visual C runtime installation problems can be a huge pain. To "help" with compatibility problems of programs compiled using different versions of Visual C/C++ Microsoft came up with the concept of "Side by side" allowing different versions of the same runtime to be installed and run at the same time so each program could always have the exact same version of the runtime it was compiled with. This is great and usually works well but problems do turn up. Even though it shouldn't happen an already installed version of a runtime can block the installation of another version. 

    The solution, such as it is, is to go to Programs and Features, find the runtime that's causing the problem, uninstall it, then run the installer for the app you want to install. The runtime that's giving you the problem is a Visual C++ 2008 redistributable. In the pic below there are several versions installed and there's no good way to tell which one is causing the problem so you either uninstall all of them at once or try one at a time until the installer works. WARNING uninstalling runtimes can/will break and/or impact the stability of the application that originally installed it. In theory the newest version should work for multiple apps but that doesn't always happen and that's why Side by Side exists in the first place. If you want to try this you're pretty much on your own.

    The Side by Side configuration can also get corrupted and as far as I know there isn't a good solution to fix that. The recommended solution is to do an "in place upgrade" of Windows as opposed to a clean install but it's still re-installing Windows.

    One last thing that might work is to install the latest version of the runtime manually before trying the HitFilm installer. If it doesn't install then you're back to what I wrote above but if it does install then it might get you past the problem.

    https://www.microsoft.com/en-us/download/details.aspx?id=26368

    Last but not least if you haven't opened a support ticket FXHOME may very well know an exact solution for you.

    http://hitfilm.com/questions/submit

  • Hitfilm is now working. Windows reinstall solved the problem.

  • Hello ervery time when I try to install Hitfilm 4 Express I get this error "this installer has encountered an unexpected error installing this package, this may indicate a problem with this package , the error code is :2330 " so what can i do sir plz resolve this error my os is 32 bit system

  • @sayan315 ; Unfortunely, Hitfilm will not run on 32 bit systems which is probably where the error is coming from.  Also, if you did mean Hitfilm 4 Express, unless you had a previous installation of it from a couple of years ago you can no longer get the activation codes generated.  I'm fairly certain that FXHOME is only able to activate the latest release of Pro or Express which is Express 2017 and the newest Hitfilm Pro (version 6 unofficially) But again they only run on 64 bit systems.  Hope this helps you out from knocking your head against a wall, and sorry to bear bad news.

  • Hello, i just installed HITFILM EXPRESS free version. But i can't install and open it. It's showing  "some file is missing from the computer".. kindly help me to resolve it. Thanks from INDIA

  • @sahil_cool ; Most likely you want to contact support directly with your issue at:

    https://fxhome.com/support

    But they, or any of the gurus here on the user forum, will need to know the exact error message to be of any help.

Sign in to comment

Leave a Comment