[SOLVED] Render / Export not working

Hi,

I try to export a Composite Shot with two 3d Models, two Particle Simulators, and various Lights. I always get an error at around 52% which says "Process finished unexpectedly" or at the very beginning which says "bad allocation". I also can´t make a Proxy.

Note: I´m using the latest version of Hitfilm Pro 2017.

Comments

  • System specs?

  • Intel I5-6400

    8GB RAM

    NVIDIA GTX 960

    Windows 10

    @Stargazer54

  • Triem23Triem23 Moderator

    Try going into "File>Options>Cache"  and clearing the cache? Failing that, you might try clearing the proxy directory. If you have a bad file in those directories problems can occur. 

    How hefty are your sims? The viewer window has anti-aliasing off by default. When that's kicking in for export, it adds significant overhead to the render. It's possible you're overflowing the VRAM on your 960. There is no way to disable AA on export, so turn that down to the minimum 4xMSAA if it's not already there. 

  • @Triem23

    I cleared the cache and proxy directory. Also the anti-aliasing in turned off.

    It´s still not working.

    Please explain the last thing again, I´m not an expert at this.

  • Stargazer54Stargazer54 Moderator
    edited March 2017

    Triem23 is talking about going to File, Options and then setting the Default Antialiasing Mode to 4xMSAA.

    If that doesn't fix it, then there might be a bug you are hitting.  Try changing parameters slightly in your particle simulator(s).  There is a lot of complex math going on, so your current set up could be tripping a memory leak or some other dreaded "boar head" that is emerging from the code.

    But keep the original file that crashes. It might be worth sending that to support for the devs to look over.

     Update: You can also set Anti-Aliasing Mode under the Project tab.

  • AdyAdy Staff

    @Malik_Patzold - As others have stated it might be a good idea to send us the Project if you haven't already?

    It's the easiest way to replicate issues with Projects, you can contact support here if you haven't done so already & they will instruct you on how to get the files to us.

    Thanks!

  • In this forum here I had a problem with to much info in my comp and H4E says it is not responding! can I send that file to you guys (through what Ady's last comment says) so you can export it for me? All I need to do is have it exported! Thanks in advance :)

  •  @HIS_Films ;

    If For some reason that's beyond the scope of Hitfilm support, I would be happy to export your project for you.  Just send me a link to the needed files and the project file via the cloud storage you use for sharing.

  • Hi,

    I've shot a video in 4K and used Rocky Mountain converter on the files and made them prores422, proxy, h.264 and was able to edit with minimal lag and issues. But now the video is stuck "starting" the export and I really need this video over to my clients! My email is jacksonq08@gmail.com

  • Ok I'm confused here. You say ProRes422, proxy and H.264. That's three different things so did you choose one of the three or mix all three? What's the workflow? Are there any messages other than starting? While you're answering, what are your system specs and OS?

  • i have the same problem.  When the exporting is on 54% bad allocation shows up. And i have done everything you have said. it`s not fu##ing working

  • @JoaKing668 Let's start with the same question everyone else above was asked: what are your system specs and OS?

  • I had that error some weeks ago. When carefully watching memory usage I found out that it supposes to happen when memory is limited (I have manually set the virtual memory). So I increased it by 8 B and then it worked. 

    I suggest watching the memory usage at task manager. Maybe that is the problem.

  • 'bad allocation' is out of memory.

    Try reducing the resolution and/or bit depth of your project.

  •  DannyDev,  how?

    Where do I reduce the resolution?  Where do I reduce the bit depth?
    What impacts will this have on the final product?

  • @DixonJowers You can reduce the project resolution in the Project Tab of the Hitfilm Interface. Bit depth--if you're in Express, don't worry about it, you won't have that option--can also be adjusted from the Project tab.

    Lowering the resolution will, well, lower the resolution of your final project (fewer pixels is less work for the GPU). Bit depth... If working in Pro a higher bit-depth (16-32 bit) can improve the look of certain generated effects like glows and gradients.

  • My exporting is not working either, i accendently deleted the hitfilm pro exports cache from my computer, 

  • @Soccer_Basketball

    This is a really old thread, initially started over 2 1/2 years ago. A lot has changed since then. I’m sure you were just trying to be helpful, but in this case, please start a new thread detailing what the issue is and what you’ve done so far to try and fix it. Listing your computer’s specs (OS, CPU, GPU, RAM, HitFilm version) would also be a good idea. Thanks for your help.

  • @Soccer_Baseball ; if by exports cache you mean the default folder Hitfilm exports to on your Desktop you can go to OPTIONS under FILE at the top of the screen and drop down to EXPORT near the bottom of the list and select Restore Export settings and this will recreate that folder and select it for export.  You can also select any folder you wish to be your export default by using the Browse button there. m I hope I correctly guessed at what you were meaning but if not will try again.  FYI you can also select where you want to export on a case by case basis in the Export Queue by clicking on the OUTPUT tab.

  • click on the place you are rendering make sure its in the HF folder. this happens to me time to time then make sure you render the same as your source files. Then clock ontop of the folder then press render and it should work.

     

    I have noticed for some reason its hit and miss when its render's instead of a straight click to render

This discussion has been closed.