Plugin Bug With FCPX 10.3?

hey, getting a watermark on my hit film plugs in fcpx 10.3- my hf plugs are version 3.1.0173. mac os x 10.11.6

my after effects hf plugs functioning fine, so not sure what's up here.


  • AdyAdy Staff

    Hi @PsychicArchie,

    I have just had a look at your issue here with our test machines & I don't see a problem with watermarks at all.

    Is the actual effect in the viewer showing a watermark or just the previews in the effects panel?

  • edited March 2017

    Hey Ady,

    It is both, here's a screen grab.

    screen cap of watermark

    hmm. insert image didn't work. but, it is both plug icon and output.

    update: i uninstalled and reinstalled plugs (and hit film proper), no joy.

    the plugs in Motion also have watermark on output.

    In Resolve however, everything works as it should.  i don't have Premiere to test, but After Effects functions correctly also. FCPX is my primary editor, so i would like to have the plugs working (use them often) but can work around the issue.

  • AdyAdy Staff

    @PsychicArchie - Yeah the image didn't work unfortunately, could you try an image hosting site like Tinypic?

    Have you installed any other versions of the plug-ins by any chance, like Ignite for example? Or have you only ever used 3.1.0173?


  • i will post the image to tiny pic and update here, thanks for the tip. regarding the version of the plugs, i purchased hit film 3 when it first was released, so have not used ignite (have not upgraded to 4). is there a version of ignite i'm eligible for with my hf3 license? if so i will try it. 

  • edited March 2017



    here's link to pic, hope i did this correctly.

    MOD EDIT: Inserting Picture from link

    @PsychicArchie With Tinypic you want to use the "Direct Link for Layouts" URL to insert an image in a forum post

  • Triem23Triem23 Moderator

    Image link does work @Ady.

  • AdyAdy Staff
    edited March 2017

    Hi @PsychicArchie,

    I can see that you have raised a support ticket, I think it would be best if you continue to reply to Axel & respond to any questions he may have rather than posting here. If a solution is found to your problem I will update this thread.

    Thank you for your patience.

  • edited March 2017

    If I may:

    @PsychicArchie - I had the same type of problem as you with the Plugins

    I fixed my problem following the steps I laid out in that thread.

    Also...MAC is funny. The main user account can become corrupt. Have you tried making a new account with admin privileges and then install the plugins?

    Motion 5 and FCPX support both suggest this and it cured a Motion 5/Hitfilm 3 problem I had.

    Since the mods staff have all but hushed this thread you can converse with me about this in private mail on this system if you want.

  • Hey GreyMotion, thanks for your response, i will check it out.

  • AdyAdy Staff
    edited April 2017

    @GrayMotion - Not hushing any thread, I just didn't want the support team to have to duplicate answers for @PshchicArchie or for them to miss questions, replies from staff and vice versa.

    Helping people on a one to one basis is much easier if the information being provided is all located in one place & not scattered across forum threads and support tickets.. etc.

  • Tell you what @Ady. I'll keep my keyboard quite when it comes to helping folks who need it. That way I won't ruffle ANYONES feathers.

    I hope that the OP @PsychicArchie  got their problem solved as the plugins are a great asset to have in AE, FCPX and Motion


  • AdyAdy Staff

    @GrayMotion - You aren't ruffling anyone's feathers. :) I merely explained my reasoning behind why I wanted the OP to maintain contact with Support.

    Being helpful on the forum is what makes this excellent community what it is, I would hate for you to feel you cannot do that. If I have made you feel that way I apologise, it was never my intention.

    As this is going way off topic, I'll close this thread.

This discussion has been closed.