HitFilmer276253

HI Can anyone tell me the official website for loading  Handbrake. I have downloaded it from https://handbrake.fr/ but when I finished loading it and tried to open it a screen told me I have to load in a piece of software called NET Framework 4.7.1 for it to work. My computer is 64 bit and more than enough memory to handle Handbrake. I used to have Handbrake on my computer but there was a button on it asking me to see if there was an upgrade, so I pressed it and it seemed to go through a process of upgrading,  at the end of the processing it asked me if I would like to delete the old version, so I did and then this screen came up to say I needed NET Framework 4.7.1 to run it, again I did but handbrake won't open. A screen comes up saying there is a problem close the program, Michael Blount

About

Username
HitFilmer276253
Joined
Visits
29
Last Active
Roles
Website User

Discussions