Problem with the app

Hi there!
I think I have quite the unusual problem because I can't find anyone on the internet having the same one. I'm either super dumb and shouldn't be using any computer ever or just unfortunate. Anyway, I downloaded and installed HitFilm Express 2017 yesterday and since then I can't really use it. When I run the app it opens up okay but when I want to open up a new project it takes forever till I can open the "edit" screen. So after it finally opened I saved it (empty project) and now when I open the app via the project file it opens up nice and fast and the app runs smoothly. And that's where another problem is. After I finish editing my video I can't go to the "export" screen (or the "project" screen). The weird thing is it doesn't crash or anything and I can still go back to edit anytime. After I click on the "export" tab and move my mouse it looks like this:

I have no idea what's up but I can't seem to find a solution to that problem. If the solution is more complicated than what I've already tried please let me know so I can stop feeling like a dummy.

Here are my specs:
Windows 10 64-bit
Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz, 2601 MHz
GeForce GTX 960M



  • edited July 2017

    Can you do this "JetBoost" (grab it from majorgeeks of the developers website) and close all background apps, including any AV etc and then try Hitfilm? 

  • ^ Thanks for the suggestion. Tried it but it didn't work. I was hoping maybe the July 20 update would fix my problem but it didn't help either. 

  • edited July 2017

    do you have deinstall and reinstall hitfilm without antivirus-tool (not deactivate but deinst. exept win-defender)?

  • Hi, @chriguf. Just tried it and yet again- didn't work. Thanks for the comment though!
    I'm so close to giving up on this app. It's almost unusable. And it's a shame cos editing is amazing. I really hope something can help. 

  • Triem23Triem23 Moderator

    Are your GPU drivers current? Not that the most recent Windows update rolled GPU drivers back to default, so if you haven't updated your GPU drivers since your last Windows update, the answer is "no."

    You might need to contact support. Something strange is going on with your install, but it's certainly not a common issue or, you'd find a lot more posts about it.

  • @Triem23 Yeap, my GPU drivers are current. Thanks for the comment, I'll do as you suggested. :)

  • Please don't give up yet @crystalc , be patient, a solution is just around the corner.

  • AdyAdy Staff

    @crystalc - If support haven't told you to do so yet, could you please rollback your driver to 382.05. We are currently working with Nvidia on this, but it would appear that rolling back the driver to this version corrects the issue for now.

    Once we have further information, I will update you, unless of course support beats me to it! :) 

  • Triem23Triem23 Moderator

    @Ady odd. I'm on the current Nvidia driver, but don't have this bug. Guess I'm lucky! :) 

  • edited July 2017

     @Yeremyah @Ady @Triem23 Thank you so much for the comments, guys! I've contacted support and already got a reply (which is awesome btw didn't suspect it'd be so quick!) and what I have to do is roll back to an older driver for my GPU cos the problem might be caused by a recent update NVIDIA issued for their drivers. Support suggested rolling back to driver so I'll see how it goes. :)
    It worked you guys! Thank you all for the help. 

  • AdyAdy Staff

    @Triem23 - It affects only certain configs, usually those with multiple GPU's, one being the Intel HD & the other being an Nvidia.

  • Triem23Triem23 Moderator

    @Ady I'm guessing specifically the HD4000 since I have an integrated HD530. 

Sign in to comment

Leave a Comment