HF Pro 2017 Import Issues

edited November 2016 in Pro Support

I can't import MXF X-AVC recorded by Sony Z100. Same for 4k CineForm AVIs. HitFilm Pro 2017 just ignores these files when trying to import.

EDIT: Oops, I can't even import simple AVC (rendered by HandBrake, all media 4k).

EDIT 2: Very strange. I did reboot my system twice but I can't import any kind of media into HitFilm 2017 no more.

Looks like this happens since I deinstalled HF Pro 4.


  • @Avalon - Un-installing HitFilm 4 should have no bearing on what files HitFilm Pro 2017 supports.

    What are you trying to import other than the CineForm .AVI's you've mentioned that also don't import?

    Any chance of you uploading a sample of the files you're attempting to import so we can try them here?

  • edited November 2016

    I tried seven different media types now. Three of them are 4k – CineForm 422 rendered from Vegas Pro, 4k X-AVC recorded by a Sony Z100, MainConcept AVC rendered from Vegas Pro.

    Also 720p50 AVC recorded by a Pana GH2 which worked 1 hour ago in the demo version of HF Pro 2017 and 1080p25 AVC rendered by HandBrake.

    Also a simple PNG and JPEG grafic file. No media works no more.

    I will now go on to deinstall and reinstall HF Pro 2017 before uploading a sample.

  • O. k. Just did a clean re-install of HF Pro 2017.

    I can now import PNG, JPEG, AVC (both MainConcept from Vegas Pro as well as HandBrake) and GH2 files. 

    X-AVC files (MXF) recorded from Z100 do import but decode of the files is crushed. Files are unusable. 
    Is MXF X-AVC supposed to work in HF Pro 2017?

  • Oh no. Started a new project and again I cannot import any kind of media. 

  • @Avalon Unfortunately XAVC is not currently supported by HitFilm so you'll have to transcode to Cineform first

  • I wonder whether scopes are involved in this kind of issue. The scopes panel is causing all kind of trouble here and often freezes HF processes.
    Turned scope panel off now and tried several times to open and start new projects with importing mixed media and with scopes off it seems to work fine.

  • edited November 2016

    Well, I can repro any time if

    - I start using project template "4K DCI 2160p @ 25 fps".
    - I have scope panel turned on.

    Doing this I can't import any kind of media and also (if media was imported before turning scopes panel on  or  before switching project properties to 4k) I cannot drag existing  media into the timeline.

    I have to close the running project before restarting with different project properties or scopes panel turned off. Turning off scopes panel within existing 4k project does not work. Changing project properties of existing project works but does not help. Starting a new project from within the running one doesn't help either. I need to close the running project first and have to use a 4k project without scopes panel or scopes panel within an HD project instead.

  • Is it working for others?

  • @Avalon I can't reproduce it here, that's strange. I can't think of what could cause this...

    Just to confirm, if you have the scopes panel open, you cannot import anything, including pngs and jpegs? Could you post a screenshot here of the message you are getting?

  • edited November 2016

    Both conditions must be true to repro:

    - Using a project template "4K DCI 2160p @ 25 fps".
    - Scopes panel turned on.

    There is no message then. Trying to import media does – nothing (yes, not even JPEG works, no media at all works).

    Also the issue I mentioned in an earlier thread then occurs again:
    I can't switch the scope view from histogram/parade/vectorscope/waveform to another one, nor can I switch the scopes panel from single/double/tripple/quadro scopes to another one. Just nothing happens when I click onto one of these view option buttons.

  • @Avalon could you please add a screenshot showing the issue?

  • Yes, I could (and will do). But you won't see the issue on a screenshot as there is just nothing happening. A screenshot would/will show HitFilm with scopes panels opened and an empty import section. Will make and upload the screenshot asap though I doubt it could help in any way.

  • edited November 2016

    O.k. - here is a screenshot which shows HitFilm Pro 2017 (4k DCI 2160p @ 25 fps) with scopes panel on after I tried importing a JPEG file:

    HitFilm Issue

  • You can have a reference at this resource to find the detailed workflow for Hitfilm 2017:


Sign in to comment

Leave a Comment