Fatal error when import and saving![WIN10]

I yesterday downloadet hitfilm4express and was happy at first: When i was finished setting all the stuff up i created a new project just to try it out. When i tried to import new files the explorer opened...fine...NOT the program crahed giving me a fatal error. I tried to clean the registry witch CCcleaner and so on but didnt work..!

Thanks for any help!


  • Triem23Triem23 Moderator

    System specs? CPU, GPU, OS, RAM and storage? Is your computer a Dell? 

  • It is a Dell Win10 64bit. I7 4790@ 3.60GHz 4 cores

    RAM:16GB DDR3 @798MHz


    STORAGE:1TB HDD (thats what hitfim is running on) 250GB SSD

    Thanks for the reply!

  • Aladdin4dAladdin4d Moderator

    You have two problems - First Dell Backup and Recovery causes problems with a lot of software packages including HitFilm so if that's installed it needs to be removed.


    Second you have a workstation GPU and unfortunately HitFilm does not support workstation GPU's. If you can set HitFilm to use the Intel HD 4600 instead it should run but the Intel HD 4000 series is minimum spec for HitFilm

  • edited April 2017

    Arghh!! yea thats kind of not god :( but how can i get hitflim to use the INTEL GPU?

    and by the way when i restart the pc it works but when i tab out and back in to hitfilm it crashes.

    To make it understandable:Restart the PC--Open HITFILM--Open PROJECT--Then tab out to look something somewhere--tab back in--BOOM crash--restart hitfilm--Crashes every time i trie to import!

  • Aladdin4dAladdin4d Moderator

    Open up Catalyst control Center/Crimson software, go to the Power section and look for "Switchable Graphics" You should be able to select HitFilm from the application list or browse to the HitFilm executable to add it to the list and set which GPU to use. 

    If you don't find anything on Switchable Graphics the option to switch might be disabled in the bios.

  • Uhm yea i wanted to buy a new PC anyways so looks like its time for it thanks for your advice!!

Sign in to comment

Leave a Comment