Latest update won't install due to error

edited July 2016 in Express Support

Latest update (HitFilm4Pro_x64_4.0.5422.10801.msi) won't install due to error.  Wanted to add image but is not possible.

This is the error:

"An error occurred during the installation of assembly 'Microsoft.VC90.CRT,  version="9.0.30729.5570", publicKeyToken="1fc8b3b9a1e18e3b", processorArchitecture="amd64", type="win32". Please refer to Help and Support for more information. HRESULT: 0x80070091.

Previous version was uninstalled. Tried install again and it worked.

Finally I just send this for information purposes only.

Kind regards,



  • Hi @DWMP,

    The VC90 error is a fairly common issue related directly to your Windows installation rather than HitFilm itself (it just happens to interfere with the installation process).

    If it comes up again, here are some steps you can follow, courtesy of the Windows support forums:

    Method 1
    Make sure that the Windows installer service is running on the computer.
    a) Click Start, click Run, type services.msc in the Open text box, and then click OK.
    b) In the Services (Local) list, right-click Windows Installer, and then click Properties.
    c) If the Startup type drop-down list is set to a value of Disable, select the Manual option from the Startup type drop-down list, and then click OK.
    d) Click the File menu, and then click Exit.
    Method 2
    Make sure that you have installed all the available updates for your Windows installation.
    Install Windows updates for your installation. All optional updates must be selected, with the exception of those that relate to language changes. Please pay particular attention to those that mention C++ or .netframework

    Method 3
    Start the computer in clean boot and then try to install the software to check if any third party program is causing the issue. To configure your computer to clean boot refer the following link.

    Note: After you have finished troubleshooting, follow step 7 in the article to boot to normal startup.
    Method 4 
    If the issue persists then, update the Visual C++ Redistributable Package and check if that helps. Download Visual C++ Redistributable Package from the following link;

  • Hello!

    I have tried doing all of the Methods here and I still get the error. I have updated everything, I have tried the clean boot, and I have the latest version of the C++ Package. Still won't install, still get the error. Is there any other way I can install the program?

  • edited January 19

    This fixed my windows 10 problem  try -

    Mod Edit: Link removed

  • @Crackskullin I don't think that link is what you meant to post.  Perhaps this? (extracted/interpreted from that excessively-long URL)


Sign in to comment

Leave a Comment