Using HitFilm 4 with multiple GPU's (Resolved)

edited December 2015 in Express Support

I'm using HF4 Demo but all my import video isn't showed on view screen.

Not just video I import, even planes won't be showed. HF4 only shows the audio of video.

And the view screen of pop up window when I'm importing 3D Model also shows the black screen.


  • I have the same issue (or something very similar) using the Hitfilm Pro 4 demo.

    Video will display in the trimmer normally but when it gets added to the editor or compositor timeline, the viewer window remains black. Also, I have not been able to get any other type of element such as a plane to display in the viewer.

    If I try to change the viewer rendering quality from FULL to HALF the software will always crash with the following error message:

    'An OpenGL error occurred while trying to render your project and the applcation must now exit.'

    I'm not too bothered about this issue currently because Hitfilm Pro 3 is fine for my needs.


    OS: Windows 8.1
    CPU: Intel Core i5
    RAM: 8 GB memory
    GPU: Intel Iris Graphics 5100

  • Absolutely the same here (also using the demo)...

    But only when using the Intel HD4000 GPU (which HF4 supposedly supports).

    The viewer window will show the video on the timeline if I am using the other GPU on my laptop (GT650M).

    But, since this should work with the HD4000, it would be nice to hear if this is a bug.

  • Hm, this does sound GPU-related. Have you all got the latest drivers installed?

  • KoDuty - Can you provide some more information about your machine please? It's hard to diagnose a problem with little to no information about your set-up. Thanks

    efolve - Please update the drivers for your Intel Iris GPU, you can do this from this link: Intel HD Driver 

    Aph - You should always be using the Nvidia GT650M as it's a better card than your Intel HD 4000. But again the reason why you experience problems with the software on your Intel HD is probably due to an outdated driver. Please visit the link I posted above for efolve & update your driver, your problems will then go away. But I'd always recommend using the Nvidia card over the Intel HD.

  • My 9 month old HP laptop with Intel Iris 5100 graphics seems to be engineered by HP to prevent display driver updates sourced direct from Intel.

    From an Intel support page: "A customized computer manufacturer driver is installed on your computer. The Intel® Driver Update Utility is not able to update the driver".

    I tried to manually install the latest driver from Intel following Intel’s instructions but that failed for the same reason as above.

    Finally, I went to the HP support page for my specific model of laptop and downloaded the latest Intel High-Definition Graphics Driver (dated November 15, 2015). I ran the setup program; the installation ran successfully and I re-booted. Result: the demo version of Hitfilm Pro 4 has the same blank viewer issue as before. Hitfilm Pro 3 works fine. On further investigation in the Windows device manager, the 'updated' display driver that I installed turns out to be no newer than the one that was in place previously. The details for the updated graphics driver properties are:

    Intel Iris Graphics 5100
    Driver Provider: Intel Corporation
    Driver Date: 24/04/2014
    Driver Version:

    Having spent most of the morning trying to resolve the issue, I think I'll just give up and stick with what works, i.e., Hitfilm Pro 3.


    OS: Windows 8.1
    CPU: Intel Core i5
    RAM: 8 GB memory
    GPU: Intel Iris Graphics 5100

  • -------------------------------

    Laptop: ASUS G550JK

    OS: Windows 8.1

    CPU: Intel Core i7

    RAM: 8Gb

    GPU: NVIDA Geforce GTX 850M

  • My HF4 crashes when I put imported video into timeline. It wont crash if I create comp, but the view screen shows only black color

  • AdyAdy Staff
    edited December 2015

    efolve - Sorry I realise this is a frustrating experience for you & I can only apologise. Sadly we cannot help if a manufacturer locks out the updating of drivers, I thought they had abolished this but it appears I was wrong. 

    HitFilm 4 is a significant upgrade from HitFilm 3 especially as to what happens under the hood (so to speak), this requires the latest drivers in order to use these features. I'll see if there are any other workarounds for HP systems (I have an HP system at home also) in order to get the latest drivers.

    KoDuty - Your system probably has 2 GPU's like Aph's system, can you make sure: 

    a) Your Intel HD driver is up to date: Intel Driver Update

    b) Your Nvidia driver is up to date: Nvidia Driver Update

    c) HitFilm is assigned to the Nvidia GPU: Nvidia Optimus Profiles


  • @Ady I have a licensed version of HF4 and I'm having the same issue on a Mac. I've opened a support ticket for this under my account.

    How can I change the GPU assignment to see if that fixes the issue?


    Here are my system specs:

    MacBook Pro (Retina, 15-inch, Mid 2014)
    2.5 GHz Intel Core i7
    16 GB 1600 MHz DDR3
    NVIDIA GeForce GT 750M 2048 MB

  • Thanks for your assistance, Ady.

    I managed to summon up enough perseverance to have another go at installing the latest Intel GPU drivers. After looking for solutions on the web, I followed the instructions on this web page:

    Success! I can now run the demo of Hitfilm Pro 4 without any issues.

    (Earlier in the day I had followed instructions on Intel's support website for forcing the update, but these were markedly different and the installation failed).

  • cshreffler - The Mac OS does this automatically I believe, although I think there is a 3rd party app that you can install that you can then force the selection GPU. You can find the app here.

    efolve - Ah, no problem, happy to help, I'm just sorry your experience hasn't been a good one. But I'm very pleased to hear that you are up & running, that is great news. Thank you for the link also, I've bookmarked that for future users who may have issues with HP driver updates, very useful information to have.


  • edited December 2015

    OMG Tks Ady I fixed it!!! I just:

    - Download Intel® Driver Update Utility, although it scanned and says nothing to update.

    - Set runs HF4 with High-Performance NVIDIA Processor mode.

    And HF4 works well!

    I don't even download NVIDIA driver because it automatically update when new driver's out

  • KoDuty - Great to hear that you are up & running! I'm going to mark this thread as resolved & close it as the issue has been resolved.

This discussion has been closed.