How to Use VirtualDub FilterMod to fix VFR issues and convert to Cineform



  • @ProCrash And you were able to import that back into HitFilm?

  • VirtualDub filtermod now supports Cineform natively. v40538

    Cineform system codec installs no longer necessary. VirtualDub can now deal with Cineform in any container it supports. It's just mux/demux.

  • @NormanPCN I figured native Cineform support was coming but even so this was pretty quick!

  • @Aladdin4d well, when this happened

    I kinda figured people would make their own versions/drivers anyway. It's probably something the dev coded two years ago, given a quick dust off and released from "personal use" to the wild. 

  • AFAIK, The SMPTE spec was free to SMPTE members. Also, VC-5 is not 100% binary compatible with classic Cineform. At least according to the guy who did the libavcodec/ffmpeg Cineform decoder. He wrote from the spec and it did not properly decode Cineform files in the wild.

    Really VirtualDub already had all of the features to do much of the work. The file identification and the demuxers and muxers and Vdub support just about every frame type that exists.  All this is independent of any specific codec like Cineform. Decoder/encoders are magic boxes with two holes. One hole for input and the output from the other hole. Really a decoder just accepts the demuxer chunks and returns one or more frames. An encoder just accepts a frame and returns a compressed frame. So unless the encoder/decoder code you receive, like Cineform, has some odd ways of working or unusual requirements it should be pretty straight forward to incorporate into your existing file demux/mux framework.

  • @Aladdin4d  Support took a look at the files that were not working for me and said it appears that there is a bug related to certain Cineform files. It has been logged so the developers can try to identify the specific cause, and develop a fix for it.

    What doesn't make since to me is why did the files that you converted and worked in Hitfilms express 2017 for you not work int Hitfilms express 2017 for me?

    Ill try converting  to Cineform  using the new VirtualDub See if that works 

  • @ProCrash You got me! I wish I knew because your situation is definitely out of the ordinary. Do try the latest version of VirtualDub FilterMod though. It and HitFilm both use the Cineform SDK now so in theory, that might avoid a bug. 

  •  Hello! Could you guys help me with my problem? After compressing via virtualdub to cineform format i have a lot of artifacts in my footage (a lot of white dots in the black areas). How can i fix it? I tried to change quality up to filmscan3, but no effect. Thanks in advance

  • Any idea, guys?

  • @AL_ien Not off the top of my head no. Have you tried just using HitFilm to convert a clip to see if you still have the problem?

  • I cannot open this .mov file in hitfilm, that's why people from other topic in the forum told me to convert it to cineform :(

  • edited January 20

    When I transcode like it is described here the resolution video includes TWO copies side by side. I don't know how to get rid of it. Other codecs in virtualdub work as expected, the Cineform (native) produces this one (With loss of resolution, source is HD, this one is HD but two pictures)

  • edited February 26

    Hi all,

    @ProCrash & @Aladdin4d  did you end up having any update/solution for this?

    I have the exact same behavior as @ProCrash for cineform compression on virtualdub_filtermod. Hitfilm Express just says "file error". When I click on clip properties it says "The media could not be imported". Any help would be very much appreciated.

    Also, on another topic if I try to run an HEVC (from a GoPro) on virtualdub_filtermod it opens alright, but when I got to File, Save As  and save it, a Microsoft Visual C++ Runtime Library window opens up stating that the application has requested the Runtime to terminate it an unusual way, and it basically terminates virtuadub filtermod. Any idea why? --- After a couple more tests, it seems it only happens for footage at 4k 60fps.. 1080 at 240fps which is supposedly using the same HEVC/ H265 codec, there is no "runtime error"...



    So, quick update on this. I caught another topic with the last reply dated April 2017 (see link below) where the sound/audio was apparently the problem with the exported footage of virtualdub with cineform compression. So, just tested that and if you choose the "No Audio" option on virtualdub, the output file is imported just fine by Hitfilm. I also tested this with the files made available by @Aladdin4d  on the google drive folder and I can't import those to Hitfilm just like @ProCrash had reported (guessing audio was there).

    Cineform import to Hitfilm (audio issue)

    On the second topic about the 4k @60fps footage causing "runtime error" I opened a ticket directly at sourceforge on VirtualDub FilterMod page and got an immediate answer by Anton Shekhovtsov advising to use the x64 version (Veedub64.exe) instead as this was most likely an "out-of-memory" issue. I did just that and no more problems with any footage, being it H264/265, 1080 or 4k, Cineform or not. 

    So, just need to work on that audio issue and everything works!



  • The audio import issue from a Cineform file could be due to 32-bit float audio being exported from Virtuadub. With some source audio formats Vdub will default to 32-bit float audio. Just make sure 16-bit audio is selected and you should be fine.

  • Thanks for the comment @NormanPCN.

    For what I'm doing there isn't really a need for audio so I didn't get a chance to try the 16-bit audio selection as you mentioned but I'll surely give it a try soon enough, 

    Thanks again

  • Hi Guys,

    I am using VDub Filtermod to combine the new GoPro HEVC / H.265 files and convert to Cineform, using the setup described above.  I am able to open the first MP4 file and append a further two video segments but, if I append more than two segments, the thing crashes at the end of the conversion, with the message: "Out of memory (unable to allocate 1203211 bytes)".

    I have 32GB and, according to Task Manager, VDub uses 6 or 7GB during conversion.  Works fine with H.264 files.

    Anyone else had this problem?



  • Aladdin4dAladdin4d Moderator

    Go to your VirtualDub FilterMod folder, launch Veedub64.exe and try it again. The default VirtualDub.exe is a 32 bit application. Veedub64.exe is the 64 bit version and should take care of the memory problem.

Sign in to comment