HFP file not recognized by software

Hello everyone,

A few days, I' just installed the new version of Hitfilm Express 2017 on my Mac Book Pro 2015. I found that the .hfp file is not recognized by the software (see attached picture) hfp file

I said to the system that this type of file opened only with Hitfilm Express 2017..

But why .hfp files are not recognized by Hitfilm Express 2017 in this new version?

Thank you for your comeback and comments.


  • have you activate the new version correctly?

    is it the same, when you "open" the file directly with hitfilm or doubleclick the project?

  • @Igcom

    I would try the two things @chriguf said... If they don't work, I'd suggest issuing a support ticket...

  • @chriguf yes the instal had corrected and activation is correct.

    No in Hitfilm software, I' haven't problem.

    +1 for @Fillm_Empire 

  • @lgcom So this file opens without errors in HitFilm? If you open HitFilm, create a new project and save it on your desktop, does the file have an icon? Last question, have you got any prior versions of HitFilm?

  • hello @CedricBonnier none error if file is open in Hitfilm. 

    See picture 

    On the left : 2 files from old Hitfilm Express (before July 2017 )
    On the right : new file with (new) Hitfilm Express 2017 (after july 2017).

    None icon with old or new Hitfilm.

    If I' click on the file icon from Desktop, the file is not recognized by Hitfilm (except if I' said to the system : this file must be open with Hitfilm).  


  • @lgcom could you please try removing all your versions of HitFilm, empty the bin and then install the latest version that you can find here: https://hitfilm.com/software-update/hitfilm-express-2017

    Does it work after doing that?

  • @CedricBonnier 1 hour I'd re-installed the new Hitfilm Express version and the result is the same ! :) 

  • edited September 2017

    You need to remove completely ALL versions of HitFilm, not just the latest version. I suspect your system is getting confused with what application can open these .hfp files. It may be trying to find a version that you have now deleted. Running the installer again with no other known application capable of opening .hfp files may fix your issue.

    PS: once you've solved your issue, if you want to reinstall old versions of the software, you can get the download link from your account page

  • OK @CedricBonnier !

    I'removed complety all versions and removed all shortcuts and files with Clean My Mac App. I' restarted my Mac Book Pro.  I're-installed the Hitfilm Express 2017 from download link from my account page

    And the result is the same :( 

    When I click directly on the icon file, the file isn't recognize by the system or the software. When I' open Hitfilm Express 2017, the file is recognize inside the software. 
    With the previous version, I did not have this problem.

    What must I do now ?

  • @lgcom If you add HitFilm to your dock, can you drag the file on top of the doc icon to open it? If you double click the file, does it open HitFilm or does it not work at all?

  • edited September 2017

    HitFilm is already inside my dock and when I' drag the file from the top to the dock Hitfilm icon, the file is correctly open in Hitfilm Express 2017. 

    When I' double-click on the icon file from Desktop or everywhere, the result is SEE PICTURE below : (same result for every .hfp file) 

  • maybee this helps...

    open with ctrl and mouseclick the .hfp on desktop, select information, and select "open with..." and at the bottom "other programm", select now the the new hitfilm-icon at new location.

  • @chriguf thank you but it's already tested in prévious installation before my first post here. 

    The Hitfim file icon on the Desktop remains  blank and is not recognized as a Hitfilm file.

  • do you have make a PRAM reset?

  • @lgcom So you right clicked the .hfp file, opened the get info dialog, changed the open with to HitFilm Pro 2017 and clicked "change all..."? And even after that double clicking the project file doesn't open in HitFilm?

    I'm not doubting what you said, I'm just making sure I understood properly before suggesting any other solution.

  • @CedricBonnier this is starting to sound like a Windows issue. HITFILM is loading the project but the icons aren't showing on the desktop correctly and project files aren't linking to Hitfilm via file association. 

    Maybe clean the registry? 

  • @Triem23 it's on macOS but yes it sounds like it is a system config that didn't get updated. I just don't want to jump to the command line solution unless we have to.

  • edited September 2017

    i think, the mac-os hitfilm-devlopper specialiste  must help him to clean the library/application-folder from hitfilm-things... 

  • edited September 2017

    yes @CedricBonnier  that's right ! 

    After the click the window opens and I' choose Hitfilm Express 2017 software  

    Yes Hitfilm Express 2017 is on my Macbook Pro 2015

  • some news @CedricBonnier  ? 


  • @lgcom After some more digging, it turns out that we had one mac that had a very similar issue. I should point out that changing the Get Info > Open with to for example HitFilm 2017 would not update the icon but double clicking the project icon on the desktop would open HitFilm 2017 as expected. You do not get this as far as I understand?

    To fix the icon, I ran a few commands in the terminal (please ask for more details if you're not familiar with this).

    • sudo rm -rf /Library/Caches/com.apple.iconservices.store
    • sudo find /private/var/folders/ \( -name com.apple.dock.iconcache -or -name com.apple.iconservices \) -exec rm -rfv {} \;
    • /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

    Then restart.


  • @CedricBonnier  I'don't know this commands to fix icon :( 

    Could you help me ? 


  • edited September 2017

    @CedricBonnier   ?  if you're french, belgian or canadian please use french :) 

  • hello @CedricBonnier 5 five days ago I've installed Mac OS 10.13 High Sierra. 

    I'retrieved the launch icon in Desktop and Dock Bar. The form and colours was changed. 

    Now I've some problems to execute and import .mov files into HitfilmExpress. 
    Is that Hitfilm Express can be installed and run correctly on Mac Os 10.13 High Sierra ?

    May be not see your page https://hitfilm.com/express/specs#requirements ;

Sign in to comment