Can't access drop down lists in HitFilm 4 with Auto-Hide Taskbar enabled

Love Hitfilm4Pro, but I'm having a bit of an issue.  If HF4P is in full screen mode, I cannot select any of the drop downs.  If I switch to windowed mode the drop downs work as they should and stop working if I switch back to full screen.  I've tried several different screen resolutions (native: 1920x1200), but that did not make any difference.

  • Windows 10
  • SABERTOOTH X79 (Intel X79),Intel Core i7 3930K, 32GB RAM
  • NVIDIA GeForce GTX 680 2GB with latest drivers

Thanks in advance!


  • First thing to check is whether the toolbar is set to auto hide. If so, turning it off may be the fix for now. I had this same issue yesterday, and that's all it took. Thanks again to Axel who suggested the fix. 

  • Thanks, that work around did the trick.

  • Thanks for that tip!! I have the same issue but wish I didn't have to modify my toolbar. 

  • Hi Guys,

    We are working on a fix for the Auto Hide Taskbar problem, it's sadly not an easy thing to fix though. But you will be notified of any future updates.


  • I have full faith!

  • @BriRedd in the meantime if you want to use the auto hide taskbar, you can restore down HitFilm window and manually resize it to cover the screen. As long as you don't click the maximize button, HitFilm should behave as expected.

  • Just downloaded and installed the update, still having issues.

    Where before if I had my auto-hide taskbar disabled I was able to access drop down menus even when Hitfilm was maxmized.

    Now, I can't access drop down menus unless Hitfilm is not maximized (auto-hide Taskbar disabled).

  • edited December 2015

    @BriRedd what version of Windows are you running? If you restore down then maximize again you can't do new > composite shot in the media panel?

    If you click the logo at the top left, what version of HitFilm are you running?

  • edited December 2015

    Hi and thanks @CedricBonnier

    I should have included this information in the earlier post.

    Windows 7 Home Premium - Service Pack 1 - 64 bit
    i7 @ 1.73GHz
    8 GB Ram
    AMD Radeon HD 5700 Series / 1GB 

    All drivers are up to date.

    Hitfilm version: 4.0.4803.28705

    With Hide-Taskbar disabled and Hitfilm maximized:
    1) I can not access drop down menus including 'new>composite shot' or  'import'  in the media panel nor 'File" from the top menu bar. I did restore down and maximized without affect. When not maximized all drop downs work.

    2) When maximized, Hitfilm will  cover the taskbar (not hidden) and forces me to use the Windows key to bring it forward.

    3) Hitfilm will not minimize to the taskbar when the Hitfilm icon in the taskbar is clicked. This happens regardless of Hitfilm being maximized or not.

    I hope this helps, let me know if you need addition information. I still have faith , these things take time.

  • Ok, may I ask what your screen setup is? Have you got a dual screen? If so which one is your primary screen? What resolution are you running on (for each screen)? Is your taskbar at the bottom of your screen?

    I have never seen HitFilm not being able to be minimised but we might have missed something.


  • Laptop - single screen - 1366 x 768
    Taskbar at the bottom of screen

  • Hi @BriRedd, I've just tried on a laptop running Windows 8 and everything seems to be working fine. I'll see if I can find an old laptop to install Windows 7 on.

    In the meantime if you manually resize the window to something slightly smaller than your screen does it solve your issue?

  • edited December 2015

    Yes, if I minimize the window but stretch it to fill the screen Hitfilm menus work as they should. 

    As soundly as my install of Windows 7 has been perhaps it's time to make the upgrade. The Windows 10 upgrade reminder keeps popping up, maybe it's a sign!

    Thank you, @CedricBonnier for looking into this. The staff of Hitfilm is a big reason I made the investment. It may not be a perfect program but I see that everyone is working towards that goal.

  • Same issue in windows 10 btw which I posted in another thread.

  • Same issue with Hitfilm 4 drop down menus not working, but I get it regardless of auto-hide. I'm on Windows 7 x64.

  • I should also mention that I DIDN'T have this problem with Hitfilm 3, it only appeared when I upgraded.

  • Hi @skitchy, could you please tell us what resolution your screen is running at? We've fixed an issue internally for screens running at 1366 x 768 but I'd like to confirm that it'll work for everyone before pushing the next update.

  • edited December 2015

    @CedricBonnier Just to add to the data set. 

    Using HF4P Demo on a dual monitor setup, running HF4P (first release, not the #1 update) on the lower monitor with a physical resolution of 1366x768, but with the resolution set in  Windows to 1600x900 (I'd rather have more, albeit smaller on it, even if it's a bit softer through being rescaled) and an upper monitor with  1920 x1200 on it, I also get the missing dropdown menus (RGB, Options etc.) when using the 'Classic', 'Compositing' or 'Editing' single screen layouts.

    The thing is: they're not missing; they're on the bottom of the upper monitor if I only have a single screen layout with Hitfilm on the lower one. This is whether or not Hitfilm is full screen or not full screen and stretched to be a few pixels in from the edges (the suggested fix). The only thing that works is making it small enough that the top is far enough down that the menus start to appear at the top of the lower monitor. They never straddle the two, although the editor itself can.

    When I float the video container to the upper monitor and make that full screen (My preferred layout), the dropdowns are where they should be on that top monitor.

    And I just checked and it does exactly the same in HF3P as well. I usually use two monitors and only spotted this when setting it to one to take some screenshots to illustrate something.

    Oops, nearly forgot: Windows 7, NVidia Geforce GTX 580

  • @Palacono I don't think it is possible to set a screen resolution to something bigger than what the screen supports. You can set it smaller but not bigger.

    Could you install update 1 (you can download the updates even if you use the demo) and do a screenshot of your entire desktop after you pressed that menu? Click on the arrow next to the import button or on the new button. HitFilm should not be covering the entire screen. If you do not wish to post it here, send it to me directly on the forums.

    Something else you could try: with the viewer panel maximized on your top screen, can you access all the menus, like the zoom level, the options, the rendering options etc.?

  • edited December 2015

    @CedricBonnier Sure you can have the Windows resolution set higher than the physical resolution of the monitor. It's just rescaled to fit.

    Benq G950 specs:

    Resolution (max.) 1366x768


    With the Windows resolution @1600x900 it fits more on, but it's a little softer and all text is smaller. It can't go higher as monitor says 'Out of Range' - but swapping between the two is definitely different. Works everywhere: Hitfilm, Browser, even the desktop background image changes  - see images below.

    Haven't downloaded the update - HF3P suits me for now, but here's some screenshots showing the menus on HF4P release version.

    Ditto on HF3P BTW, so not sure why people report it as a new thing.

    Lower screen (check the size, it's 1600x900) either full screen or not, pops the menus on bottom of the upper monitor. With that video window floated on to the top Monitor (1920x1200) the menus are correct.

    The "Import > " menu works fine all the time on both programs.

  • @Palacono Being able to set the desktop resolution higher than the physical resolution of the display is not a universal option and even when it can be done it can take different forms. The higher resolution can be scaled to fit as in your case or a user can only see as much of the desktop as the physical resolution allows at one time having to scroll to see the rest like in a game. 

  • edited December 2015

    @Alladin4D, OK, how that 'feature' works (or doesn't for some, I assume you're implying) is a side issue. Could be Windows being clever, could be the Graphics card telling fibs to Windows, but it  doesn't change how the menus work.

    Even when I set the lower monitor to its physical resolution of 1366 x768, both Hitfilms still put the menus at the bottom of the upper monitor.

  • @Palacono ok, after investigating a bit more I think I understand what is going on. Your issue is different than the others here. A workaround for this is to change your screen layout to put your secondary screen beside your primary screen. Another workaround if you want to use the default layout is to put HitFilm on your top screen, menus should all work as expected there.

    Or you could just carry on using HitFilm as you were until now, with the viewer on your secondary screen, which works as well :)

  • @CedricBonnier Yes, if I put Hitfilm on the top screen rather than the bottom one, the menus work.  But that screen is a different size, so which change makes them work again? Is Size or Location the problem when they don't?

    I'm not going to resize my top screen to 1366x768 and check if it's resolution because Windows will scramble my desktop icons to make them all fit and I've got quite a lot, so I'd rather they stayed where they were. :)

    As a fix: I don't want to tell Windows the secondary screen is next to the primary one because it isn't: it's below it. and the mouse wouldn't move properly.  As it is I can straddle the two with very tall documents, etc.

    Top screen is Windows Screen 1 (icons, desktop, taskbar etc.), lower screen is Screen 2, but I usually run Hitfilm on the lower one (2) and the  Viewer, full sized on the top (1). Menus work fine then. But if I choose to use Hitfilm in a Single Screen layout on the lower screen, they don't.  As I said previously: I only found this when trying to take (smaller) screen shots of (other) Hitfilm bugs.

    It possible that if I only had one screen, the resolution was 1366x768 (or 1600x900) and Hitfilm was on it: the menus wouldn't work properly. While the rest of my layout might be unique, that last is potentially similar to others on a laptop with a single screen.

    Anyway, enough data points. Best of luck.

  • The issue has nothing to do with the screen resolution, it's because the screens are stacked vertically, menus won't work properly if you use HitFilm on the bottom screen. As it works for you most of the time but when you use HitFilm on a single screen, I would suggest that when you do so, move HitFilm to your top screen and then everything should work. If you want a smaller window just resize it down.

    I'm not sure I am going to be able to fix that, it is an issue with the windowing framework we use and it feels like it's one of those that are hard to fix and incredibly time consuming. Besides, this issue has been there since HitFilm 1, there are ways to work around it and you are the first one that reported it since 2011...

  • @CedricBonnier Yeah, I get that a lot. "You're the first one to spot that!"

    I generally ask if there is a prize because there is little-to-no chance that it'll get fixed.   Just call me "Edge Case Palacono"

  • CedricBonnier To answer your question from a few posts back, I'm running at 1360x768. Thanks for responding.

  • @skitchy ok, in that case just wait for next update, it'll get fixed then

  • Are the trial downloads updated? I can't use hf4 on my laptop yet.
    Works on the desktop though.

  • Nope. Trial and Pro are the same code and download. 

    I don't remember if it was @CedricBonnier or @Ady who said it, but the dev team is locking in some bug fixes (this issue and a Projection issue that I know of), but, being Holiday season to not expect the next update until January. 

Sign In or Register to comment.