My videos are stuttering

edited November 2015 in Express Support

So I have the Express version. I edit long gaming videos. Nothing serious. Just adding an intro. The video is 30 minutes long. I don't know if it is from my computer (although I am pretty sure it isn't, because I have a powerful gaming PC) or if it is from HitFilm express. If you have dealt with similar problems I am open to suggestions.

Comments

  • I have experienced this. The only thing that seems to help some what is to right click the video clip on the editor timeline and select the option to make a proxy from that clip. It helps but the make proxy feature is a hit and miss as it works great sometimes and sometimes it doesn't.  On a 30 second clip it might even stall or crash from my experience and I have a decent CPU. I hope this helps. 

  • Proxy is basically rendering your clip "in the background"

  • Supercole

    Also check that the frame rates matches the footage with in your comp :) 

  • If you are editing gaming videos are you having audio drift? If so, the chances are your screen recording was encoded at a variable framerate, which Hitfilm doesn't like. The solution to this is to use other free software like Handbrake, VirtualDub or Mpeg Streamclip to convert your footage to a constant framerate first. 

    If by stuttering, you mean choppy playback and slow response when moving the playhead, well.... Your recordings are probably h.264 encoded mp4 files, and any NLE will slow down when dealing with mp4 (Although Hitfilm is worse with it than some others). 

    H.264 is a "delivery" codec meant to just be played back on a device and not to be used in an editor. The TL/DR explanation is that the way h.264 encodes, if you put your playhead on frame 50, Hitfilm probably has to look at frames 0-49 and 51-299 just to display frame 50,and if you cut frames 0-49 out of the timeline, Hitfilm STILL has to look at frames 0-49 and 51-299 to display that frame 50. This slows things down. A lot. 

    A good, not-too-techie explaination of the difference between editing and delivery codecs is here:

    telestreamblog.telestream.net/2012/04/save-yourself-frustration-use-editing-formats-when-editing-2/

    Again, the solution is to use free software like VirtualDub or Mpeg Streamclip to convert your footage to DNxHD, or another good editing codec. Handbrake (mentioned above) only encodes to h.264.

     

  • So I tried virtual dub, but the video type is not recognized from the programm  and I think I can't convert it.  As for the proxy it did not work for me. The framerates match the video. I think ...

     

  • By default VirtualDub only recognizes AVI files. To open other file types you need to add import plugins. Once added some will work automatically with "Open Video File" but for others like the FFMpeg plugin you'll also have to change the "Files of type" to match (i.e. "FFMpeg supported files") in the file open dialog.

    There's links to most common import plugins here:

    http://www.videohelp.com/software/Virtualdub

    I would make sure to get the QuickTime plugin by fcchandler and the FFMpeg Input Driver but there's also an AIO installer that has most of the available import plugins and filters.

    Also by default VirtuaDub only exports to AVI so you should make sure you have a good AVI intermediate codec installed like Cineform or MagicYUV. There's a list covering the pros and cons of many intermediates here:

    The Intermediate Codec Thread

    Since you're dealing with game cap footage odds are you're dealing with a variable frame rate so to fix that you'll need to set a frame rate under the Video menu item (Video-->Frame Rate...). Under Frame rate conversion tick "Convert to fps:" and enter your target frame rate which I'm guessing is 60 fps for you.

    Another alternative that Triem23 mentioned is Mpeg Streamclip which if it accepts your footage will let you export to Avid DNx. To get to the DNx options with Streamclip you have to select the "Export to Other Formats" option under the file menu, make sure compression is set to QuickTime Movie and then click the options button and finally the Settings button under Video. Now you can select DNx as the codec and set a target frame rate.  

Sign In or Register to comment.